Daemon Power

The NetBSD Packages Collection: devel/py-pyobjc

Brief description of the package:
Bridge between Python and Objective-C

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://pythonhosted.org/pyobjc/.

Please note that this package has a mit license.

The package is located in the "devel/py-pyobjc" directory. The current source version of the package is "py37-pyobjc-6.1". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for devel/py-pyobjc :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: py37-pyobjc-core>=6.1 py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7 libffi>=1.20 cwrappers>=20150314 libuuid>=2.18 openssl>=1.1.1 libffi>=3.3nb1 openssl>=1.1.1dnb2 readline>=2.2 readline>=6.0 python37>=3.7.0 python37>=3.7.7 py37-pyobjc-framework-AVFoundation>=6.1 py37-pyobjc-framework-Cocoa>=6.1 py37-pyobjc-framework-Quartz>=6.1 py37-pyobjc-framework-AVKit>=6.1 py37-pyobjc-framework-Accounts>=6.1 py37-pyobjc-framework-AddressBook>=6.1 py37-pyobjc-framework-AppleScriptKit>=6.1 py37-pyobjc-framework-AppleScriptObjC>=6.1 py37-pyobjc-framework-ApplicationServices>=6.1 py37-pyobjc-framework-Automator>=6.1 py37-pyobjc-framework-CFNetwork>=6.1 py37-pyobjc-framework-CalendarStore>=6.1 py37-pyobjc-framework-CloudKit>=6.1 py37-pyobjc-framework-CoreData>=6.1 py37-pyobjc-framework-CoreLocation>=6.1 py37-pyobjc-framework-Collaboration>=6.1 py37-pyobjc-framework-ColorSync>=6.1 py37-pyobjc-framework-Contacts>=6.1 py37-pyobjc-framework-ContactsUI>=6.1 py37-pyobjc-framework-CoreBluetooth>=6.1 py37-pyobjc-framework-CoreML>=6.1 py37-pyobjc-framework-CoreServices>=6.1 py37-pyobjc-framework-FSEvents>=6.1 py37-pyobjc-framework-CoreSpotlight>=6.1 py37-pyobjc-framework-CoreText>=6.1 py37-pyobjc-framework-CoreWLAN>=6.1 py37-pyobjc-framework-CryptoTokenKit>=6.1 py37-pyobjc-framework-DictionaryServices>=6.1 py37-pyobjc-framework-DiskArbitration>=6.1 py37-pyobjc-framework-EventKit>=6.1 py37-pyobjc-framework-ExceptionHandling>=6.1 py37-pyobjc-framework-ExternalAccessory>=6.1 py37-pyobjc-framework-FinderSync>=6.1 py37-pyobjc-framework-GameCenter>=6.1 py37-pyobjc-framework-GameController>=6.1 py37-pyobjc-framework-GameKit>=6.1 py37-pyobjc-framework-GameplayKit>=6.1 py37-pyobjc-framework-SpriteKit>=6.1 py37-pyobjc-framework-IOSurface>=6.1 py37-pyobjc-framework-ImageCaptureCore>=6.1 py37-pyobjc-framework-InputMethodKit>=6.1 py37-pyobjc-framework-InstallerPlugins>=6.1 py37-pyobjc-framework-InstantMessage>=6.1 py37-pyobjc-framework-Intents>=6.1 py37-pyobjc-framework-LatentSemanticMapping>=6.1 py37-pyobjc-framework-LaunchServices>=6.1 py37-pyobjc-framework-LocalAuthentication>=6.1 py37-pyobjc-framework-MapKit>=6.1 py37-pyobjc-framework-MediaAccessibility>=6.1 py37-pyobjc-framework-MediaLibrary>=6.1 py37-pyobjc-framework-MediaPlayer>=6.1 py37-pyobjc-framework-MetalKit>=6.1 py37-pyobjc-framework-ModelIO>=6.1 py37-pyobjc-framework-MultipeerConnectivity>=6.1 py37-pyobjc-framework-NetFS>=6.1 py37-pyobjc-framework-NetworkExtension>=6.1 py37-pyobjc-framework-NotificationCenter>=6.1 py37-pyobjc-framework-OpenDirectory>=6.1 py37-pyobjc-framework-Photos>=6.1 py37-pyobjc-framework-PhotosUI>=6.1 py37-pyobjc-framework-PreferencePanes>=6.1 py37-pyobjc-framework-PubSub>=6.1 py37-pyobjc-framework-QTKit>=6.1 py37-pyobjc-framework-SafariServices>=6.1 py37-pyobjc-framework-SceneKit>=6.1 py37-pyobjc-framework-ScreenSaver>=6.1 py37-pyobjc-framework-ScriptingBridge>=6.1 py37-pyobjc-framework-SearchKit>=6.1 py37-pyobjc-framework-Security>=6.1 py37-pyobjc-framework-SecurityInterface>=6.1 py37-pyobjc-framework-ServiceManagement>=6.1 py37-pyobjc-framework-Social>=6.1 py37-pyobjc-framework-StoreKit>=6.1 py37-pyobjc-framework-SyncServices>=6.1 py37-pyobjc-framework-SystemConfiguration>=6.1 py37-pyobjc-framework-Vision>=6.1 py37-pyobjc-framework-WebKit>=6.1 py37-pyobjc-framework-iTunesLibrary>=6.1 py37-pyobjc-framework-libdispatch>=6.1 .

This package requires the following package(s) to run: py37-pyobjc-core>=6.1 py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7 libffi>=1.20 libuuid>=2.18 openssl>=1.1.1 libffi>=3.3nb1 openssl>=1.1.1dnb2 python37>=3.7.0 python37>=3.7.7 py37-pyobjc-framework-AVFoundation>=6.1 py37-pyobjc-framework-Cocoa>=6.1 py37-pyobjc-framework-Quartz>=6.1 py37-pyobjc-framework-AVKit>=6.1 py37-pyobjc-framework-Accounts>=6.1 py37-pyobjc-framework-AddressBook>=6.1 py37-pyobjc-framework-AppleScriptKit>=6.1 py37-pyobjc-framework-AppleScriptObjC>=6.1 py37-pyobjc-framework-ApplicationServices>=6.1 py37-pyobjc-framework-Automator>=6.1 py37-pyobjc-framework-CFNetwork>=6.1 py37-pyobjc-framework-CalendarStore>=6.1 py37-pyobjc-framework-CloudKit>=6.1 py37-pyobjc-framework-CoreData>=6.1 py37-pyobjc-framework-CoreLocation>=6.1 py37-pyobjc-framework-Collaboration>=6.1 py37-pyobjc-framework-ColorSync>=6.1 py37-pyobjc-framework-Contacts>=6.1 py37-pyobjc-framework-ContactsUI>=6.1 py37-pyobjc-framework-CoreBluetooth>=6.1 py37-pyobjc-framework-CoreML>=6.1 py37-pyobjc-framework-CoreServices>=6.1 py37-pyobjc-framework-FSEvents>=6.1 py37-pyobjc-framework-CoreSpotlight>=6.1 py37-pyobjc-framework-CoreText>=6.1 py37-pyobjc-framework-CoreWLAN>=6.1 py37-pyobjc-framework-CryptoTokenKit>=6.1 py37-pyobjc-framework-DictionaryServices>=6.1 py37-pyobjc-framework-DiskArbitration>=6.1 py37-pyobjc-framework-EventKit>=6.1 py37-pyobjc-framework-ExceptionHandling>=6.1 py37-pyobjc-framework-ExternalAccessory>=6.1 py37-pyobjc-framework-FinderSync>=6.1 py37-pyobjc-framework-GameCenter>=6.1 py37-pyobjc-framework-GameController>=6.1 py37-pyobjc-framework-GameKit>=6.1 py37-pyobjc-framework-GameplayKit>=6.1 py37-pyobjc-framework-SpriteKit>=6.1 py37-pyobjc-framework-IOSurface>=6.1 py37-pyobjc-framework-ImageCaptureCore>=6.1 py37-pyobjc-framework-InputMethodKit>=6.1 py37-pyobjc-framework-InstallerPlugins>=6.1 py37-pyobjc-framework-InstantMessage>=6.1 py37-pyobjc-framework-Intents>=6.1 py37-pyobjc-framework-LatentSemanticMapping>=6.1 py37-pyobjc-framework-LaunchServices>=6.1 py37-pyobjc-framework-LocalAuthentication>=6.1 py37-pyobjc-framework-MapKit>=6.1 py37-pyobjc-framework-MediaAccessibility>=6.1 py37-pyobjc-framework-MediaLibrary>=6.1 py37-pyobjc-framework-MediaPlayer>=6.1 py37-pyobjc-framework-MetalKit>=6.1 py37-pyobjc-framework-ModelIO>=6.1 py37-pyobjc-framework-MultipeerConnectivity>=6.1 py37-pyobjc-framework-NetFS>=6.1 py37-pyobjc-framework-NetworkExtension>=6.1 py37-pyobjc-framework-NotificationCenter>=6.1 py37-pyobjc-framework-OpenDirectory>=6.1 py37-pyobjc-framework-Photos>=6.1 py37-pyobjc-framework-PhotosUI>=6.1 py37-pyobjc-framework-PreferencePanes>=6.1 py37-pyobjc-framework-PubSub>=6.1 py37-pyobjc-framework-QTKit>=6.1 py37-pyobjc-framework-SafariServices>=6.1 py37-pyobjc-framework-SceneKit>=6.1 py37-pyobjc-framework-ScreenSaver>=6.1 py37-pyobjc-framework-ScriptingBridge>=6.1 py37-pyobjc-framework-SearchKit>=6.1 py37-pyobjc-framework-Security>=6.1 py37-pyobjc-framework-SecurityInterface>=6.1 py37-pyobjc-framework-ServiceManagement>=6.1 py37-pyobjc-framework-Social>=6.1 py37-pyobjc-framework-StoreKit>=6.1 py37-pyobjc-framework-SyncServices>=6.1 py37-pyobjc-framework-SystemConfiguration>=6.1 py37-pyobjc-framework-Vision>=6.1 py37-pyobjc-framework-WebKit>=6.1 py37-pyobjc-framework-iTunesLibrary>=6.1 py37-pyobjc-framework-libdispatch>=6.1 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
none

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]