devel/py-pylru - The NetBSD Packages Collection

Implementation of a least recently used (LRU) cache

Pylru implements a true LRU cache along with several support classes. The cache
is efficient and written in pure Python. It works with Python 2.6+ including
the 3.x series. Basic operations (lookup, insert, delete) all run in a constant
amount of time. Pylru provides a cache class with a simple dict interface. It
also provides classes to wrap any object that has a dict interface with a
cache. Both write-through and write-back semantics are supported. Pylru also
provides classes to wrap functions in a similar way, including a function
decorator.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/py-setuptools lang/python38 lang/python38

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfpy27-pylru-1.2.0.tgz
NetBSD 8.0earmv7hfpy36-pylru-1.2.0.tgz
NetBSD 8.0earmv7hfpy37-pylru-1.2.0.tgz
NetBSD 8.0earmv7hfpy38-pylru-1.2.0.tgz
NetBSD 8.0earmv7hfpy39-pylru-1.2.0.tgz
NetBSD 8.0i386py27-pylru-1.2.0.tgz
NetBSD 8.0i386py36-pylru-1.2.0.tgz
NetBSD 8.0i386py37-pylru-1.2.0.tgz
NetBSD 8.0i386py38-pylru-1.2.0.tgz
NetBSD 8.0i386py39-pylru-1.2.0.tgz
NetBSD 8.0powerpcpy27-pylru-1.2.0.tgz
NetBSD 8.0powerpcpy36-pylru-1.2.0.tgz
NetBSD 8.0powerpcpy37-pylru-1.2.0.tgz
NetBSD 8.0powerpcpy38-pylru-1.2.0.tgz
NetBSD 8.0powerpcpy39-pylru-1.2.0.tgz
NetBSD 8.0powerpcpy27-pylru-1.2.0.tgz
NetBSD 8.0powerpcpy36-pylru-1.2.0.tgz
NetBSD 8.0powerpcpy37-pylru-1.2.0.tgz
NetBSD 8.0powerpcpy38-pylru-1.2.0.tgz
NetBSD 8.0powerpcpy39-pylru-1.2.0.tgz
NetBSD 8.0x86_64py27-pylru-1.2.0.tgz
NetBSD 8.0x86_64py36-pylru-1.2.0.tgz
NetBSD 8.0x86_64py37-pylru-1.2.0.tgz
NetBSD 8.0x86_64py38-pylru-1.2.0.tgz
NetBSD 8.0x86_64py39-pylru-1.2.0.tgz
NetBSD 9.0aarch64py27-pylru-1.2.0.tgz
NetBSD 9.0aarch64py36-pylru-1.2.0.tgz
NetBSD 9.0aarch64py37-pylru-1.2.0.tgz
NetBSD 9.0aarch64py38-pylru-1.2.0.tgz
NetBSD 9.0aarch64py39-pylru-1.2.0.tgz
NetBSD 9.0alphapy27-pylru-1.2.0.tgz
NetBSD 9.0alphapy36-pylru-1.2.0.tgz
NetBSD 9.0alphapy37-pylru-1.2.0.tgz
NetBSD 9.0alphapy38-pylru-1.2.0.tgz
NetBSD 9.0alphapy39-pylru-1.2.0.tgz
NetBSD 9.0earmpy36-pylru-1.2.0.tgz
NetBSD 9.0earmpy37-pylru-1.2.0.tgz
NetBSD 9.0earmpy38-pylru-1.2.0.tgz
NetBSD 9.0earmv6hfpy27-pylru-1.2.0.tgz
NetBSD 9.0earmv6hfpy36-pylru-1.2.0.tgz
NetBSD 9.0earmv6hfpy37-pylru-1.2.0.tgz
NetBSD 9.0earmv6hfpy38-pylru-1.2.0.tgz
NetBSD 9.0earmv6hfpy39-pylru-1.2.0.tgz
NetBSD 9.0earmv7hfpy27-pylru-1.2.0.tgz
NetBSD 9.0earmv7hfpy36-pylru-1.2.0.tgz
NetBSD 9.0earmv7hfpy37-pylru-1.2.0.tgz
NetBSD 9.0earmv7hfpy38-pylru-1.2.0.tgz
NetBSD 9.0earmv7hfpy39-pylru-1.2.0.tgz
NetBSD 9.0earmv7hfpy27-pylru-1.2.0.tgz
NetBSD 9.0earmv7hfpy36-pylru-1.2.0.tgz
NetBSD 9.0earmv7hfpy37-pylru-1.2.0.tgz
NetBSD 9.0earmv7hfpy38-pylru-1.2.0.tgz
NetBSD 9.0earmv7hfpy39-pylru-1.2.0.tgz
NetBSD 9.0i386py27-pylru-1.2.0.tgz
NetBSD 9.0i386py36-pylru-1.2.0.tgz
NetBSD 9.0i386py37-pylru-1.2.0.tgz
NetBSD 9.0i386py38-pylru-1.2.0.tgz
NetBSD 9.0i386py39-pylru-1.2.0.tgz
NetBSD 9.0mips64ebpy27-pylru-1.2.0.tgz
NetBSD 9.0mips64ebpy36-pylru-1.2.0.tgz
NetBSD 9.0mips64ebpy37-pylru-1.2.0.tgz
NetBSD 9.0mips64ebpy38-pylru-1.2.0.tgz
NetBSD 9.0mips64ebpy39-pylru-1.2.0.tgz
NetBSD 9.0powerpcpy27-pylru-1.2.0.tgz
NetBSD 9.0powerpcpy36-pylru-1.2.0.tgz
NetBSD 9.0powerpcpy37-pylru-1.2.0.tgz
NetBSD 9.0powerpcpy38-pylru-1.2.0.tgz
NetBSD 9.0powerpcpy39-pylru-1.2.0.tgz
NetBSD 9.0powerpcpy27-pylru-1.2.0.tgz
NetBSD 9.0powerpcpy36-pylru-1.2.0.tgz
NetBSD 9.0powerpcpy37-pylru-1.2.0.tgz
NetBSD 9.0powerpcpy38-pylru-1.2.0.tgz
NetBSD 9.0powerpcpy39-pylru-1.2.0.tgz
NetBSD 9.0sh3elpy36-pylru-1.2.0.tgz
NetBSD 9.0sh3elpy37-pylru-1.2.0.tgz
NetBSD 9.0sh3elpy38-pylru-1.2.0.tgz
NetBSD 9.0sparc64py27-pylru-1.2.0.tgz
NetBSD 9.0sparc64py36-pylru-1.2.0.tgz
NetBSD 9.0sparc64py37-pylru-1.2.0.tgz
NetBSD 9.0sparc64py38-pylru-1.2.0.tgz
NetBSD 9.0sparc64py39-pylru-1.2.0.tgz
NetBSD 9.0sparcpy27-pylru-1.2.0.tgz
NetBSD 9.0sparcpy36-pylru-1.2.0.tgz
NetBSD 9.0sparcpy37-pylru-1.2.0.tgz
NetBSD 9.0sparcpy38-pylru-1.2.0.tgz
NetBSD 9.0sparcpy39-pylru-1.2.0.tgz
NetBSD 9.0x86_64py27-pylru-1.2.0.tgz
NetBSD 9.0x86_64py36-pylru-1.2.0.tgz
NetBSD 9.0x86_64py37-pylru-1.2.0.tgz
NetBSD 9.0x86_64py38-pylru-1.2.0.tgz
NetBSD 9.0x86_64py39-pylru-1.2.0.tgz
NetBSD 9.0x86_64py27-pylru-1.2.0.tgz
NetBSD 9.0x86_64py36-pylru-1.2.0.tgz
NetBSD 9.0x86_64py37-pylru-1.2.0.tgz
NetBSD 9.0x86_64py38-pylru-1.2.0.tgz
NetBSD 9.0x86_64py39-pylru-1.2.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.