devel/py-cwcwidth - The NetBSD Packages Collection

Python bindings for wc(s)width

cwcwidth provides Python bindings for wcwidth and wcswidth functions defined in
POSIX.1-2001 and POSIX.1-2008 based on Cython. These functions compute the
printable length of a unicode character/string on a terminal. The module
provides the same functions as wcwidth and its behavior is compatible.

Build dependencies

devel/py-cython pkgtools/cwrappers

Runtime dependencies

devel/py-setuptools lang/python38 lang/python38

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfpy36-cwcwidth-0.1.4.tgz
NetBSD 8.0earmv7hfpy37-cwcwidth-0.1.4.tgz
NetBSD 8.0earmv7hfpy38-cwcwidth-0.1.4.tgz
NetBSD 8.0earmv7hfpy39-cwcwidth-0.1.4.tgz
NetBSD 8.0i386py36-cwcwidth-0.1.4.tgz
NetBSD 8.0i386py37-cwcwidth-0.1.4.tgz
NetBSD 8.0i386py38-cwcwidth-0.1.4.tgz
NetBSD 8.0i386py39-cwcwidth-0.1.4.tgz
NetBSD 8.0powerpcpy36-cwcwidth-0.1.4.tgz
NetBSD 8.0powerpcpy37-cwcwidth-0.1.4.tgz
NetBSD 8.0powerpcpy38-cwcwidth-0.1.4.tgz
NetBSD 8.0powerpcpy39-cwcwidth-0.1.4.tgz
NetBSD 8.0powerpcpy36-cwcwidth-0.1.4.tgz
NetBSD 8.0powerpcpy37-cwcwidth-0.1.4.tgz
NetBSD 8.0powerpcpy38-cwcwidth-0.1.4.tgz
NetBSD 8.0powerpcpy39-cwcwidth-0.1.4.tgz
NetBSD 8.0x86_64py36-cwcwidth-0.1.4.tgz
NetBSD 8.0x86_64py37-cwcwidth-0.1.4.tgz
NetBSD 8.0x86_64py38-cwcwidth-0.1.4.tgz
NetBSD 8.0x86_64py39-cwcwidth-0.1.4.tgz
NetBSD 9.0aarch64py36-cwcwidth-0.1.4.tgz
NetBSD 9.0aarch64py37-cwcwidth-0.1.4.tgz
NetBSD 9.0aarch64py38-cwcwidth-0.1.4.tgz
NetBSD 9.0aarch64py39-cwcwidth-0.1.4.tgz
NetBSD 9.0alphapy36-cwcwidth-0.1.4.tgz
NetBSD 9.0alphapy37-cwcwidth-0.1.4.tgz
NetBSD 9.0alphapy38-cwcwidth-0.1.4.tgz
NetBSD 9.0alphapy39-cwcwidth-0.1.4.tgz
NetBSD 9.0earmpy36-cwcwidth-0.1.4.tgz
NetBSD 9.0earmpy37-cwcwidth-0.1.4.tgz
NetBSD 9.0earmpy38-cwcwidth-0.1.4.tgz
NetBSD 9.0earmpy39-cwcwidth-0.1.4.tgz
NetBSD 9.0earmv6hfpy36-cwcwidth-0.1.4.tgz
NetBSD 9.0earmv6hfpy37-cwcwidth-0.1.4.tgz
NetBSD 9.0earmv6hfpy38-cwcwidth-0.1.4.tgz
NetBSD 9.0earmv6hfpy39-cwcwidth-0.1.4.tgz
NetBSD 9.0earmv7hfpy36-cwcwidth-0.1.4.tgz
NetBSD 9.0earmv7hfpy37-cwcwidth-0.1.4.tgz
NetBSD 9.0earmv7hfpy38-cwcwidth-0.1.4.tgz
NetBSD 9.0earmv7hfpy39-cwcwidth-0.1.4.tgz
NetBSD 9.0earmv7hfpy36-cwcwidth-0.1.4.tgz
NetBSD 9.0earmv7hfpy37-cwcwidth-0.1.4.tgz
NetBSD 9.0earmv7hfpy38-cwcwidth-0.1.4.tgz
NetBSD 9.0earmv7hfpy39-cwcwidth-0.1.4.tgz
NetBSD 9.0i386py36-cwcwidth-0.1.4.tgz
NetBSD 9.0i386py37-cwcwidth-0.1.4.tgz
NetBSD 9.0i386py38-cwcwidth-0.1.4.tgz
NetBSD 9.0i386py39-cwcwidth-0.1.4.tgz
NetBSD 9.0mips64ebpy36-cwcwidth-0.1.4.tgz
NetBSD 9.0mips64ebpy37-cwcwidth-0.1.4.tgz
NetBSD 9.0mips64ebpy38-cwcwidth-0.1.4.tgz
NetBSD 9.0mips64ebpy39-cwcwidth-0.1.4.tgz
NetBSD 9.0mipselpy38-cwcwidth-0.1.4.tgz
NetBSD 9.0powerpcpy36-cwcwidth-0.1.4.tgz
NetBSD 9.0powerpcpy37-cwcwidth-0.1.4.tgz
NetBSD 9.0powerpcpy38-cwcwidth-0.1.4.tgz
NetBSD 9.0powerpcpy39-cwcwidth-0.1.4.tgz
NetBSD 9.0powerpcpy36-cwcwidth-0.1.4.tgz
NetBSD 9.0powerpcpy37-cwcwidth-0.1.4.tgz
NetBSD 9.0powerpcpy38-cwcwidth-0.1.4.tgz
NetBSD 9.0powerpcpy39-cwcwidth-0.1.4.tgz
NetBSD 9.0sh3elpy36-cwcwidth-0.1.4.tgz
NetBSD 9.0sh3elpy37-cwcwidth-0.1.4.tgz
NetBSD 9.0sh3elpy38-cwcwidth-0.1.4.tgz
NetBSD 9.0sh3elpy39-cwcwidth-0.1.4.tgz
NetBSD 9.0sparc64py36-cwcwidth-0.1.4.tgz
NetBSD 9.0sparc64py37-cwcwidth-0.1.4.tgz
NetBSD 9.0sparc64py38-cwcwidth-0.1.4.tgz
NetBSD 9.0sparc64py39-cwcwidth-0.1.4.tgz
NetBSD 9.0sparcpy36-cwcwidth-0.1.4.tgz
NetBSD 9.0sparcpy37-cwcwidth-0.1.4.tgz
NetBSD 9.0sparcpy38-cwcwidth-0.1.4.tgz
NetBSD 9.0sparcpy39-cwcwidth-0.1.4.tgz
NetBSD 9.0x86_64py36-cwcwidth-0.1.4.tgz
NetBSD 9.0x86_64py37-cwcwidth-0.1.4.tgz
NetBSD 9.0x86_64py38-cwcwidth-0.1.4.tgz
NetBSD 9.0x86_64py39-cwcwidth-0.1.4.tgz
NetBSD 9.0x86_64py36-cwcwidth-0.1.4.tgz
NetBSD 9.0x86_64py37-cwcwidth-0.1.4.tgz
NetBSD 9.0x86_64py38-cwcwidth-0.1.4.tgz
NetBSD 9.0x86_64py39-cwcwidth-0.1.4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.