devel/pcre2 - The NetBSD Packages Collection

Perl Compatible Regular Expressions library (major version 2)

PCRE2 is a re-working of the original PCRE library to provide an entirely new
API.

PCRE2 is written in C, and it has its own API. There are three sets of
functions, one for the 8-bit library, which processes strings of bytes, one for
the 16-bit library, which processes strings of 16-bit values, and one for the
32-bit library, which processes strings of 32-bit values. There are no C++
wrappers.

Build dependencies

pkgtools/cwrappers devel/libtool-base

Runtime dependencies

(none)

Available binary packages

aarch64:pcre2-10.35nb1.tgz(NetBSD 9.0)
aarch64:pcre2-10.35nb1.tgz(NetBSD 9.0)
aarch64:pcre2-10.36.tgz(NetBSD 9.0)
alpha:pcre2-10.36.tgz(NetBSD 9.0)
alpha:pcre2-10.35nb1.tgz(NetBSD 9.0)
alpha:pcre2-10.35nb1.tgz(NetBSD 9.0)
earm:pcre2-10.35nb1.tgz(NetBSD 9.0)
earm:pcre2-10.34.tgz(NetBSD 9.0)
earm:pcre2-10.36.tgz(NetBSD 9.0)
earmv6hf:pcre2-10.36.tgz(NetBSD 9.0)
earmv6hf:pcre2-10.35nb1.tgz(NetBSD 9.0)
earmv6hf:pcre2-10.35nb1.tgz(NetBSD 9.0)
earmv6hf:pcre2-10.36.tgz(NetBSD 9.0)
earmv7hf:pcre2-10.36.tgz(NetBSD 8.0)
earmv7hf:pcre2-10.34.tgz(NetBSD 8.0)
earmv7hf:pcre2-10.35nb1.tgz(NetBSD 8.0)
earmv7hf:pcre2-10.35nb1.tgz(NetBSD 8.0)
earmv7hf:pcre2-10.36.tgz(NetBSD 9.0)
earmv7hf:pcre2-10.34.tgz(NetBSD 9.0)
earmv7hf:pcre2-10.35nb1.tgz(NetBSD 9.0)
earmv7hf:pcre2-10.35nb1.tgz(NetBSD 9.0)
earmv7hf:pcre2-10.36.tgz(NetBSD 9.0)
i386:pcre2-10.35nb1.tgz(NetBSD 8.0)
i386:pcre2-10.35nb1.tgz(NetBSD 8.0)
i386:pcre2-10.36.tgz(NetBSD 8.0)
i386:pcre2-10.35nb1.tgz(NetBSD 9.0)
i386:pcre2-10.35nb1.tgz(NetBSD 9.0)
i386:pcre2-10.36.tgz(NetBSD 9.0)
m68k:pcre2-10.35nb1.tgz(NetBSD 9.0)
m68k:pcre2-10.35nb1.tgz(NetBSD 9.0)
m68k:pcre2-10.36.tgz(NetBSD 9.0)
mips64eb:pcre2-10.35nb1.tgz(NetBSD 9.0)
mips64eb:pcre2-10.36.tgz(NetBSD 9.0)
mipsel:pcre2-10.36.tgz(NetBSD 9.0)
powerpc:pcre2-10.35nb1.tgz(NetBSD 8.0)
powerpc:pcre2-10.36.tgz(NetBSD 8.0)
powerpc:pcre2-10.36.tgz(NetBSD 9.0)
powerpc:pcre2-10.35nb1.tgz(NetBSD 9.0)
powerpc:pcre2-10.35nb1.tgz(NetBSD 9.0)
sh3el:pcre2-10.35nb1.tgz(NetBSD 9.0)
sh3el:pcre2-10.36.tgz(NetBSD 9.0)
sparc64:pcre2-10.36.tgz(NetBSD 9.0)
sparc64:pcre2-10.35nb1.tgz(NetBSD 9.0)
sparc64:pcre2-10.35nb1.tgz(NetBSD 9.0)
sparc:pcre2-10.35nb1.tgz(NetBSD 9.0)
sparc:pcre2-10.35nb1.tgz(NetBSD 9.0)
sparc:pcre2-10.36.tgz(NetBSD 9.0)
vax:pcre2-10.36.tgz(NetBSD 9.0)
vax:pcre2-10.35nb1.tgz(NetBSD 9.0)
x86_64:pcre2-10.35nb1.tgz(NetBSD 9.0)
x86_64:pcre2-10.36.tgz(NetBSD 9.0)
x86_64:pcre2-10.36.tgz(NetBSD 9.0)
x86_64:pcre2-10.35nb1.tgz(NetBSD 9.0)
x86_64:pcre2-10.35nb1.tgz(NetBSD 8.0)
x86_64:pcre2-10.35nb1.tgz(NetBSD 8.0)
x86_64:pcre2-10.36.tgz(NetBSD 8.0)
x86_64:pcre2-10.35nb1.tgz(NetBSD 9.0)
x86_64:pcre2-10.35nb1.tgz(NetBSD 9.0)
x86_64:pcre2-10.36.tgz(NetBSD 9.0)
x86_64:pcre2-10.36.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

pcre2-jit
Enable JIT (just-in-time) support in pcre2.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]