devel/p5-pip - The NetBSD Packages Collection

Perl Installation Program

The pip ("Perl Installation Program") console application is used to install
Perl distributions in a wide variety of formats, both from CPAN and from
external third-party locations, while supporting module dependencies that go
across the boundary from third-party to CPAN.

Using pip you can install CPAN modules, arbitrary tarballs from both the
local file-system or across the internet from arbitrary URIs.

Build dependencies

www/p5-LWP-Online devel/p5-Test-Script pkgtools/cwrappers

Runtime dependencies

archivers/p5-Archive-Zip devel/p5-CPAN-Inject devel/p5-File-Which devel/p5-File-pushd devel/p5-PAR-Dist devel/p5-Params-Util www/p5-URI www/p5-libwww lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-pip-1.19nb10.tgz
NetBSD 8.0earmv7hfp5-pip-1.19nb9.tgz
NetBSD 8.0earmv7hfp5-pip-1.19nb10.tgz
NetBSD 8.0i386p5-pip-1.19nb9.tgz
NetBSD 8.0i386p5-pip-1.19nb10.tgz
NetBSD 8.0powerpcp5-pip-1.19nb9.tgz
NetBSD 8.0powerpcp5-pip-1.19nb10.tgz
NetBSD 8.0powerpcp5-pip-1.19nb10.tgz
NetBSD 8.0powerpcp5-pip-1.19nb10.tgz
NetBSD 8.0x86_64p5-pip-1.19nb9.tgz
NetBSD 8.0x86_64p5-pip-1.19nb10.tgz
NetBSD 9.0aarch64p5-pip-1.19nb10.tgz
NetBSD 9.0aarch64p5-pip-1.19nb9.tgz
NetBSD 9.0aarch64p5-pip-1.19nb10.tgz
NetBSD 9.0earmv6hfp5-pip-1.19nb10.tgz
NetBSD 9.0earmv6hfp5-pip-1.19nb9.tgz
NetBSD 9.0earmv6hfp5-pip-1.19nb10.tgz
NetBSD 9.0earmv7hfp5-pip-1.19nb10.tgz
NetBSD 9.0earmv7hfp5-pip-1.19nb9.tgz
NetBSD 9.0earmv7hfp5-pip-1.19nb10.tgz
NetBSD 9.0earmv7hfp5-pip-1.19nb10.tgz
NetBSD 9.0i386p5-pip-1.19nb9.tgz
NetBSD 9.0i386p5-pip-1.19nb10.tgz
NetBSD 9.0i386p5-pip-1.19nb10.tgz
NetBSD 9.0mips64ebp5-pip-1.19nb10.tgz
NetBSD 9.0mips64ebp5-pip-1.19nb10.tgz
NetBSD 9.0powerpcp5-pip-1.19nb9.tgz
NetBSD 9.0powerpcp5-pip-1.19nb10.tgz
NetBSD 9.0sparc64p5-pip-1.19nb10.tgz
NetBSD 9.0sparc64p5-pip-1.19nb10.tgz
NetBSD 9.0x86_64p5-pip-1.19nb10.tgz
NetBSD 9.0x86_64p5-pip-1.19nb10.tgz
NetBSD 9.0x86_64p5-pip-1.19nb9.tgz
NetBSD 9.0x86_64p5-pip-1.19nb10.tgz
NetBSD 9.0x86_64p5-pip-1.19nb10.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.