devel/p5-indirect - The NetBSD Packages Collection

Lexically warn about using the indirect method call syntax

When enabled, this pragma warns about indirect method calls that are
present in your code.

This pragma currently does not warn for core functions (print, say, exec
or system). This may change in the future, or may be added as optional
features that would be enabled by passing options to unimport.

In http://www.shadowcat.co.uk/blog/matt-s-trout/indirect-but-still-fatal,
Matt S. Trout gives an example of an undesirable indirect method call on
a block that can cause a particularly bewildering error.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-indirect-0.39nb2.tgz
NetBSD 8.0earmv7hfp5-indirect-0.39nb1.tgz
NetBSD 8.0earmv7hfp5-indirect-0.39nb2.tgz
NetBSD 8.0i386p5-indirect-0.39nb1.tgz
NetBSD 8.0i386p5-indirect-0.39nb2.tgz
NetBSD 8.0powerpcp5-indirect-0.39nb1.tgz
NetBSD 8.0powerpcp5-indirect-0.39nb2.tgz
NetBSD 8.0powerpcp5-indirect-0.39nb2.tgz
NetBSD 8.0powerpcp5-indirect-0.39nb2.tgz
NetBSD 8.0x86_64p5-indirect-0.39nb1.tgz
NetBSD 8.0x86_64p5-indirect-0.39nb2.tgz
NetBSD 9.0aarch64p5-indirect-0.39nb2.tgz
NetBSD 9.0aarch64p5-indirect-0.39nb1.tgz
NetBSD 9.0aarch64p5-indirect-0.39nb2.tgz
NetBSD 9.0alphap5-indirect-0.39nb2.tgz
NetBSD 9.0alphap5-indirect-0.39nb1.tgz
NetBSD 9.0alphap5-indirect-0.39nb2.tgz
NetBSD 9.0earmp5-indirect-0.39nb1.tgz
NetBSD 9.0earmp5-indirect-0.39nb2.tgz
NetBSD 9.0earmp5-indirect-0.39nb2.tgz
NetBSD 9.0earmv6hfp5-indirect-0.39nb2.tgz
NetBSD 9.0earmv6hfp5-indirect-0.39nb1.tgz
NetBSD 9.0earmv6hfp5-indirect-0.39nb2.tgz
NetBSD 9.0earmv7hfp5-indirect-0.39nb2.tgz
NetBSD 9.0earmv7hfp5-indirect-0.39nb1.tgz
NetBSD 9.0earmv7hfp5-indirect-0.39nb2.tgz
NetBSD 9.0earmv7hfp5-indirect-0.39nb2.tgz
NetBSD 9.0i386p5-indirect-0.39nb1.tgz
NetBSD 9.0i386p5-indirect-0.39nb2.tgz
NetBSD 9.0i386p5-indirect-0.39nb2.tgz
NetBSD 9.0m68kp5-indirect-0.39nb2.tgz
NetBSD 9.0m68kp5-indirect-0.39nb2.tgz
NetBSD 9.0mips64ebp5-indirect-0.39nb2.tgz
NetBSD 9.0mips64ebp5-indirect-0.39nb1.tgz
NetBSD 9.0mips64ebp5-indirect-0.39nb1.tgz
NetBSD 9.0mips64ebp5-indirect-0.39nb1.tgz
NetBSD 9.0mips64ebp5-indirect-0.39nb2.tgz
NetBSD 9.0mipselp5-indirect-0.39nb2.tgz
NetBSD 9.0mipselp5-indirect-0.39nb1.tgz
NetBSD 9.0mipselp5-indirect-0.39nb1.tgz
NetBSD 9.0mipselp5-indirect-0.39nb2.tgz
NetBSD 9.0powerpcp5-indirect-0.39nb2.tgz
NetBSD 9.0powerpcp5-indirect-0.39nb1.tgz
NetBSD 9.0powerpcp5-indirect-0.39nb2.tgz
NetBSD 9.0powerpcp5-indirect-0.39nb2.tgz
NetBSD 9.0sh3elp5-indirect-0.39nb2.tgz
NetBSD 9.0sh3elp5-indirect-0.39nb1.tgz
NetBSD 9.0sh3elp5-indirect-0.39nb1.tgz
NetBSD 9.0sh3elp5-indirect-0.39nb2.tgz
NetBSD 9.0sparc64p5-indirect-0.39nb2.tgz
NetBSD 9.0sparc64p5-indirect-0.39nb1.tgz
NetBSD 9.0sparc64p5-indirect-0.39nb2.tgz
NetBSD 9.0sparcp5-indirect-0.39nb2.tgz
NetBSD 9.0sparcp5-indirect-0.39nb1.tgz
NetBSD 9.0sparcp5-indirect-0.39nb1.tgz
NetBSD 9.0sparcp5-indirect-0.39nb1.tgz
NetBSD 9.0sparcp5-indirect-0.39nb2.tgz
NetBSD 9.0vaxp5-indirect-0.39nb1.tgz
NetBSD 9.0vaxp5-indirect-0.39nb1.tgz
NetBSD 9.0vaxp5-indirect-0.39nb2.tgz
NetBSD 9.0vaxp5-indirect-0.39nb2.tgz
NetBSD 9.0x86_64p5-indirect-0.39nb2.tgz
NetBSD 9.0x86_64p5-indirect-0.39nb2.tgz
NetBSD 9.0x86_64p5-indirect-0.39nb1.tgz
NetBSD 9.0x86_64p5-indirect-0.39nb2.tgz
NetBSD 9.0x86_64p5-indirect-0.39nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.