devel/p5-Wx-Perl-DataWalker - The NetBSD Packages Collection

Shows a relatively simple Perl data structure browser

Wx::Perl::DataWalker implements a Wx::Frame subclass that shows a relatively
simple Perl data structure browser. After opening such a frame and supplying
it with a reference to an essentially arbitrary data structure, it can be
visually browsed by double-clicking references.

Build dependencies

x11/p5-Alien-wxWidgets devel/p5-ExtUtils-XSpp pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools lang/perl5

Runtime dependencies

devel/p5-Class-XSAccessor devel/p5-Devel-Size textproc/p5-YAML-LibYAML x11/p5-Wx lang/perl5 lang/perl5 x11/p5-Wx

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 8.0earmv7hfp5-Wx-Perl-DataWalker-0.02nb46.tgz
NetBSD 8.0earmv7hfp5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 8.0i386p5-Wx-Perl-DataWalker-0.02nb46.tgz
NetBSD 8.0i386p5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 8.0powerpcp5-Wx-Perl-DataWalker-0.02nb46.tgz
NetBSD 8.0powerpcp5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 8.0powerpcp5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 8.0powerpcp5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 8.0x86_64p5-Wx-Perl-DataWalker-0.02nb46.tgz
NetBSD 8.0x86_64p5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 9.0aarch64p5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 9.0aarch64p5-Wx-Perl-DataWalker-0.02nb46.tgz
NetBSD 9.0aarch64p5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 9.0alphap5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 9.0alphap5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 9.0earmp5-Wx-Perl-DataWalker-0.02nb46.tgz
NetBSD 9.0earmp5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 9.0earmp5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 9.0earmv6hfp5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 9.0earmv6hfp5-Wx-Perl-DataWalker-0.02nb46.tgz
NetBSD 9.0earmv6hfp5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 9.0earmv7hfp5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 9.0earmv7hfp5-Wx-Perl-DataWalker-0.02nb46.tgz
NetBSD 9.0earmv7hfp5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 9.0earmv7hfp5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 9.0i386p5-Wx-Perl-DataWalker-0.02nb46.tgz
NetBSD 9.0i386p5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 9.0mips64ebp5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 9.0mips64ebp5-Wx-Perl-DataWalker-0.02nb46.tgz
NetBSD 9.0mips64ebp5-Wx-Perl-DataWalker-0.02nb46.tgz
NetBSD 9.0mips64ebp5-Wx-Perl-DataWalker-0.02nb46.tgz
NetBSD 9.0mips64ebp5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 9.0powerpcp5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 9.0powerpcp5-Wx-Perl-DataWalker-0.02nb46.tgz
NetBSD 9.0powerpcp5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 9.0powerpcp5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 9.0sparc64p5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 9.0sparc64p5-Wx-Perl-DataWalker-0.02nb46.tgz
NetBSD 9.0sparc64p5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 9.0sparcp5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 9.0sparcp5-Wx-Perl-DataWalker-0.02nb46.tgz
NetBSD 9.0sparcp5-Wx-Perl-DataWalker-0.02nb46.tgz
NetBSD 9.0sparcp5-Wx-Perl-DataWalker-0.02nb46.tgz
NetBSD 9.0sparcp5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 9.0x86_64p5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 9.0x86_64p5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 9.0x86_64p5-Wx-Perl-DataWalker-0.02nb46.tgz
NetBSD 9.0x86_64p5-Wx-Perl-DataWalker-0.02nb47.tgz
NetBSD 9.0x86_64p5-Wx-Perl-DataWalker-0.02nb47.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.