devel/p5-Tie-Cache-LRU-Expires - The NetBSD Packages Collection

Extends Tie::Cache::LRU with expiring

This module implements an expiring LRU cache, using Tie::Cache::LRU.
Each entry in this cache expires after 'EXPIRES' seconds (default 3600).
The cache is in RAM (see Tie::Cache::LRU).  ENTRIES provides the maximum
number of entries in the Tie::Cache::LRU cache.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/p5-Tie-Cache-LRU lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 8.0earmv7hfp5-Tie-Cache-LRU-Expires-0.55nb6.tgz
NetBSD 8.0earmv7hfp5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 8.0i386p5-Tie-Cache-LRU-Expires-0.55nb6.tgz
NetBSD 8.0i386p5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 8.0powerpcp5-Tie-Cache-LRU-Expires-0.55nb6.tgz
NetBSD 8.0powerpcp5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 8.0powerpcp5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 8.0powerpcp5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 8.0x86_64p5-Tie-Cache-LRU-Expires-0.55nb6.tgz
NetBSD 8.0x86_64p5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 9.0aarch64p5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 9.0aarch64p5-Tie-Cache-LRU-Expires-0.55nb6.tgz
NetBSD 9.0aarch64p5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 9.0alphap5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 9.0alphap5-Tie-Cache-LRU-Expires-0.55nb6.tgz
NetBSD 9.0alphap5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 9.0earmv6hfp5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 9.0earmv6hfp5-Tie-Cache-LRU-Expires-0.55nb6.tgz
NetBSD 9.0earmv6hfp5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 9.0earmv7hfp5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 9.0earmv7hfp5-Tie-Cache-LRU-Expires-0.55nb6.tgz
NetBSD 9.0earmv7hfp5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 9.0earmv7hfp5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 9.0i386p5-Tie-Cache-LRU-Expires-0.55nb6.tgz
NetBSD 9.0i386p5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 9.0i386p5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 9.0mips64ebp5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 9.0mips64ebp5-Tie-Cache-LRU-Expires-0.55nb6.tgz
NetBSD 9.0mips64ebp5-Tie-Cache-LRU-Expires-0.55nb6.tgz
NetBSD 9.0mips64ebp5-Tie-Cache-LRU-Expires-0.55nb6.tgz
NetBSD 9.0mips64ebp5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 9.0powerpcp5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 9.0powerpcp5-Tie-Cache-LRU-Expires-0.55nb6.tgz
NetBSD 9.0powerpcp5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 9.0powerpcp5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 9.0sparc64p5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 9.0sparc64p5-Tie-Cache-LRU-Expires-0.55nb6.tgz
NetBSD 9.0sparc64p5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 9.0sparcp5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 9.0sparcp5-Tie-Cache-LRU-Expires-0.55nb6.tgz
NetBSD 9.0sparcp5-Tie-Cache-LRU-Expires-0.55nb6.tgz
NetBSD 9.0sparcp5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 9.0x86_64p5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 9.0x86_64p5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 9.0x86_64p5-Tie-Cache-LRU-Expires-0.55nb6.tgz
NetBSD 9.0x86_64p5-Tie-Cache-LRU-Expires-0.55nb7.tgz
NetBSD 9.0x86_64p5-Tie-Cache-LRU-Expires-0.55nb7.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.