devel/p5-Test-ClassAPI - The NetBSD Packages Collection

Provide basic first-pass API testing for large class trees

For many APIs with large numbers of classes, it can be very useful
to be able to do a quick once-over to make sure that classes,
methods, and inheritance is correct, before doing more comprehensive
testing. This module aims to provide such a capability.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/p5-Class-Inspector devel/p5-Config-Tiny devel/p5-Params-Util lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 8.0earmv7hfp5-Test-ClassAPI-1.07nb3.tgz
NetBSD 8.0earmv7hfp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 8.0i386p5-Test-ClassAPI-1.07nb3.tgz
NetBSD 8.0i386p5-Test-ClassAPI-1.07nb4.tgz
NetBSD 8.0powerpcp5-Test-ClassAPI-1.07nb3.tgz
NetBSD 8.0powerpcp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 8.0powerpcp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 8.0powerpcp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 8.0x86_64p5-Test-ClassAPI-1.07nb3.tgz
NetBSD 8.0x86_64p5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0aarch64p5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0aarch64p5-Test-ClassAPI-1.07nb3.tgz
NetBSD 9.0aarch64p5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0alphap5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0alphap5-Test-ClassAPI-1.07nb3.tgz
NetBSD 9.0alphap5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0earmp5-Test-ClassAPI-1.07nb3.tgz
NetBSD 9.0earmp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0earmp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0earmv6hfp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0earmv6hfp5-Test-ClassAPI-1.07nb3.tgz
NetBSD 9.0earmv6hfp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0earmv7hfp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0earmv7hfp5-Test-ClassAPI-1.07nb3.tgz
NetBSD 9.0earmv7hfp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0earmv7hfp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0i386p5-Test-ClassAPI-1.07nb3.tgz
NetBSD 9.0i386p5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0i386p5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0m68kp5-Test-ClassAPI-1.07nb3.tgz
NetBSD 9.0m68kp5-Test-ClassAPI-1.07nb3.tgz
NetBSD 9.0m68kp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0m68kp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0mips64ebp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0mips64ebp5-Test-ClassAPI-1.07nb3.tgz
NetBSD 9.0mips64ebp5-Test-ClassAPI-1.07nb3.tgz
NetBSD 9.0mips64ebp5-Test-ClassAPI-1.07nb3.tgz
NetBSD 9.0mips64ebp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0mipselp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0mipselp5-Test-ClassAPI-1.07nb3.tgz
NetBSD 9.0mipselp5-Test-ClassAPI-1.07nb3.tgz
NetBSD 9.0mipselp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0powerpcp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0powerpcp5-Test-ClassAPI-1.07nb3.tgz
NetBSD 9.0powerpcp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0powerpcp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0sh3elp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0sh3elp5-Test-ClassAPI-1.07nb3.tgz
NetBSD 9.0sh3elp5-Test-ClassAPI-1.07nb3.tgz
NetBSD 9.0sh3elp5-Test-ClassAPI-1.07nb3.tgz
NetBSD 9.0sh3elp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0sparc64p5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0sparc64p5-Test-ClassAPI-1.07nb3.tgz
NetBSD 9.0sparc64p5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0sparcp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0sparcp5-Test-ClassAPI-1.07nb3.tgz
NetBSD 9.0sparcp5-Test-ClassAPI-1.07nb3.tgz
NetBSD 9.0sparcp5-Test-ClassAPI-1.07nb3.tgz
NetBSD 9.0sparcp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0vaxp5-Test-ClassAPI-1.07nb3.tgz
NetBSD 9.0vaxp5-Test-ClassAPI-1.07nb3.tgz
NetBSD 9.0vaxp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0vaxp5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0x86_64p5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0x86_64p5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0x86_64p5-Test-ClassAPI-1.07nb3.tgz
NetBSD 9.0x86_64p5-Test-ClassAPI-1.07nb4.tgz
NetBSD 9.0x86_64p5-Test-ClassAPI-1.07nb4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.