devel/p5-Term-ReadLine-TTYtter - The NetBSD Packages Collection

Perl 5 module providing minimal interface to Readline libraries

Term::ReadLine::TTYtter is a modified version of T::RL::Perl with
several new nonstandard features specific to TTYtter, but may be useful for
other applications.

It also allows UTF-8 characters to be entered without crashing, and adds a
counter so you can see how many characters you've entered (which is a big
deal for Twitter and other microblogging platforms).

For information about TTYtter, a Twitter-client written in Perl, visit
http://www.floodgap.com/software/ttytter.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 8.0earmv7hfp5-Term-ReadLine-TTYtter-1.4nb8.tgz
NetBSD 8.0earmv7hfp5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 8.0i386p5-Term-ReadLine-TTYtter-1.4nb8.tgz
NetBSD 8.0i386p5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 8.0powerpcp5-Term-ReadLine-TTYtter-1.4nb8.tgz
NetBSD 8.0powerpcp5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 8.0powerpcp5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 8.0powerpcp5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 8.0x86_64p5-Term-ReadLine-TTYtter-1.4nb8.tgz
NetBSD 8.0x86_64p5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 9.0aarch64p5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 9.0aarch64p5-Term-ReadLine-TTYtter-1.4nb8.tgz
NetBSD 9.0aarch64p5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 9.0alphap5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 9.0alphap5-Term-ReadLine-TTYtter-1.4nb8.tgz
NetBSD 9.0alphap5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 9.0earmp5-Term-ReadLine-TTYtter-1.4nb8.tgz
NetBSD 9.0earmp5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 9.0earmp5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 9.0earmv6hfp5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 9.0earmv6hfp5-Term-ReadLine-TTYtter-1.4nb8.tgz
NetBSD 9.0earmv6hfp5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 9.0earmv7hfp5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 9.0earmv7hfp5-Term-ReadLine-TTYtter-1.4nb8.tgz
NetBSD 9.0earmv7hfp5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 9.0earmv7hfp5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 9.0i386p5-Term-ReadLine-TTYtter-1.4nb8.tgz
NetBSD 9.0i386p5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 9.0mips64ebp5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 9.0mips64ebp5-Term-ReadLine-TTYtter-1.4nb8.tgz
NetBSD 9.0mips64ebp5-Term-ReadLine-TTYtter-1.4nb8.tgz
NetBSD 9.0mips64ebp5-Term-ReadLine-TTYtter-1.4nb8.tgz
NetBSD 9.0mips64ebp5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 9.0powerpcp5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 9.0powerpcp5-Term-ReadLine-TTYtter-1.4nb8.tgz
NetBSD 9.0powerpcp5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 9.0powerpcp5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 9.0sparc64p5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 9.0sparc64p5-Term-ReadLine-TTYtter-1.4nb8.tgz
NetBSD 9.0sparc64p5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 9.0sparcp5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 9.0sparcp5-Term-ReadLine-TTYtter-1.4nb8.tgz
NetBSD 9.0sparcp5-Term-ReadLine-TTYtter-1.4nb8.tgz
NetBSD 9.0sparcp5-Term-ReadLine-TTYtter-1.4nb8.tgz
NetBSD 9.0sparcp5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 9.0x86_64p5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 9.0x86_64p5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 9.0x86_64p5-Term-ReadLine-TTYtter-1.4nb8.tgz
NetBSD 9.0x86_64p5-Term-ReadLine-TTYtter-1.4nb9.tgz
NetBSD 9.0x86_64p5-Term-ReadLine-TTYtter-1.4nb9.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.