devel/p5-SVN-Notify - The NetBSD Packages Collection

Perl module for mailing messages for Subversion repository activity

The Perl5 module SVN::Notify provide a class that may be used for
sending email messages for Subversion repository activity. There
are a number of different modes supported, and SVN::Notify is fully
subclassable, to easily add new functionality. By default, A list
of all the files affected by the commit will be assembled and listed
in a single message. An additional option allows diffs to be
calculated for the changes and either appended to the message or
added as an attachment. The included subclass, SVN::Notify::HTML,
allows the messages to be sent in HTML format. A svnnotify script
is also provided.

Build dependencies

devel/p5-Module-Build pkgtools/cwrappers

Runtime dependencies

www/p5-HTML-Parser mail/p5-Net-SMTP_auth textproc/p5-Text-Trac mail/p5-Email-Address-XS lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-SVN-Notify-2.87nb4.tgz
NetBSD 8.0earmv7hfp5-SVN-Notify-2.87nb3.tgz
NetBSD 8.0earmv7hfp5-SVN-Notify-2.87nb4.tgz
NetBSD 8.0i386p5-SVN-Notify-2.87nb3.tgz
NetBSD 8.0i386p5-SVN-Notify-2.87nb4.tgz
NetBSD 8.0powerpcp5-SVN-Notify-2.87nb3.tgz
NetBSD 8.0powerpcp5-SVN-Notify-2.87nb4.tgz
NetBSD 8.0powerpcp5-SVN-Notify-2.87nb4.tgz
NetBSD 8.0powerpcp5-SVN-Notify-2.87nb4.tgz
NetBSD 8.0x86_64p5-SVN-Notify-2.87nb3.tgz
NetBSD 8.0x86_64p5-SVN-Notify-2.87nb4.tgz
NetBSD 9.0aarch64p5-SVN-Notify-2.87nb4.tgz
NetBSD 9.0aarch64p5-SVN-Notify-2.87nb3.tgz
NetBSD 9.0aarch64p5-SVN-Notify-2.87nb4.tgz
NetBSD 9.0alphap5-SVN-Notify-2.87nb4.tgz
NetBSD 9.0alphap5-SVN-Notify-2.87nb3.tgz
NetBSD 9.0alphap5-SVN-Notify-2.87nb4.tgz
NetBSD 9.0earmv6hfp5-SVN-Notify-2.87nb4.tgz
NetBSD 9.0earmv6hfp5-SVN-Notify-2.87nb3.tgz
NetBSD 9.0earmv6hfp5-SVN-Notify-2.87nb4.tgz
NetBSD 9.0earmv7hfp5-SVN-Notify-2.87nb4.tgz
NetBSD 9.0earmv7hfp5-SVN-Notify-2.87nb3.tgz
NetBSD 9.0earmv7hfp5-SVN-Notify-2.87nb4.tgz
NetBSD 9.0earmv7hfp5-SVN-Notify-2.87nb4.tgz
NetBSD 9.0i386p5-SVN-Notify-2.87nb3.tgz
NetBSD 9.0i386p5-SVN-Notify-2.87nb4.tgz
NetBSD 9.0mips64ebp5-SVN-Notify-2.87nb4.tgz
NetBSD 9.0mips64ebp5-SVN-Notify-2.87nb3.tgz
NetBSD 9.0mips64ebp5-SVN-Notify-2.87nb3.tgz
NetBSD 9.0mips64ebp5-SVN-Notify-2.87nb3.tgz
NetBSD 9.0mips64ebp5-SVN-Notify-2.87nb4.tgz
NetBSD 9.0powerpcp5-SVN-Notify-2.87nb4.tgz
NetBSD 9.0powerpcp5-SVN-Notify-2.87nb3.tgz
NetBSD 9.0powerpcp5-SVN-Notify-2.87nb4.tgz
NetBSD 9.0powerpcp5-SVN-Notify-2.87nb4.tgz
NetBSD 9.0sparc64p5-SVN-Notify-2.87nb4.tgz
NetBSD 9.0sparc64p5-SVN-Notify-2.87nb3.tgz
NetBSD 9.0sparc64p5-SVN-Notify-2.87nb4.tgz
NetBSD 9.0sparcp5-SVN-Notify-2.87nb4.tgz
NetBSD 9.0sparcp5-SVN-Notify-2.87nb3.tgz
NetBSD 9.0sparcp5-SVN-Notify-2.87nb3.tgz
NetBSD 9.0sparcp5-SVN-Notify-2.87nb4.tgz
NetBSD 9.0x86_64p5-SVN-Notify-2.87nb4.tgz
NetBSD 9.0x86_64p5-SVN-Notify-2.87nb4.tgz
NetBSD 9.0x86_64p5-SVN-Notify-2.87nb3.tgz
NetBSD 9.0x86_64p5-SVN-Notify-2.87nb4.tgz
NetBSD 9.0x86_64p5-SVN-Notify-2.87nb4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.