devel/p5-Perl-Critic - The NetBSD Packages Collection

Perl 5 module providing a static Perl source code analysis engine

The Perl 5 module Perl::Critic is an extensible framework for
creating and applying coding standards to Perl source code.

Essentially, it is a static source code analysis engine. Perl::Critic
is distributed with a number of Perl::Critic::Policy modules that
attempt to enforce various coding guidelines. Most Policy modules
are based on Damian Conway's book Perl Best Practices. However,
Perl::Critic is not limited to PBP and will even support Policies
that contradict Conway. You can enable, disable, and customize
those Polices through the Perl::Critic interface. You can also
create new Policy modules that suit your own tastes.
A front-end script, perlcritic, is provided.

Build dependencies

devel/p5-Module-Build pkgtools/cwrappers

Runtime dependencies

devel/p5-B-Keywords devel/p5-Config-Tiny devel/p5-Exception-Class devel/p5-File-Which devel/p5-IO-String devel/p5-List-MoreUtils devel/p5-Module-Pluggable devel/p5-PPI textproc/p5-PPIx-QuoteLike devel/p5-PPIx-Regexp devel/p5-PPIx-Utilities devel/p5-Perl-Tidy textproc/p5-Pod-Spell textproc/p5-Pod-Parser devel/p5-Readonly devel/p5-String-Format devel/p5-Task-Weaken devel/p5-Readonly-XS lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Perl-Critic-1.140.tgz
NetBSD 8.0earmv7hfp5-Perl-Critic-1.138nb2.tgz
NetBSD 8.0earmv7hfp5-Perl-Critic-1.138nb3.tgz
NetBSD 8.0i386p5-Perl-Critic-1.138nb2.tgz
NetBSD 8.0i386p5-Perl-Critic-1.138nb3.tgz
NetBSD 8.0powerpcp5-Perl-Critic-1.138nb2.tgz
NetBSD 8.0powerpcp5-Perl-Critic-1.138nb3.tgz
NetBSD 8.0powerpcp5-Perl-Critic-1.138nb3.tgz
NetBSD 8.0powerpcp5-Perl-Critic-1.140.tgz
NetBSD 8.0x86_64p5-Perl-Critic-1.138nb2.tgz
NetBSD 8.0x86_64p5-Perl-Critic-1.138nb3.tgz
NetBSD 9.0aarch64p5-Perl-Critic-1.140.tgz
NetBSD 9.0aarch64p5-Perl-Critic-1.138nb2.tgz
NetBSD 9.0aarch64p5-Perl-Critic-1.138nb3.tgz
NetBSD 9.0alphap5-Perl-Critic-1.140.tgz
NetBSD 9.0alphap5-Perl-Critic-1.138nb2.tgz
NetBSD 9.0alphap5-Perl-Critic-1.138nb3.tgz
NetBSD 9.0earmp5-Perl-Critic-1.138nb2.tgz
NetBSD 9.0earmp5-Perl-Critic-1.138nb3.tgz
NetBSD 9.0earmv6hfp5-Perl-Critic-1.140.tgz
NetBSD 9.0earmv6hfp5-Perl-Critic-1.138nb2.tgz
NetBSD 9.0earmv6hfp5-Perl-Critic-1.138nb3.tgz
NetBSD 9.0earmv7hfp5-Perl-Critic-1.140.tgz
NetBSD 9.0earmv7hfp5-Perl-Critic-1.138nb2.tgz
NetBSD 9.0earmv7hfp5-Perl-Critic-1.138nb3.tgz
NetBSD 9.0earmv7hfp5-Perl-Critic-1.140.tgz
NetBSD 9.0i386p5-Perl-Critic-1.138nb2.tgz
NetBSD 9.0i386p5-Perl-Critic-1.138nb3.tgz
NetBSD 9.0i386p5-Perl-Critic-1.140.tgz
NetBSD 9.0mips64ebp5-Perl-Critic-1.138nb3.tgz
NetBSD 9.0mips64ebp5-Perl-Critic-1.138nb1.tgz
NetBSD 9.0mips64ebp5-Perl-Critic-1.138nb2.tgz
NetBSD 9.0mips64ebp5-Perl-Critic-1.138nb2.tgz
NetBSD 9.0mips64ebp5-Perl-Critic-1.140.tgz
NetBSD 9.0mipselp5-Perl-Critic-1.138nb3.tgz
NetBSD 9.0mipselp5-Perl-Critic-1.138nb2.tgz
NetBSD 9.0mipselp5-Perl-Critic-1.138nb2.tgz
NetBSD 9.0powerpcp5-Perl-Critic-1.138nb3.tgz
NetBSD 9.0powerpcp5-Perl-Critic-1.138nb2.tgz
NetBSD 9.0powerpcp5-Perl-Critic-1.138nb3.tgz
NetBSD 9.0powerpcp5-Perl-Critic-1.140.tgz
NetBSD 9.0sh3elp5-Perl-Critic-1.138nb3.tgz
NetBSD 9.0sh3elp5-Perl-Critic-1.138nb2.tgz
NetBSD 9.0sh3elp5-Perl-Critic-1.138nb2.tgz
NetBSD 9.0sparc64p5-Perl-Critic-1.138nb3.tgz
NetBSD 9.0sparc64p5-Perl-Critic-1.138nb2.tgz
NetBSD 9.0sparc64p5-Perl-Critic-1.140.tgz
NetBSD 9.0sparcp5-Perl-Critic-1.138nb3.tgz
NetBSD 9.0sparcp5-Perl-Critic-1.138nb1.tgz
NetBSD 9.0sparcp5-Perl-Critic-1.138nb2.tgz
NetBSD 9.0sparcp5-Perl-Critic-1.138nb2.tgz
NetBSD 9.0sparcp5-Perl-Critic-1.140.tgz
NetBSD 9.0vaxp5-Perl-Critic-1.138nb2.tgz
NetBSD 9.0x86_64p5-Perl-Critic-1.138nb3.tgz
NetBSD 9.0x86_64p5-Perl-Critic-1.140.tgz
NetBSD 9.0x86_64p5-Perl-Critic-1.138nb2.tgz
NetBSD 9.0x86_64p5-Perl-Critic-1.138nb3.tgz
NetBSD 9.0x86_64p5-Perl-Critic-1.140.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.