devel/p5-PPI - The NetBSD Packages Collection

Perl 5 module to parse, analyze and manipulate Perl (without perl)

The purpose of the Perl 5 module PPI is to parse Perl code or more
accurately Perl Documents. Among the things that people might want
a "Perl parser" for you will find tasks like documentation, structural
and quality analysis, refactoring, layout and presentation

Build dependencies

devel/p5-Class-Inspector sysutils/p5-File-Remove devel/p5-Test-NoWarnings devel/p5-Test-Object devel/p5-Test-SubCalls pkgtools/cwrappers

Runtime dependencies

devel/p5-Clone devel/p5-IO-String devel/p5-List-MoreUtils devel/p5-Params-Util devel/p5-Task-Weaken lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-PPI-1.270nb2.tgz
NetBSD 8.0earmv7hfp5-PPI-1.270nb1.tgz
NetBSD 8.0earmv7hfp5-PPI-1.270nb2.tgz
NetBSD 8.0i386p5-PPI-1.270nb1.tgz
NetBSD 8.0i386p5-PPI-1.270nb2.tgz
NetBSD 8.0powerpcp5-PPI-1.270nb1.tgz
NetBSD 8.0powerpcp5-PPI-1.270nb2.tgz
NetBSD 8.0powerpcp5-PPI-1.270nb2.tgz
NetBSD 8.0powerpcp5-PPI-1.270nb2.tgz
NetBSD 8.0x86_64p5-PPI-1.270nb1.tgz
NetBSD 8.0x86_64p5-PPI-1.270nb2.tgz
NetBSD 9.0aarch64p5-PPI-1.270nb2.tgz
NetBSD 9.0aarch64p5-PPI-1.270nb1.tgz
NetBSD 9.0aarch64p5-PPI-1.270nb2.tgz
NetBSD 9.0alphap5-PPI-1.270nb2.tgz
NetBSD 9.0alphap5-PPI-1.270nb1.tgz
NetBSD 9.0alphap5-PPI-1.270nb2.tgz
NetBSD 9.0earmp5-PPI-1.270nb1.tgz
NetBSD 9.0earmp5-PPI-1.270nb2.tgz
NetBSD 9.0earmp5-PPI-1.270nb2.tgz
NetBSD 9.0earmv6hfp5-PPI-1.270nb2.tgz
NetBSD 9.0earmv6hfp5-PPI-1.270nb1.tgz
NetBSD 9.0earmv6hfp5-PPI-1.270nb2.tgz
NetBSD 9.0earmv7hfp5-PPI-1.270nb2.tgz
NetBSD 9.0earmv7hfp5-PPI-1.270nb1.tgz
NetBSD 9.0earmv7hfp5-PPI-1.270nb2.tgz
NetBSD 9.0earmv7hfp5-PPI-1.270nb2.tgz
NetBSD 9.0i386p5-PPI-1.270nb1.tgz
NetBSD 9.0i386p5-PPI-1.270nb2.tgz
NetBSD 9.0i386p5-PPI-1.270nb2.tgz
NetBSD 9.0m68kp5-PPI-1.270nb1.tgz
NetBSD 9.0m68kp5-PPI-1.270nb1.tgz
NetBSD 9.0m68kp5-PPI-1.270nb2.tgz
NetBSD 9.0mips64ebp5-PPI-1.270nb2.tgz
NetBSD 9.0mips64ebp5-PPI-1.270nb1.tgz
NetBSD 9.0mips64ebp5-PPI-1.270nb1.tgz
NetBSD 9.0mips64ebp5-PPI-1.270nb1.tgz
NetBSD 9.0mips64ebp5-PPI-1.270nb2.tgz
NetBSD 9.0mipselp5-PPI-1.270nb2.tgz
NetBSD 9.0mipselp5-PPI-1.270nb1.tgz
NetBSD 9.0mipselp5-PPI-1.270nb1.tgz
NetBSD 9.0mipselp5-PPI-1.270nb2.tgz
NetBSD 9.0powerpcp5-PPI-1.270nb2.tgz
NetBSD 9.0powerpcp5-PPI-1.270nb1.tgz
NetBSD 9.0powerpcp5-PPI-1.270nb2.tgz
NetBSD 9.0powerpcp5-PPI-1.270nb2.tgz
NetBSD 9.0sh3elp5-PPI-1.270nb2.tgz
NetBSD 9.0sh3elp5-PPI-1.270nb1.tgz
NetBSD 9.0sh3elp5-PPI-1.270nb1.tgz
NetBSD 9.0sh3elp5-PPI-1.270nb1.tgz
NetBSD 9.0sh3elp5-PPI-1.270nb2.tgz
NetBSD 9.0sparc64p5-PPI-1.270nb2.tgz
NetBSD 9.0sparc64p5-PPI-1.270nb1.tgz
NetBSD 9.0sparc64p5-PPI-1.270nb2.tgz
NetBSD 9.0sparcp5-PPI-1.270nb2.tgz
NetBSD 9.0sparcp5-PPI-1.270nb1.tgz
NetBSD 9.0sparcp5-PPI-1.270nb1.tgz
NetBSD 9.0sparcp5-PPI-1.270nb1.tgz
NetBSD 9.0sparcp5-PPI-1.270nb2.tgz
NetBSD 9.0vaxp5-PPI-1.270nb1.tgz
NetBSD 9.0vaxp5-PPI-1.270nb1.tgz
NetBSD 9.0vaxp5-PPI-1.270nb2.tgz
NetBSD 9.0vaxp5-PPI-1.270nb2.tgz
NetBSD 9.0x86_64p5-PPI-1.270nb2.tgz
NetBSD 9.0x86_64p5-PPI-1.270nb2.tgz
NetBSD 9.0x86_64p5-PPI-1.270nb1.tgz
NetBSD 9.0x86_64p5-PPI-1.270nb2.tgz
NetBSD 9.0x86_64p5-PPI-1.270nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.