devel/p5-MooseX-LazyRequire - The NetBSD Packages Collection

Required attributes which fail only when trying to use them

This module adds a lazy_required option to Moose attribute declarations.

The reader methods for all attributes with that option will throw an
exception unless a value for the attributes was provided earlier by a
constructor parameter or through a writer method.

Build dependencies

devel/p5-Test-CheckDeps devel/p5-Test-Fatal devel/p5-Package-DeprecationManager pkgtools/cwrappers

Runtime dependencies

devel/p5-Moose devel/p5-aliased devel/p5-namespace-autoclean lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 8.0earmv7hfp5-MooseX-LazyRequire-0.11nb6.tgz
NetBSD 8.0earmv7hfp5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 8.0i386p5-MooseX-LazyRequire-0.11nb6.tgz
NetBSD 8.0i386p5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 8.0powerpcp5-MooseX-LazyRequire-0.11nb6.tgz
NetBSD 8.0powerpcp5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 8.0powerpcp5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 8.0powerpcp5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 8.0x86_64p5-MooseX-LazyRequire-0.11nb6.tgz
NetBSD 8.0x86_64p5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0aarch64p5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0aarch64p5-MooseX-LazyRequire-0.11nb6.tgz
NetBSD 9.0aarch64p5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0alphap5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0alphap5-MooseX-LazyRequire-0.11nb6.tgz
NetBSD 9.0alphap5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0earmp5-MooseX-LazyRequire-0.11nb6.tgz
NetBSD 9.0earmp5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0earmp5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0earmv6hfp5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0earmv6hfp5-MooseX-LazyRequire-0.11nb6.tgz
NetBSD 9.0earmv6hfp5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0earmv7hfp5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0earmv7hfp5-MooseX-LazyRequire-0.11nb6.tgz
NetBSD 9.0earmv7hfp5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0earmv7hfp5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0i386p5-MooseX-LazyRequire-0.11nb6.tgz
NetBSD 9.0i386p5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0i386p5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0mips64ebp5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0mips64ebp5-MooseX-LazyRequire-0.11nb6.tgz
NetBSD 9.0mips64ebp5-MooseX-LazyRequire-0.11nb6.tgz
NetBSD 9.0mips64ebp5-MooseX-LazyRequire-0.11nb6.tgz
NetBSD 9.0mips64ebp5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0mipselp5-MooseX-LazyRequire-0.11nb6.tgz
NetBSD 9.0mipselp5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0powerpcp5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0powerpcp5-MooseX-LazyRequire-0.11nb6.tgz
NetBSD 9.0powerpcp5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0powerpcp5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0sh3elp5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0sh3elp5-MooseX-LazyRequire-0.11nb6.tgz
NetBSD 9.0sh3elp5-MooseX-LazyRequire-0.11nb6.tgz
NetBSD 9.0sh3elp5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0sparc64p5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0sparc64p5-MooseX-LazyRequire-0.11nb6.tgz
NetBSD 9.0sparc64p5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0sparcp5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0sparcp5-MooseX-LazyRequire-0.11nb6.tgz
NetBSD 9.0sparcp5-MooseX-LazyRequire-0.11nb6.tgz
NetBSD 9.0sparcp5-MooseX-LazyRequire-0.11nb6.tgz
NetBSD 9.0sparcp5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0x86_64p5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0x86_64p5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0x86_64p5-MooseX-LazyRequire-0.11nb6.tgz
NetBSD 9.0x86_64p5-MooseX-LazyRequire-0.11nb7.tgz
NetBSD 9.0x86_64p5-MooseX-LazyRequire-0.11nb7.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.