devel/p5-MooseX-ClassAttribute - The NetBSD Packages Collection

Perl 5 module to declare class attributes Moose-style

The Perl 5 module MooseX::ClassAttribute is a Moose extension
allowing you to declare class attributes in exactly the same way
as object attributes, using class_has() instead of has().

Build dependencies

devel/p5-Package-DeprecationManager devel/p5-Test-Requires pkgtools/cwrappers

Runtime dependencies

devel/p5-Moose devel/p5-namespace-autoclean lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 8.0earmv7hfp5-MooseX-ClassAttribute-0.29nb5.tgz
NetBSD 8.0earmv7hfp5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 8.0i386p5-MooseX-ClassAttribute-0.29nb5.tgz
NetBSD 8.0i386p5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 8.0powerpcp5-MooseX-ClassAttribute-0.29nb5.tgz
NetBSD 8.0powerpcp5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 8.0powerpcp5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 8.0powerpcp5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 8.0x86_64p5-MooseX-ClassAttribute-0.29nb5.tgz
NetBSD 8.0x86_64p5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0aarch64p5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0aarch64p5-MooseX-ClassAttribute-0.29nb5.tgz
NetBSD 9.0aarch64p5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0alphap5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0alphap5-MooseX-ClassAttribute-0.29nb5.tgz
NetBSD 9.0alphap5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0earmp5-MooseX-ClassAttribute-0.29nb5.tgz
NetBSD 9.0earmp5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0earmp5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0earmv6hfp5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0earmv6hfp5-MooseX-ClassAttribute-0.29nb5.tgz
NetBSD 9.0earmv6hfp5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0earmv7hfp5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0earmv7hfp5-MooseX-ClassAttribute-0.29nb5.tgz
NetBSD 9.0earmv7hfp5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0earmv7hfp5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0i386p5-MooseX-ClassAttribute-0.29nb5.tgz
NetBSD 9.0i386p5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0i386p5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0mips64ebp5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0mips64ebp5-MooseX-ClassAttribute-0.29nb5.tgz
NetBSD 9.0mips64ebp5-MooseX-ClassAttribute-0.29nb5.tgz
NetBSD 9.0mips64ebp5-MooseX-ClassAttribute-0.29nb5.tgz
NetBSD 9.0mips64ebp5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0mipselp5-MooseX-ClassAttribute-0.29nb5.tgz
NetBSD 9.0mipselp5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0powerpcp5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0powerpcp5-MooseX-ClassAttribute-0.29nb5.tgz
NetBSD 9.0powerpcp5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0powerpcp5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0sh3elp5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0sh3elp5-MooseX-ClassAttribute-0.29nb5.tgz
NetBSD 9.0sh3elp5-MooseX-ClassAttribute-0.29nb5.tgz
NetBSD 9.0sh3elp5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0sparc64p5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0sparc64p5-MooseX-ClassAttribute-0.29nb5.tgz
NetBSD 9.0sparc64p5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0sparcp5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0sparcp5-MooseX-ClassAttribute-0.29nb5.tgz
NetBSD 9.0sparcp5-MooseX-ClassAttribute-0.29nb5.tgz
NetBSD 9.0sparcp5-MooseX-ClassAttribute-0.29nb5.tgz
NetBSD 9.0sparcp5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0x86_64p5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0x86_64p5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0x86_64p5-MooseX-ClassAttribute-0.29nb5.tgz
NetBSD 9.0x86_64p5-MooseX-ClassAttribute-0.29nb6.tgz
NetBSD 9.0x86_64p5-MooseX-ClassAttribute-0.29nb6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.