devel/p5-Module-Manifest - The NetBSD Packages Collection

Parse and examine a Perl distribution MANIFEST file

Module::Manifest is a simple utility module created originally for use in
Module::Inspector.

It can load a MANIFEST file that comes in a Perl distribution tarball,
examine the contents, and perform some simple tasks. It can also load the
MANIFEST.SKIP file and check that.

Granted, the functionality needed to do this is quite simple, but the Perl
distribution MANIFEST specification contains a couple of little
idiosyncracies, such as line comments and space-seperated inline comments.

The use of this module means that any little nigglies are dealt with behind
the scenes, and you can concentrate the main task at hand.

Build dependencies

devel/p5-Test-Exception devel/p5-Test-Warn pkgtools/cwrappers

Runtime dependencies

devel/p5-Params-Util lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Module-Manifest-1.09nb4.tgz
NetBSD 8.0earmv7hfp5-Module-Manifest-1.09nb3.tgz
NetBSD 8.0earmv7hfp5-Module-Manifest-1.09nb4.tgz
NetBSD 8.0i386p5-Module-Manifest-1.09nb3.tgz
NetBSD 8.0i386p5-Module-Manifest-1.09nb4.tgz
NetBSD 8.0powerpcp5-Module-Manifest-1.09nb3.tgz
NetBSD 8.0powerpcp5-Module-Manifest-1.09nb4.tgz
NetBSD 8.0powerpcp5-Module-Manifest-1.09nb4.tgz
NetBSD 8.0powerpcp5-Module-Manifest-1.09nb4.tgz
NetBSD 8.0x86_64p5-Module-Manifest-1.09nb3.tgz
NetBSD 8.0x86_64p5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0aarch64p5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0aarch64p5-Module-Manifest-1.09nb3.tgz
NetBSD 9.0aarch64p5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0alphap5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0alphap5-Module-Manifest-1.09nb3.tgz
NetBSD 9.0alphap5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0earmp5-Module-Manifest-1.09nb3.tgz
NetBSD 9.0earmp5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0earmp5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0earmv6hfp5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0earmv6hfp5-Module-Manifest-1.09nb3.tgz
NetBSD 9.0earmv6hfp5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0earmv7hfp5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0earmv7hfp5-Module-Manifest-1.09nb3.tgz
NetBSD 9.0earmv7hfp5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0earmv7hfp5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0i386p5-Module-Manifest-1.09nb3.tgz
NetBSD 9.0i386p5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0i386p5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0m68kp5-Module-Manifest-1.09nb3.tgz
NetBSD 9.0m68kp5-Module-Manifest-1.09nb3.tgz
NetBSD 9.0mips64ebp5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0mips64ebp5-Module-Manifest-1.09nb3.tgz
NetBSD 9.0mips64ebp5-Module-Manifest-1.09nb3.tgz
NetBSD 9.0mips64ebp5-Module-Manifest-1.09nb3.tgz
NetBSD 9.0mips64ebp5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0mipselp5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0mipselp5-Module-Manifest-1.09nb3.tgz
NetBSD 9.0mipselp5-Module-Manifest-1.09nb3.tgz
NetBSD 9.0mipselp5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0powerpcp5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0powerpcp5-Module-Manifest-1.09nb3.tgz
NetBSD 9.0powerpcp5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0powerpcp5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0sh3elp5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0sh3elp5-Module-Manifest-1.09nb3.tgz
NetBSD 9.0sh3elp5-Module-Manifest-1.09nb3.tgz
NetBSD 9.0sh3elp5-Module-Manifest-1.09nb3.tgz
NetBSD 9.0sh3elp5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0sparc64p5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0sparc64p5-Module-Manifest-1.09nb3.tgz
NetBSD 9.0sparc64p5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0sparcp5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0sparcp5-Module-Manifest-1.09nb3.tgz
NetBSD 9.0sparcp5-Module-Manifest-1.09nb3.tgz
NetBSD 9.0sparcp5-Module-Manifest-1.09nb3.tgz
NetBSD 9.0sparcp5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0vaxp5-Module-Manifest-1.09nb3.tgz
NetBSD 9.0vaxp5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0vaxp5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0x86_64p5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0x86_64p5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0x86_64p5-Module-Manifest-1.09nb3.tgz
NetBSD 9.0x86_64p5-Module-Manifest-1.09nb4.tgz
NetBSD 9.0x86_64p5-Module-Manifest-1.09nb4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.