devel/p5-Gtk2-GladeXML - The NetBSD Packages Collection

Perl bindings for Glade (2)

Glade is a free user interface builder for GTK+ and GNOME. After designing a
user interface with glade-2 the layout and configuration are saved in an XML
file. libglade is a library which knows how to build and hook up the user
interface described in the Glade XML file at application run time.

This extension module binds libglade to Perl so you can create and manipulate
user interfaces in Perl code in conjunction with Gtk2 and even Gnome2. Better
yet you can load a file's contents into a PERL scalar do a few magical regular
expressions to customize things and the load up the app. It doesn't get any
easier.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/pkgconf

Runtime dependencies

devel/p5-ExtUtils-Depends devel/p5-ExtUtils-PkgConfig devel/p5-glib2 devel/libglade lang/perl5 lang/perl5 x11/p5-gtk2 devel/p5-glib2 devel/libglade x11/p5-gtk2

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 8.0earmv7hfp5-Gtk2-GladeXML-1.007nb47.tgz
NetBSD 8.0earmv7hfp5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 8.0i386p5-Gtk2-GladeXML-1.007nb47.tgz
NetBSD 8.0i386p5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 8.0powerpcp5-Gtk2-GladeXML-1.007nb47.tgz
NetBSD 8.0powerpcp5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 8.0powerpcp5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 8.0powerpcp5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 8.0x86_64p5-Gtk2-GladeXML-1.007nb47.tgz
NetBSD 8.0x86_64p5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 9.0aarch64p5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 9.0aarch64p5-Gtk2-GladeXML-1.007nb47.tgz
NetBSD 9.0aarch64p5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 9.0alphap5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 9.0alphap5-Gtk2-GladeXML-1.007nb47.tgz
NetBSD 9.0alphap5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 9.0earmv6hfp5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 9.0earmv6hfp5-Gtk2-GladeXML-1.007nb47.tgz
NetBSD 9.0earmv6hfp5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 9.0earmv7hfp5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 9.0earmv7hfp5-Gtk2-GladeXML-1.007nb47.tgz
NetBSD 9.0earmv7hfp5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 9.0earmv7hfp5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 9.0i386p5-Gtk2-GladeXML-1.007nb47.tgz
NetBSD 9.0i386p5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 9.0i386p5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 9.0mips64ebp5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 9.0mips64ebp5-Gtk2-GladeXML-1.007nb46.tgz
NetBSD 9.0mips64ebp5-Gtk2-GladeXML-1.007nb47.tgz
NetBSD 9.0mips64ebp5-Gtk2-GladeXML-1.007nb47.tgz
NetBSD 9.0mips64ebp5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 9.0powerpcp5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 9.0powerpcp5-Gtk2-GladeXML-1.007nb47.tgz
NetBSD 9.0powerpcp5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 9.0powerpcp5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 9.0sparc64p5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 9.0sparc64p5-Gtk2-GladeXML-1.007nb47.tgz
NetBSD 9.0sparc64p5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 9.0sparcp5-Gtk2-GladeXML-1.007nb47.tgz
NetBSD 9.0sparcp5-Gtk2-GladeXML-1.007nb47.tgz
NetBSD 9.0x86_64p5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 9.0x86_64p5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 9.0x86_64p5-Gtk2-GladeXML-1.007nb47.tgz
NetBSD 9.0x86_64p5-Gtk2-GladeXML-1.007nb49.tgz
NetBSD 9.0x86_64p5-Gtk2-GladeXML-1.007nb49.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.