devel/p5-GitLab-API-v3 - The NetBSD Packages Collection

Complete GitLab API v3 client

This module provides a one-to-one interface with the GitLab API v3. Much
is not documented here as it would just be duplicating GitLab's own API
Documentation.

Note that this distribution also includes the gitlab-api-v3 command-line
interface (CLI).

Build dependencies

devel/p5-Module-Build-Tiny pkgtools/cwrappers

Runtime dependencies

devel/p5-Const-Fast devel/p5-Log-Any-Adapter-Screen devel/p5-Log-Any-Adapter-TAP textproc/p5-YAML www/p5-Role-REST-Client devel/p5-Moo lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-GitLab-API-v3-1.05nb3.tgz
NetBSD 8.0earmv7hfp5-GitLab-API-v3-1.05nb2.tgz
NetBSD 8.0earmv7hfp5-GitLab-API-v3-1.05nb3.tgz
NetBSD 8.0i386p5-GitLab-API-v3-1.05nb2.tgz
NetBSD 8.0i386p5-GitLab-API-v3-1.05nb3.tgz
NetBSD 8.0powerpcp5-GitLab-API-v3-1.05nb2.tgz
NetBSD 8.0powerpcp5-GitLab-API-v3-1.05nb3.tgz
NetBSD 8.0powerpcp5-GitLab-API-v3-1.05nb3.tgz
NetBSD 8.0powerpcp5-GitLab-API-v3-1.05nb3.tgz
NetBSD 8.0x86_64p5-GitLab-API-v3-1.05nb2.tgz
NetBSD 8.0x86_64p5-GitLab-API-v3-1.05nb3.tgz
NetBSD 9.0aarch64p5-GitLab-API-v3-1.05nb3.tgz
NetBSD 9.0aarch64p5-GitLab-API-v3-1.05nb2.tgz
NetBSD 9.0aarch64p5-GitLab-API-v3-1.05nb3.tgz
NetBSD 9.0alphap5-GitLab-API-v3-1.05nb3.tgz
NetBSD 9.0alphap5-GitLab-API-v3-1.05nb2.tgz
NetBSD 9.0alphap5-GitLab-API-v3-1.05nb3.tgz
NetBSD 9.0earmv6hfp5-GitLab-API-v3-1.05nb3.tgz
NetBSD 9.0earmv6hfp5-GitLab-API-v3-1.05nb2.tgz
NetBSD 9.0earmv6hfp5-GitLab-API-v3-1.05nb3.tgz
NetBSD 9.0earmv7hfp5-GitLab-API-v3-1.05nb3.tgz
NetBSD 9.0earmv7hfp5-GitLab-API-v3-1.05nb2.tgz
NetBSD 9.0earmv7hfp5-GitLab-API-v3-1.05nb3.tgz
NetBSD 9.0earmv7hfp5-GitLab-API-v3-1.05nb3.tgz
NetBSD 9.0i386p5-GitLab-API-v3-1.05nb2.tgz
NetBSD 9.0i386p5-GitLab-API-v3-1.05nb3.tgz
NetBSD 9.0mips64ebp5-GitLab-API-v3-1.05nb3.tgz
NetBSD 9.0mips64ebp5-GitLab-API-v3-1.05nb2.tgz
NetBSD 9.0mips64ebp5-GitLab-API-v3-1.05nb2.tgz
NetBSD 9.0mips64ebp5-GitLab-API-v3-1.05nb2.tgz
NetBSD 9.0mips64ebp5-GitLab-API-v3-1.05nb3.tgz
NetBSD 9.0powerpcp5-GitLab-API-v3-1.05nb3.tgz
NetBSD 9.0powerpcp5-GitLab-API-v3-1.05nb2.tgz
NetBSD 9.0powerpcp5-GitLab-API-v3-1.05nb3.tgz
NetBSD 9.0powerpcp5-GitLab-API-v3-1.05nb3.tgz
NetBSD 9.0sparc64p5-GitLab-API-v3-1.05nb3.tgz
NetBSD 9.0sparc64p5-GitLab-API-v3-1.05nb2.tgz
NetBSD 9.0sparc64p5-GitLab-API-v3-1.05nb3.tgz
NetBSD 9.0sparcp5-GitLab-API-v3-1.05nb3.tgz
NetBSD 9.0sparcp5-GitLab-API-v3-1.05nb2.tgz
NetBSD 9.0sparcp5-GitLab-API-v3-1.05nb2.tgz
NetBSD 9.0sparcp5-GitLab-API-v3-1.05nb3.tgz
NetBSD 9.0x86_64p5-GitLab-API-v3-1.05nb3.tgz
NetBSD 9.0x86_64p5-GitLab-API-v3-1.05nb3.tgz
NetBSD 9.0x86_64p5-GitLab-API-v3-1.05nb2.tgz
NetBSD 9.0x86_64p5-GitLab-API-v3-1.05nb3.tgz
NetBSD 9.0x86_64p5-GitLab-API-v3-1.05nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.