devel/p5-Git-Version-Compare - The NetBSD Packages Collection

Functions to compare Git versions

Git::Version::Compare contains a selection of subroutines that make
dealing with Git-related things (like versions) a little bit easier.

The strings to compare can be version numbers, tags from git.git or
the output of git version or git describe.

Build dependencies

devel/p5-namespace-clean devel/p5-Test-NoWarnings pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Git-Version-Compare-1.004nb5.tgz
NetBSD 8.0earmv7hfp5-Git-Version-Compare-1.004nb4.tgz
NetBSD 8.0earmv7hfp5-Git-Version-Compare-1.004nb5.tgz
NetBSD 8.0i386p5-Git-Version-Compare-1.004nb4.tgz
NetBSD 8.0i386p5-Git-Version-Compare-1.004nb5.tgz
NetBSD 8.0powerpcp5-Git-Version-Compare-1.004nb4.tgz
NetBSD 8.0powerpcp5-Git-Version-Compare-1.004nb5.tgz
NetBSD 8.0powerpcp5-Git-Version-Compare-1.004nb5.tgz
NetBSD 8.0powerpcp5-Git-Version-Compare-1.004nb5.tgz
NetBSD 8.0x86_64p5-Git-Version-Compare-1.004nb4.tgz
NetBSD 8.0x86_64p5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0aarch64p5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0aarch64p5-Git-Version-Compare-1.004nb4.tgz
NetBSD 9.0aarch64p5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0alphap5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0alphap5-Git-Version-Compare-1.004nb4.tgz
NetBSD 9.0alphap5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0earmp5-Git-Version-Compare-1.004nb4.tgz
NetBSD 9.0earmp5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0earmp5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0earmv6hfp5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0earmv6hfp5-Git-Version-Compare-1.004nb4.tgz
NetBSD 9.0earmv6hfp5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0earmv7hfp5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0earmv7hfp5-Git-Version-Compare-1.004nb4.tgz
NetBSD 9.0earmv7hfp5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0earmv7hfp5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0i386p5-Git-Version-Compare-1.004nb4.tgz
NetBSD 9.0i386p5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0m68kp5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0m68kp5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0mips64ebp5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0mips64ebp5-Git-Version-Compare-1.004nb4.tgz
NetBSD 9.0mips64ebp5-Git-Version-Compare-1.004nb4.tgz
NetBSD 9.0mips64ebp5-Git-Version-Compare-1.004nb4.tgz
NetBSD 9.0mips64ebp5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0mipselp5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0mipselp5-Git-Version-Compare-1.004nb4.tgz
NetBSD 9.0mipselp5-Git-Version-Compare-1.004nb4.tgz
NetBSD 9.0mipselp5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0powerpcp5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0powerpcp5-Git-Version-Compare-1.004nb4.tgz
NetBSD 9.0powerpcp5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0powerpcp5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0sh3elp5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0sh3elp5-Git-Version-Compare-1.004nb4.tgz
NetBSD 9.0sh3elp5-Git-Version-Compare-1.004nb4.tgz
NetBSD 9.0sh3elp5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0sparc64p5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0sparc64p5-Git-Version-Compare-1.004nb4.tgz
NetBSD 9.0sparc64p5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0sparcp5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0sparcp5-Git-Version-Compare-1.004nb4.tgz
NetBSD 9.0sparcp5-Git-Version-Compare-1.004nb4.tgz
NetBSD 9.0sparcp5-Git-Version-Compare-1.004nb4.tgz
NetBSD 9.0sparcp5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0x86_64p5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0x86_64p5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0x86_64p5-Git-Version-Compare-1.004nb4.tgz
NetBSD 9.0x86_64p5-Git-Version-Compare-1.004nb5.tgz
NetBSD 9.0x86_64p5-Git-Version-Compare-1.004nb5.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.