devel/p5-Fennec-Lite - The NetBSD Packages Collection

Minimalist Fennec, the commonly used bits

Fennec does a ton, but it may be hard to adopt it all at once. It
also is a large project, and has not yet been fully split into
component projects. Fennec::Lite takes a minimalist approach to do
for Fennec what Mouse does for Moose.

Fennec::Lite is a single module file with no non-core dependencies.
It can easily be used by any project, either directly, or by copying
it into your project. The file itself is less than 300 lines of
code at the time of this writing, that includes whitespace.

Build dependencies

devel/p5-Module-Build pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Fennec-Lite-0.004nb1.tgz
NetBSD 8.0earmv7hfp5-Fennec-Lite-0.004.tgz
NetBSD 8.0earmv7hfp5-Fennec-Lite-0.004nb1.tgz
NetBSD 8.0i386p5-Fennec-Lite-0.004.tgz
NetBSD 8.0i386p5-Fennec-Lite-0.004nb1.tgz
NetBSD 8.0powerpcp5-Fennec-Lite-0.004.tgz
NetBSD 8.0powerpcp5-Fennec-Lite-0.004nb1.tgz
NetBSD 8.0powerpcp5-Fennec-Lite-0.004nb1.tgz
NetBSD 8.0powerpcp5-Fennec-Lite-0.004nb1.tgz
NetBSD 8.0x86_64p5-Fennec-Lite-0.004.tgz
NetBSD 8.0x86_64p5-Fennec-Lite-0.004nb1.tgz
NetBSD 9.0aarch64p5-Fennec-Lite-0.004nb1.tgz
NetBSD 9.0aarch64p5-Fennec-Lite-0.004.tgz
NetBSD 9.0aarch64p5-Fennec-Lite-0.004nb1.tgz
NetBSD 9.0alphap5-Fennec-Lite-0.004nb1.tgz
NetBSD 9.0alphap5-Fennec-Lite-0.004.tgz
NetBSD 9.0alphap5-Fennec-Lite-0.004nb1.tgz
NetBSD 9.0earmv6hfp5-Fennec-Lite-0.004nb1.tgz
NetBSD 9.0earmv6hfp5-Fennec-Lite-0.004.tgz
NetBSD 9.0earmv6hfp5-Fennec-Lite-0.004nb1.tgz
NetBSD 9.0earmv7hfp5-Fennec-Lite-0.004nb1.tgz
NetBSD 9.0earmv7hfp5-Fennec-Lite-0.004.tgz
NetBSD 9.0earmv7hfp5-Fennec-Lite-0.004nb1.tgz
NetBSD 9.0earmv7hfp5-Fennec-Lite-0.004nb1.tgz
NetBSD 9.0i386p5-Fennec-Lite-0.004.tgz
NetBSD 9.0i386p5-Fennec-Lite-0.004nb1.tgz
NetBSD 9.0i386p5-Fennec-Lite-0.004nb1.tgz
NetBSD 9.0mips64ebp5-Fennec-Lite-0.004nb1.tgz
NetBSD 9.0mips64ebp5-Fennec-Lite-0.004.tgz
NetBSD 9.0mips64ebp5-Fennec-Lite-0.004.tgz
NetBSD 9.0mips64ebp5-Fennec-Lite-0.004.tgz
NetBSD 9.0mips64ebp5-Fennec-Lite-0.004nb1.tgz
NetBSD 9.0powerpcp5-Fennec-Lite-0.004nb1.tgz
NetBSD 9.0powerpcp5-Fennec-Lite-0.004.tgz
NetBSD 9.0powerpcp5-Fennec-Lite-0.004nb1.tgz
NetBSD 9.0powerpcp5-Fennec-Lite-0.004nb1.tgz
NetBSD 9.0sparc64p5-Fennec-Lite-0.004nb1.tgz
NetBSD 9.0sparc64p5-Fennec-Lite-0.004.tgz
NetBSD 9.0sparc64p5-Fennec-Lite-0.004nb1.tgz
NetBSD 9.0sparcp5-Fennec-Lite-0.004nb1.tgz
NetBSD 9.0sparcp5-Fennec-Lite-0.004.tgz
NetBSD 9.0sparcp5-Fennec-Lite-0.004.tgz
NetBSD 9.0sparcp5-Fennec-Lite-0.004.tgz
NetBSD 9.0sparcp5-Fennec-Lite-0.004nb1.tgz
NetBSD 9.0x86_64p5-Fennec-Lite-0.004nb1.tgz
NetBSD 9.0x86_64p5-Fennec-Lite-0.004nb1.tgz
NetBSD 9.0x86_64p5-Fennec-Lite-0.004.tgz
NetBSD 9.0x86_64p5-Fennec-Lite-0.004nb1.tgz
NetBSD 9.0x86_64p5-Fennec-Lite-0.004nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.