devel/p5-DynaLoader-Functions - The NetBSD Packages Collection

Deconstructed dynamic C library loading

This module provides a function-based interface to dynamic loading as
used by Perl. Some details of dynamic loading are very
platform-dependent, so correct use of these functions requires the
programmer to be mindful of the space of platform variations.

Build dependencies

devel/p5-Module-Build pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 8.0earmv7hfp5-DynaLoader-Functions-0.003nb1.tgz
NetBSD 8.0earmv7hfp5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 8.0i386p5-DynaLoader-Functions-0.003nb1.tgz
NetBSD 8.0i386p5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 8.0powerpcp5-DynaLoader-Functions-0.003nb1.tgz
NetBSD 8.0powerpcp5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 8.0powerpcp5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 8.0powerpcp5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 8.0x86_64p5-DynaLoader-Functions-0.003nb1.tgz
NetBSD 8.0x86_64p5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0aarch64p5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0aarch64p5-DynaLoader-Functions-0.003nb1.tgz
NetBSD 9.0aarch64p5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0alphap5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0alphap5-DynaLoader-Functions-0.003nb1.tgz
NetBSD 9.0alphap5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0earmp5-DynaLoader-Functions-0.003nb1.tgz
NetBSD 9.0earmp5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0earmp5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0earmv6hfp5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0earmv6hfp5-DynaLoader-Functions-0.003nb1.tgz
NetBSD 9.0earmv6hfp5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0earmv7hfp5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0earmv7hfp5-DynaLoader-Functions-0.003nb1.tgz
NetBSD 9.0earmv7hfp5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0earmv7hfp5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0i386p5-DynaLoader-Functions-0.003nb1.tgz
NetBSD 9.0i386p5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0i386p5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0mips64ebp5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0mips64ebp5-DynaLoader-Functions-0.003nb1.tgz
NetBSD 9.0mips64ebp5-DynaLoader-Functions-0.003nb1.tgz
NetBSD 9.0mips64ebp5-DynaLoader-Functions-0.003nb1.tgz
NetBSD 9.0mips64ebp5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0powerpcp5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0powerpcp5-DynaLoader-Functions-0.003nb1.tgz
NetBSD 9.0powerpcp5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0powerpcp5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0sh3elp5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0sh3elp5-DynaLoader-Functions-0.003nb1.tgz
NetBSD 9.0sh3elp5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0sparc64p5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0sparc64p5-DynaLoader-Functions-0.003nb1.tgz
NetBSD 9.0sparc64p5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0sparcp5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0sparcp5-DynaLoader-Functions-0.003nb1.tgz
NetBSD 9.0sparcp5-DynaLoader-Functions-0.003nb1.tgz
NetBSD 9.0sparcp5-DynaLoader-Functions-0.003nb1.tgz
NetBSD 9.0sparcp5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0vaxp5-DynaLoader-Functions-0.003nb1.tgz
NetBSD 9.0vaxp5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0vaxp5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0x86_64p5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0x86_64p5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0x86_64p5-DynaLoader-Functions-0.003nb1.tgz
NetBSD 9.0x86_64p5-DynaLoader-Functions-0.003nb2.tgz
NetBSD 9.0x86_64p5-DynaLoader-Functions-0.003nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.