devel/p5-Dist-CheckConflicts - The NetBSD Packages Collection

Perl 5 module to declare version conflicts for your dist

One shortcoming of the CPAN clients that currently exist is that
they have no way of specifying conflicting downstream dependencies
of modules. This module attempts to work around this issue by
allowing you to specify conflicting versions of modules separately,
and deal with them after the module is done installing.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/p5-Module-Runtime devel/p5-Sub-Exporter devel/p5-Test-Fatal lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 8.0earmv7hfp5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 8.0earmv7hfp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 8.0i386p5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 8.0i386p5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 8.0powerpcp5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 8.0powerpcp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 8.0powerpcp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 8.0powerpcp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 8.0x86_64p5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 8.0x86_64p5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0aarch64p5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0aarch64p5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 9.0aarch64p5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0alphap5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0alphap5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 9.0alphap5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0earmp5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 9.0earmp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0earmp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0earmv6hfp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0earmv6hfp5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 9.0earmv6hfp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0earmv7hfp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0earmv7hfp5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 9.0earmv7hfp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0earmv7hfp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0i386p5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 9.0i386p5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0m68kp5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 9.0m68kp5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 9.0m68kp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0m68kp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0mips64ebp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0mips64ebp5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 9.0mips64ebp5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 9.0mips64ebp5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 9.0mips64ebp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0mipselp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0mipselp5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 9.0mipselp5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 9.0mipselp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0powerpcp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0powerpcp5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 9.0powerpcp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0powerpcp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0sh3elp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0sh3elp5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 9.0sh3elp5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 9.0sh3elp5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 9.0sh3elp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0sparc64p5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0sparc64p5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 9.0sparc64p5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0sparcp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0sparcp5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 9.0sparcp5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 9.0sparcp5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 9.0sparcp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0vaxp5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 9.0vaxp5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 9.0vaxp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0vaxp5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0x86_64p5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0x86_64p5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0x86_64p5-Dist-CheckConflicts-0.11nb6.tgz
NetBSD 9.0x86_64p5-Dist-CheckConflicts-0.11nb7.tgz
NetBSD 9.0x86_64p5-Dist-CheckConflicts-0.11nb7.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.