devel/p5-Data-Pageset - The NetBSD Packages Collection

Page numbering and page sets

The object produced by Data::Pageset can be used to create page
navigation, it inherits from Data::Page and has access to all
methods from this object.

In addition it also provides methods for dealing with set of pages,
so that if there are too many pages you can easily break them into
chunks for the user to browse through.

You can even choose to view page numbers in your set in a 'sliding'
fassion.

The object can easily be passed to a templating system such as
Template Toolkit or be used within a script.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/p5-Data-Page lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Data-Pageset-1.06nb12.tgz
NetBSD 8.0earmv7hfp5-Data-Pageset-1.06nb11.tgz
NetBSD 8.0earmv7hfp5-Data-Pageset-1.06nb12.tgz
NetBSD 8.0i386p5-Data-Pageset-1.06nb11.tgz
NetBSD 8.0i386p5-Data-Pageset-1.06nb12.tgz
NetBSD 8.0powerpcp5-Data-Pageset-1.06nb11.tgz
NetBSD 8.0powerpcp5-Data-Pageset-1.06nb12.tgz
NetBSD 8.0powerpcp5-Data-Pageset-1.06nb12.tgz
NetBSD 8.0powerpcp5-Data-Pageset-1.06nb12.tgz
NetBSD 8.0x86_64p5-Data-Pageset-1.06nb11.tgz
NetBSD 8.0x86_64p5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0aarch64p5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0aarch64p5-Data-Pageset-1.06nb11.tgz
NetBSD 9.0aarch64p5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0alphap5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0alphap5-Data-Pageset-1.06nb11.tgz
NetBSD 9.0alphap5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0earmp5-Data-Pageset-1.06nb11.tgz
NetBSD 9.0earmp5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0earmp5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0earmv6hfp5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0earmv6hfp5-Data-Pageset-1.06nb11.tgz
NetBSD 9.0earmv6hfp5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0earmv7hfp5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0earmv7hfp5-Data-Pageset-1.06nb11.tgz
NetBSD 9.0earmv7hfp5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0earmv7hfp5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0i386p5-Data-Pageset-1.06nb11.tgz
NetBSD 9.0i386p5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0m68kp5-Data-Pageset-1.06nb11.tgz
NetBSD 9.0m68kp5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0m68kp5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0mips64ebp5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0mips64ebp5-Data-Pageset-1.06nb11.tgz
NetBSD 9.0mips64ebp5-Data-Pageset-1.06nb11.tgz
NetBSD 9.0mips64ebp5-Data-Pageset-1.06nb11.tgz
NetBSD 9.0mips64ebp5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0mipselp5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0mipselp5-Data-Pageset-1.06nb11.tgz
NetBSD 9.0mipselp5-Data-Pageset-1.06nb11.tgz
NetBSD 9.0mipselp5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0powerpcp5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0powerpcp5-Data-Pageset-1.06nb11.tgz
NetBSD 9.0powerpcp5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0powerpcp5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0sh3elp5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0sh3elp5-Data-Pageset-1.06nb11.tgz
NetBSD 9.0sh3elp5-Data-Pageset-1.06nb11.tgz
NetBSD 9.0sh3elp5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0sparc64p5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0sparc64p5-Data-Pageset-1.06nb11.tgz
NetBSD 9.0sparc64p5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0sparcp5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0sparcp5-Data-Pageset-1.06nb11.tgz
NetBSD 9.0sparcp5-Data-Pageset-1.06nb11.tgz
NetBSD 9.0sparcp5-Data-Pageset-1.06nb11.tgz
NetBSD 9.0sparcp5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0vaxp5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0vaxp5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0x86_64p5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0x86_64p5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0x86_64p5-Data-Pageset-1.06nb11.tgz
NetBSD 9.0x86_64p5-Data-Pageset-1.06nb12.tgz
NetBSD 9.0x86_64p5-Data-Pageset-1.06nb12.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.