devel/p5-CLI-Osprey - The NetBSD Packages Collection

MooX::Options + MooX::Cmd + Sanity

CLI::Osprey is a module to assist in writing commandline applications
with M* OO modules (Moose, Moo, Mo). With it, you structure your app
as one or more modules, which get instantiated with the commandline
arguments as attributes. Arguments are parsed using Getopt::Long::Descriptive,
and both long and short help messages as well as complete manual pages
are automatically generated. An app can be a single command with options,
or have sub-commands (like git). Sub-commands can be defined as modules
(with options of their own) or as simple coderefs.

Build dependencies

devel/p5-Module-Build-Tiny pkgtools/cwrappers

Runtime dependencies

devel/p5-Moo devel/p5-Getopt-Long-Descriptive filesystems/p5-Path-Tiny lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-CLI-Osprey-0.08nb2.tgz
NetBSD 8.0earmv7hfp5-CLI-Osprey-0.08nb2.tgz
NetBSD 8.0i386p5-CLI-Osprey-0.08nb2.tgz
NetBSD 8.0powerpcp5-CLI-Osprey-0.08nb2.tgz
NetBSD 8.0powerpcp5-CLI-Osprey-0.08nb2.tgz
NetBSD 8.0powerpcp5-CLI-Osprey-0.08nb2.tgz
NetBSD 8.0x86_64p5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0aarch64p5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0aarch64p5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0alphap5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0alphap5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0earmp5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0earmp5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0earmv6hfp5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0earmv6hfp5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0earmv7hfp5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0earmv7hfp5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0earmv7hfp5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0i386p5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0i386p5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0mips64ebp5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0mips64ebp5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0powerpcp5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0powerpcp5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0powerpcp5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0sh3elp5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0sh3elp5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0sparc64p5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0sparc64p5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0sparcp5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0sparcp5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0vaxp5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0vaxp5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0x86_64p5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0x86_64p5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0x86_64p5-CLI-Osprey-0.08nb2.tgz
NetBSD 9.0x86_64p5-CLI-Osprey-0.08nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.