devel/mantis - The NetBSD Packages Collection

PHP/MySQL/web based bugtracking system

Mantis is a web-based bugtracking system. It is written in the PHP scripting
language and requires the MySQL database and a webserver. Mantis has been
installed on Windows, MacOS, OS/2, and a variety of Unix operating systems.
Almost any web browser should be able to function as a client. It is released
under the terms of the GNU General Public License (GPL).

Mantis is free to use and modify. It is free to redistribute as long as you
abide by the distribution terms of the GPL.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

databases/php-mysqli textproc/php-json shells/bash

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfmantis-2.4.1nb1.tgz
NetBSD 8.0earmv7hfmantis-2.4.1nb1.tgz
NetBSD 8.0earmv7hfphp56-mantis-2.24.5.tgz
NetBSD 8.0earmv7hfphp73-mantis-2.24.5.tgz
NetBSD 8.0earmv7hfphp74-mantis-2.24.5.tgz
NetBSD 8.0earmv7hfphp80-mantis-2.24.5.tgz
NetBSD 8.0i386mantis-2.4.1nb1.tgz
NetBSD 8.0i386mantis-2.4.1nb1.tgz
NetBSD 8.0i386php56-mantis-2.24.5.tgz
NetBSD 8.0i386php73-mantis-2.24.5.tgz
NetBSD 8.0i386php74-mantis-2.24.5.tgz
NetBSD 8.0i386php80-mantis-2.24.5.tgz
NetBSD 8.0x86_64php56-mantis-2.24.5.tgz
NetBSD 8.0x86_64php73-mantis-2.24.5.tgz
NetBSD 8.0x86_64php74-mantis-2.24.5.tgz
NetBSD 8.0x86_64php80-mantis-2.24.5.tgz
NetBSD 8.0x86_64mantis-2.4.1nb1.tgz
NetBSD 8.0x86_64mantis-2.4.1nb1.tgz
NetBSD 9.0aarch64php56-mantis-2.24.5.tgz
NetBSD 9.0aarch64php73-mantis-2.24.5.tgz
NetBSD 9.0aarch64php74-mantis-2.24.5.tgz
NetBSD 9.0aarch64php80-mantis-2.24.5.tgz
NetBSD 9.0aarch64mantis-2.4.1nb1.tgz
NetBSD 9.0aarch64mantis-2.4.1nb1.tgz
NetBSD 9.0earmv6hfphp56-mantis-2.24.5.tgz
NetBSD 9.0earmv6hfphp73-mantis-2.24.5.tgz
NetBSD 9.0earmv6hfphp74-mantis-2.24.5.tgz
NetBSD 9.0earmv6hfphp80-mantis-2.24.5.tgz
NetBSD 9.0earmv6hfmantis-2.4.1nb1.tgz
NetBSD 9.0earmv6hfmantis-2.4.1nb1.tgz
NetBSD 9.0earmv6hfmantis-2.4.1nb1.tgz
NetBSD 9.0earmv7hfphp56-mantis-2.24.5.tgz
NetBSD 9.0earmv7hfphp73-mantis-2.24.5.tgz
NetBSD 9.0earmv7hfphp74-mantis-2.24.5.tgz
NetBSD 9.0earmv7hfphp80-mantis-2.24.5.tgz
NetBSD 9.0earmv7hfmantis-2.4.1nb1.tgz
NetBSD 9.0earmv7hfmantis-2.4.1nb1.tgz
NetBSD 9.0earmv7hfmantis-2.4.1nb1.tgz
NetBSD 9.0earmv7hfphp56-mantis-2.24.5.tgz
NetBSD 9.0earmv7hfphp73-mantis-2.24.5.tgz
NetBSD 9.0earmv7hfphp74-mantis-2.24.5.tgz
NetBSD 9.0earmv7hfphp80-mantis-2.24.5.tgz
NetBSD 9.0i386mantis-2.4.1nb1.tgz
NetBSD 9.0i386mantis-2.4.1nb1.tgz
NetBSD 9.0i386php56-mantis-2.24.5.tgz
NetBSD 9.0i386php73-mantis-2.24.5.tgz
NetBSD 9.0i386php74-mantis-2.24.5.tgz
NetBSD 9.0i386php80-mantis-2.24.5.tgz
NetBSD 9.0mips64ebphp56-mantis-2.24.5.tgz
NetBSD 9.0mips64ebphp73-mantis-2.24.5.tgz
NetBSD 9.0mips64ebphp74-mantis-2.24.5.tgz
NetBSD 9.0mips64ebphp80-mantis-2.24.5.tgz
NetBSD 9.0mips64ebmantis-2.4.1nb1.tgz
NetBSD 9.0mips64ebmantis-2.4.1nb1.tgz
NetBSD 9.0sparc64php56-mantis-2.24.5.tgz
NetBSD 9.0sparc64php73-mantis-2.24.5.tgz
NetBSD 9.0sparc64php74-mantis-2.24.5.tgz
NetBSD 9.0sparc64php80-mantis-2.24.5.tgz
NetBSD 9.0sparc64mantis-2.4.1nb1.tgz
NetBSD 9.0sparc64mantis-2.4.1nb1.tgz
NetBSD 9.0x86_64mantis-2.4.1nb1.tgz
NetBSD 9.0x86_64mantis-2.4.1nb1.tgz
NetBSD 9.0x86_64mantis-2.4.1nb1.tgz
NetBSD 9.0x86_64php56-mantis-2.24.5.tgz
NetBSD 9.0x86_64php73-mantis-2.24.5.tgz
NetBSD 9.0x86_64php74-mantis-2.24.5.tgz
NetBSD 9.0x86_64php80-mantis-2.24.5.tgz
NetBSD 9.0x86_64mantis-2.4.1nb1.tgz
NetBSD 9.0x86_64mantis-2.4.1nb1.tgz
NetBSD 9.0x86_64php56-mantis-2.24.5.tgz
NetBSD 9.0x86_64php73-mantis-2.24.5.tgz
NetBSD 9.0x86_64php74-mantis-2.24.5.tgz
NetBSD 9.0x86_64php80-mantis-2.24.5.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

charts
ldap
Enable LDAP support.
mysql
Enable MySQL support.
pgsql
Enable PostgreSQL support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.