devel/libtar - The NetBSD Packages Collection

Library for manipulating POSIX tar files

Libtar is a library for manipulating tar files from within C programs.
Key features:

  - Handles both POSIX 1003.1-1990 tar file format and the GNU extensions.
  - API provides functions for easy use, such as tar_extract_all().
  - Also provides functions for more granular use, such as
    tar_append_regfile().
  - Support compressed tar file by way of zlib.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/automake devel/autoconf devel/gmake

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibtar-1.2.20.tgz
NetBSD 8.0earmv7hflibtar-1.2.20.tgz
NetBSD 8.0earmv7hflibtar-1.2.20.tgz
NetBSD 8.0i386libtar-1.2.20.tgz
NetBSD 8.0i386libtar-1.2.20.tgz
NetBSD 8.0powerpclibtar-1.2.20.tgz
NetBSD 8.0powerpclibtar-1.2.20.tgz
NetBSD 8.0powerpclibtar-1.2.20.tgz
NetBSD 8.0powerpclibtar-1.2.20.tgz
NetBSD 8.0x86_64libtar-1.2.20.tgz
NetBSD 8.0x86_64libtar-1.2.20.tgz
NetBSD 9.0aarch64libtar-1.2.20.tgz
NetBSD 9.0aarch64libtar-1.2.20.tgz
NetBSD 9.0aarch64libtar-1.2.20.tgz
NetBSD 9.0alphalibtar-1.2.20.tgz
NetBSD 9.0alphalibtar-1.2.20.tgz
NetBSD 9.0alphalibtar-1.2.20.tgz
NetBSD 9.0earmlibtar-1.2.20.tgz
NetBSD 9.0earmlibtar-1.2.20.tgz
NetBSD 9.0earmlibtar-1.2.20.tgz
NetBSD 9.0earmv6hflibtar-1.2.20.tgz
NetBSD 9.0earmv6hflibtar-1.2.20.tgz
NetBSD 9.0earmv6hflibtar-1.2.20.tgz
NetBSD 9.0earmv7hflibtar-1.2.20.tgz
NetBSD 9.0earmv7hflibtar-1.2.20.tgz
NetBSD 9.0earmv7hflibtar-1.2.20.tgz
NetBSD 9.0earmv7hflibtar-1.2.20.tgz
NetBSD 9.0i386libtar-1.2.20.tgz
NetBSD 9.0i386libtar-1.2.20.tgz
NetBSD 9.0i386libtar-1.2.20.tgz
NetBSD 9.0mips64eblibtar-1.2.20.tgz
NetBSD 9.0mips64eblibtar-1.2.20.tgz
NetBSD 9.0mips64eblibtar-1.2.20.tgz
NetBSD 9.0mips64eblibtar-1.2.20.tgz
NetBSD 9.0mips64eblibtar-1.2.20.tgz
NetBSD 9.0powerpclibtar-1.2.20.tgz
NetBSD 9.0powerpclibtar-1.2.20.tgz
NetBSD 9.0powerpclibtar-1.2.20.tgz
NetBSD 9.0powerpclibtar-1.2.20.tgz
NetBSD 9.0sparc64libtar-1.2.20.tgz
NetBSD 9.0sparc64libtar-1.2.20.tgz
NetBSD 9.0sparc64libtar-1.2.20.tgz
NetBSD 9.0sparclibtar-1.2.20.tgz
NetBSD 9.0sparclibtar-1.2.20.tgz
NetBSD 9.0sparclibtar-1.2.20.tgz
NetBSD 9.0sparclibtar-1.2.20.tgz
NetBSD 9.0sparclibtar-1.2.20.tgz
NetBSD 9.0x86_64libtar-1.2.20.tgz
NetBSD 9.0x86_64libtar-1.2.20.tgz
NetBSD 9.0x86_64libtar-1.2.20.tgz
NetBSD 9.0x86_64libtar-1.2.20.tgz
NetBSD 9.0x86_64libtar-1.2.20.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.