devel/libsafec - The NetBSD Packages Collection

C bounds checking memory and string functions library

The Safe C Library provides bound checking memory and string functions
per ISO/IEC TR24731.  These functions are alternative functions to the
existing standard C library that promote safer, more secure
programming.

The ISO/IEC Programming languages -- C spec, C11, now includes the
bounded APIs in Appendix K, "Bounds-checking interfaces".

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/pkgconf

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibsafec-10052013.tgz
NetBSD 8.0earmv7hflibsafec-10052013.tgz
NetBSD 8.0earmv7hflibsafec-10052013.tgz
NetBSD 8.0i386libsafec-10052013.tgz
NetBSD 8.0i386libsafec-10052013.tgz
NetBSD 8.0powerpclibsafec-10052013.tgz
NetBSD 8.0powerpclibsafec-10052013.tgz
NetBSD 8.0powerpclibsafec-10052013.tgz
NetBSD 8.0powerpclibsafec-10052013.tgz
NetBSD 8.0x86_64libsafec-10052013.tgz
NetBSD 8.0x86_64libsafec-10052013.tgz
NetBSD 9.0aarch64libsafec-10052013.tgz
NetBSD 9.0aarch64libsafec-10052013.tgz
NetBSD 9.0aarch64libsafec-10052013.tgz
NetBSD 9.0alphalibsafec-10052013.tgz
NetBSD 9.0alphalibsafec-10052013.tgz
NetBSD 9.0alphalibsafec-10052013.tgz
NetBSD 9.0earmlibsafec-10052013.tgz
NetBSD 9.0earmlibsafec-10052013.tgz
NetBSD 9.0earmlibsafec-10052013.tgz
NetBSD 9.0earmv6hflibsafec-10052013.tgz
NetBSD 9.0earmv6hflibsafec-10052013.tgz
NetBSD 9.0earmv6hflibsafec-10052013.tgz
NetBSD 9.0earmv7hflibsafec-10052013.tgz
NetBSD 9.0earmv7hflibsafec-10052013.tgz
NetBSD 9.0earmv7hflibsafec-10052013.tgz
NetBSD 9.0earmv7hflibsafec-10052013.tgz
NetBSD 9.0i386libsafec-10052013.tgz
NetBSD 9.0i386libsafec-10052013.tgz
NetBSD 9.0i386libsafec-10052013.tgz
NetBSD 9.0mips64eblibsafec-10052013.tgz
NetBSD 9.0mips64eblibsafec-10052013.tgz
NetBSD 9.0mips64eblibsafec-10052013.tgz
NetBSD 9.0mips64eblibsafec-10052013.tgz
NetBSD 9.0mips64eblibsafec-10052013.tgz
NetBSD 9.0powerpclibsafec-10052013.tgz
NetBSD 9.0powerpclibsafec-10052013.tgz
NetBSD 9.0powerpclibsafec-10052013.tgz
NetBSD 9.0powerpclibsafec-10052013.tgz
NetBSD 9.0sparc64libsafec-10052013.tgz
NetBSD 9.0sparc64libsafec-10052013.tgz
NetBSD 9.0sparc64libsafec-10052013.tgz
NetBSD 9.0sparclibsafec-10052013.tgz
NetBSD 9.0sparclibsafec-10052013.tgz
NetBSD 9.0sparclibsafec-10052013.tgz
NetBSD 9.0sparclibsafec-10052013.tgz
NetBSD 9.0sparclibsafec-10052013.tgz
NetBSD 9.0x86_64libsafec-10052013.tgz
NetBSD 9.0x86_64libsafec-10052013.tgz
NetBSD 9.0x86_64libsafec-10052013.tgz
NetBSD 9.0x86_64libsafec-10052013.tgz
NetBSD 9.0x86_64libsafec-10052013.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.