devel/libcerf - The NetBSD Packages Collection

Library providing efficient and accurate complex error functions

This is libcerf, a self-contained numeric library that provides an
efficient and accurate implementation of complex error functions,
along with Dawson, Faddeeva, and Voigt functions.

On current GNU/Linux systems, the man page complex(7) has a "see
also" section that lists complex mathematical functions like cabs(3),
cacos(3), and so on. Among them, there is a complex error function.
However, its manual page cerf(3) describes the functions cerf and
cerfc as "unimplemented" and "reserved for future use". The present
library libcerf provides the missing implementation, along with a
related functions. It comes with a set of man pages, including a
page cerf(3) that overwrites the standard one.

Build dependencies

pkgtools/cwrappers devel/cmake lang/perl5

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibcerf-1.13.tgz
NetBSD 8.0earmv7hflibcerf-1.13.tgz
NetBSD 8.0earmv7hflibcerf-1.13.tgz
NetBSD 8.0i386libcerf-1.13.tgz
NetBSD 8.0i386libcerf-1.13.tgz
NetBSD 8.0powerpclibcerf-1.13.tgz
NetBSD 8.0powerpclibcerf-1.13.tgz
NetBSD 8.0powerpclibcerf-1.13.tgz
NetBSD 8.0powerpclibcerf-1.13.tgz
NetBSD 8.0x86_64libcerf-1.13.tgz
NetBSD 8.0x86_64libcerf-1.13.tgz
NetBSD 9.0aarch64libcerf-1.13.tgz
NetBSD 9.0aarch64libcerf-1.13.tgz
NetBSD 9.0aarch64libcerf-1.13.tgz
NetBSD 9.0alphalibcerf-1.13.tgz
NetBSD 9.0alphalibcerf-1.13.tgz
NetBSD 9.0alphalibcerf-1.13.tgz
NetBSD 9.0earmlibcerf-1.13.tgz
NetBSD 9.0earmlibcerf-1.13.tgz
NetBSD 9.0earmlibcerf-1.13.tgz
NetBSD 9.0earmv6hflibcerf-1.13.tgz
NetBSD 9.0earmv6hflibcerf-1.13.tgz
NetBSD 9.0earmv6hflibcerf-1.13.tgz
NetBSD 9.0earmv7hflibcerf-1.13.tgz
NetBSD 9.0earmv7hflibcerf-1.13.tgz
NetBSD 9.0earmv7hflibcerf-1.13.tgz
NetBSD 9.0earmv7hflibcerf-1.13.tgz
NetBSD 9.0i386libcerf-1.13.tgz
NetBSD 9.0i386libcerf-1.13.tgz
NetBSD 9.0i386libcerf-1.13.tgz
NetBSD 9.0m68klibcerf-1.13.tgz
NetBSD 9.0m68klibcerf-1.13.tgz
NetBSD 9.0m68klibcerf-1.13.tgz
NetBSD 9.0m68klibcerf-1.13.tgz
NetBSD 9.0mips64eblibcerf-1.13.tgz
NetBSD 9.0mips64eblibcerf-1.13.tgz
NetBSD 9.0mips64eblibcerf-1.13.tgz
NetBSD 9.0mips64eblibcerf-1.13.tgz
NetBSD 9.0mips64eblibcerf-1.13.tgz
NetBSD 9.0mipsellibcerf-1.13.tgz
NetBSD 9.0mipsellibcerf-1.13.tgz
NetBSD 9.0mipsellibcerf-1.13.tgz
NetBSD 9.0powerpclibcerf-1.13.tgz
NetBSD 9.0powerpclibcerf-1.13.tgz
NetBSD 9.0powerpclibcerf-1.13.tgz
NetBSD 9.0powerpclibcerf-1.13.tgz
NetBSD 9.0sh3ellibcerf-1.13.tgz
NetBSD 9.0sh3ellibcerf-1.13.tgz
NetBSD 9.0sh3ellibcerf-1.13.tgz
NetBSD 9.0sh3ellibcerf-1.13.tgz
NetBSD 9.0sh3ellibcerf-1.13.tgz
NetBSD 9.0sparc64libcerf-1.13.tgz
NetBSD 9.0sparc64libcerf-1.13.tgz
NetBSD 9.0sparc64libcerf-1.13.tgz
NetBSD 9.0sparclibcerf-1.13.tgz
NetBSD 9.0sparclibcerf-1.13.tgz
NetBSD 9.0sparclibcerf-1.13.tgz
NetBSD 9.0sparclibcerf-1.13.tgz
NetBSD 9.0sparclibcerf-1.13.tgz
NetBSD 9.0x86_64libcerf-1.13.tgz
NetBSD 9.0x86_64libcerf-1.13.tgz
NetBSD 9.0x86_64libcerf-1.13.tgz
NetBSD 9.0x86_64libcerf-1.13.tgz
NetBSD 9.0x86_64libcerf-1.13.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.