Daemon Power

The NetBSD Packages Collection: devel/js_of_ocaml

Brief description of the package:
Compiler of OCaml bytecode to Javascript

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://ocsigen.org/js_of_ocaml/.

Please note that this package has a gnu-lgpl-v2 license.

The package is located in the "devel/js_of_ocaml" directory. The current source version of the package is "js_of_ocaml-3.5.2". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for devel/js_of_ocaml :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: ocaml-tyxml>=4.0.1 ocaml-dune>=2.0.0 ocaml-findlib>=1.2 ocaml>=4.09.0 cwrappers>=20150314 ocaml-findlib>=1.8.1 ocaml-opaline>=0.3.1 ocaml-opam-file-format>=2.0.0 ocamlbuild>=0.9.2 ocamlbuild>=0.14.0 ocaml-opaline>=0.3.2 ocaml-ppx_tools_versioned>=5.0.1 ocaml-migrate-parsetree>=1.0.1 ocaml-ppx_derivers>=1.0 ocaml-dune>=2.1.3nb1 ocaml-result>=1.2 ocaml-ppx_derivers>=1.2.1 ocaml-result>=1.4 ocaml-migrate-parsetree>=1.5.0 ocaml-re>=1.6.0 ocaml-seq>=0.1 ocaml-markup>=0.7.2 ocaml-uutf>=0.9.3nb1 ocaml-topkg>=1.0.0 ocaml-cmdliner>=0.9.8 ocaml-uchar>=0.0.1 ocaml-cmdliner>=1.0.3 ocaml-uchar>=0.0.2 ocaml-uutf>=1.0.2 ocaml-ppx_tools_versioned>=5.3.0 ocaml-re>=1.9.0nb1 ocaml-markup>=0.8.2 ocaml-reactiveData>=0.2.1 ocaml-react>=1.2.0nb1 ocaml-react>=1.2.1nb4 ocaml-cppo>=1.3.1 ocaml-lwt>=5.0.0 libev>=3.9nb1 ocaml-mmap>=1.1.0 ocaml-ocplib-endian>=1.0 ocaml-cppo>=1.6.6 libev>=4.01 ocaml-lwt_log>=1.1.0 ocaml-lwt>=5.2.0 ocaml-ppx_deriving>=4.0 ocaml-ppx_tools>=6.0 ocaml-ppxfind>=1.3 ocaml-ppxlib>=0.3.0 ocaml-base>=0.9.3 ocaml-sexplib0>=0.11.0 ocaml-sexplib0>=0.13.0 ocaml-compiler-libs>=0.9.0 ocaml-stdio>=0.9.0 ocaml-base>=0.13.1 ocaml-compiler-libs>=0.12.1 ocaml-stdio>=0.13.0 ocaml-tyxml>=4.4.0 ocaml-reactiveData>=0.2.2 ocaml-lwt_log>=1.1.1 ocaml-ppx_deriving>=4.4.1 ocaml-ppxlib>=0.12.0 .

This package requires the following package(s) to run: ocaml-tyxml>=4.0.1 ocaml-dune>=2.0.0 ocaml-findlib>=1.2 ocaml>=4.09.0 ocaml-findlib>=1.8.1 ocaml-ppx_tools_versioned>=5.0.1 ocaml-migrate-parsetree>=1.0.1 ocaml-ppx_derivers>=1.0 ocaml-dune>=2.1.3nb1 ocaml-result>=1.2 ocaml-ppx_derivers>=1.2.1 ocaml-result>=1.4 ocaml-migrate-parsetree>=1.5.0 ocaml-re>=1.6.0 ocaml-seq>=0.1 ocaml-markup>=0.7.2 ocaml-uutf>=0.9.3nb1 ocaml-topkg>=1.0.0 ocaml-cmdliner>=0.9.8 ocaml-uchar>=0.0.1 ocaml-cmdliner>=1.0.3 ocaml-uchar>=0.0.2 ocaml-uutf>=1.0.2 ocaml-ppx_tools_versioned>=5.3.0 ocaml-re>=1.9.0nb1 ocaml-markup>=0.8.2 ocaml-reactiveData>=0.2.1 ocaml-react>=1.2.0nb1 ocaml-react>=1.2.1nb4 ocaml-cppo>=1.3.1 ocamlbuild>=0.9.2 ocamlbuild>=0.14.0 ocaml-lwt>=5.0.0 libev>=3.9nb1 ocaml-mmap>=1.1.0 ocaml-ocplib-endian>=1.0 ocaml-cppo>=1.6.6 libev>=4.01 ocaml-lwt_log>=1.1.0 ocaml-lwt>=5.2.0 ocaml-ppx_deriving>=4.0 ocaml-ppx_tools>=6.0 ocaml-ppxfind>=1.3 ocaml-ppxlib>=0.3.0 ocaml-base>=0.9.3 ocaml-sexplib0>=0.11.0 ocaml-sexplib0>=0.13.0 ocaml-compiler-libs>=0.9.0 ocaml-stdio>=0.9.0 ocaml-base>=0.13.1 ocaml-compiler-libs>=0.12.1 ocaml-stdio>=0.13.0 ocaml-tyxml>=4.4.0 ocaml-reactiveData>=0.2.2 ocaml-lwt_log>=1.1.1 ocaml-ppx_deriving>=4.4.1 ocaml-ppxlib>=0.12.0 .

This package supports the following build-time options:

ocaml-tyxml
Enable OCaml-tyxml support

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
aarch64:js_of_ocaml-3.4.0.tgz(NetBSD 9.0)
i386:js_of_ocaml-3.4.0.tgz(NetBSD 7.0)
i386:js_of_ocaml-3.4.0.tgz(NetBSD 7.0)
i386:js_of_ocaml-3.4.0.tgz(NetBSD 7.1)
i386:js_of_ocaml-3.4.0.tgz(NetBSD 7.1)
i386:js_of_ocaml-3.4.0.tgz(NetBSD 8.0)
i386:js_of_ocaml-3.4.0.tgz(NetBSD 8.0)
i386:js_of_ocaml-3.4.0.tgz(NetBSD 9.0)
x86_64:js_of_ocaml-3.5.2.tgz(NetBSD 9.0)
x86_64:js_of_ocaml-3.5.2.tgz(NetBSD 9.0)
x86_64:js_of_ocaml-3.4.0.tgz(NetBSD 7.0)
x86_64:js_of_ocaml-3.4.0.tgz(NetBSD 7.0)
x86_64:js_of_ocaml-3.4.0.tgz(NetBSD 7.1)
x86_64:js_of_ocaml-3.4.0.tgz(NetBSD 7.1)
x86_64:js_of_ocaml-3.4.0.tgz(NetBSD 8.0)
x86_64:js_of_ocaml-3.4.0.tgz(NetBSD 8.0)
x86_64:js_of_ocaml-3.4.0.tgz(NetBSD 9.0)
x86_64:js_of_ocaml-3.5.2.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]