devel/js2-mode - The NetBSD Packages Collection

Improved JavaScript mode for GNU Emacs

This JavaScript editing mode supports:

 - the full JavaScript language through version 1.7
 - accurate syntax highlighting using a recursive-descent parser
 - syntax-error and strict-mode warning reporting
 - "bouncing" line indentation to choose among alternate indentation points
 - smart line-wrapping within comments and strings
 - code folding:
   - show some or all function bodies as {...}
   - show some or all block comments as /*...*/
 - context-sensitive menu bar and popup menus
 - typing helpers (e.g. inserting matching braces/parens)
 - many customization options

Build dependencies

pkgtools/cwrappers

Runtime dependencies

editors/emacs26

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfjs2-20080406nb2.tgz
NetBSD 8.0earmv7hfjs2-20080406nb2.tgz
NetBSD 8.0earmv7hfjs2-20080406nb2.tgz
NetBSD 8.0i386js2-20080406nb2.tgz
NetBSD 8.0i386js2-20080406nb2.tgz
NetBSD 8.0powerpcjs2-20080406nb2.tgz
NetBSD 8.0powerpcjs2-20080406nb2.tgz
NetBSD 8.0powerpcjs2-20080406nb2.tgz
NetBSD 8.0powerpcjs2-20080406nb2.tgz
NetBSD 8.0x86_64js2-20080406nb2.tgz
NetBSD 8.0x86_64js2-20080406nb2.tgz
NetBSD 9.0aarch64js2-20080406nb2.tgz
NetBSD 9.0aarch64js2-20080406nb2.tgz
NetBSD 9.0aarch64js2-20080406nb2.tgz
NetBSD 9.0alphajs2-20080406nb2.tgz
NetBSD 9.0alphajs2-20080406nb2.tgz
NetBSD 9.0alphajs2-20080406nb2.tgz
NetBSD 9.0earmv6hfjs2-20080406nb2.tgz
NetBSD 9.0earmv6hfjs2-20080406nb2.tgz
NetBSD 9.0earmv6hfjs2-20080406nb2.tgz
NetBSD 9.0earmv7hfjs2-20080406nb2.tgz
NetBSD 9.0earmv7hfjs2-20080406nb2.tgz
NetBSD 9.0earmv7hfjs2-20080406nb2.tgz
NetBSD 9.0earmv7hfjs2-20080406nb2.tgz
NetBSD 9.0i386js2-20080406nb2.tgz
NetBSD 9.0i386js2-20080406nb2.tgz
NetBSD 9.0i386js2-20080406nb2.tgz
NetBSD 9.0powerpcjs2-20080406nb2.tgz
NetBSD 9.0powerpcjs2-20080406nb2.tgz
NetBSD 9.0powerpcjs2-20080406nb2.tgz
NetBSD 9.0powerpcjs2-20080406nb2.tgz
NetBSD 9.0sparc64js2-20080406nb2.tgz
NetBSD 9.0sparc64js2-20080406nb2.tgz
NetBSD 9.0sparc64js2-20080406nb2.tgz
NetBSD 9.0sparcjs2-20080406nb2.tgz
NetBSD 9.0sparcjs2-20080406nb2.tgz
NetBSD 9.0sparcjs2-20080406nb2.tgz
NetBSD 9.0sparcjs2-20080406nb2.tgz
NetBSD 9.0sparcjs2-20080406nb2.tgz
NetBSD 9.0x86_64js2-20080406nb2.tgz
NetBSD 9.0x86_64js2-20080406nb2.tgz
NetBSD 9.0x86_64js2-20080406nb2.tgz
NetBSD 9.0x86_64js2-20080406nb2.tgz
NetBSD 9.0x86_64js2-20080406nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.