devel/guile-gnome - The NetBSD Packages Collection

Library to access gobject/glib/gtk and gnome from guile

The guile-gnome project brings the power of Scheme to your graphical
application.  guile-gnome modules support the entire Gnome library
stack: from Pango to GnomeCanvas, Gtk+ to GStreamer, Glade to
GtkSourceView, you will find in guile-gnome a comprehensive
environment for developing modern applications.

Build dependencies

x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/libtool-base devel/gmake devel/pkgconf

Runtime dependencies

devel/guile-slib devel/atk devel/glib2 devel/g-wrap lang/guile20 devel/GConf net/ORBit2 devel/libbonobo devel/libglade x11/gtk2 devel/pango graphics/cairo devel/libgnome devel/libgnomeui graphics/libgnomecanvas graphics/guile-cairo graphics/guile-cairo devel/atk devel/glib2 devel/g-wrap lang/guile20 devel/GConf net/ORBit2 devel/libbonobo devel/libglade x11/gtk2 devel/pango graphics/cairo devel/libgnome devel/libgnomeui graphics/libgnomecanvas

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfguile-gnome-platform-2.16.5nb11.tgz
NetBSD 8.0earmv7hfguile-gnome-platform-2.16.5nb10.tgz
NetBSD 8.0earmv7hfguile-gnome-platform-2.16.5nb11.tgz
NetBSD 8.0i386guile-gnome-platform-2.16.5nb10.tgz
NetBSD 8.0i386guile-gnome-platform-2.16.5nb11.tgz
NetBSD 8.0powerpcguile-gnome-platform-2.16.5nb10.tgz
NetBSD 8.0powerpcguile-gnome-platform-2.16.5nb11.tgz
NetBSD 8.0powerpcguile-gnome-platform-2.16.5nb11.tgz
NetBSD 8.0powerpcguile-gnome-platform-2.16.5nb11.tgz
NetBSD 8.0x86_64guile-gnome-platform-2.16.5nb10.tgz
NetBSD 8.0x86_64guile-gnome-platform-2.16.5nb11.tgz
NetBSD 9.0aarch64guile-gnome-platform-2.16.5nb11.tgz
NetBSD 9.0aarch64guile-gnome-platform-2.16.5nb10.tgz
NetBSD 9.0aarch64guile-gnome-platform-2.16.5nb11.tgz
NetBSD 9.0alphaguile-gnome-platform-2.16.5nb11.tgz
NetBSD 9.0alphaguile-gnome-platform-2.16.5nb10.tgz
NetBSD 9.0alphaguile-gnome-platform-2.16.5nb11.tgz
NetBSD 9.0earmv6hfguile-gnome-platform-2.16.5nb11.tgz
NetBSD 9.0earmv6hfguile-gnome-platform-2.16.5nb10.tgz
NetBSD 9.0earmv6hfguile-gnome-platform-2.16.5nb11.tgz
NetBSD 9.0earmv7hfguile-gnome-platform-2.16.5nb11.tgz
NetBSD 9.0earmv7hfguile-gnome-platform-2.16.5nb10.tgz
NetBSD 9.0earmv7hfguile-gnome-platform-2.16.5nb11.tgz
NetBSD 9.0earmv7hfguile-gnome-platform-2.16.5nb11.tgz
NetBSD 9.0i386guile-gnome-platform-2.16.5nb10.tgz
NetBSD 9.0i386guile-gnome-platform-2.16.5nb11.tgz
NetBSD 9.0mips64ebguile-gnome-platform-2.16.5nb11.tgz
NetBSD 9.0mips64ebguile-gnome-platform-2.16.5nb9.tgz
NetBSD 9.0mips64ebguile-gnome-platform-2.16.5nb10.tgz
NetBSD 9.0mips64ebguile-gnome-platform-2.16.5nb10.tgz
NetBSD 9.0mips64ebguile-gnome-platform-2.16.5nb11.tgz
NetBSD 9.0powerpcguile-gnome-platform-2.16.5nb11.tgz
NetBSD 9.0powerpcguile-gnome-platform-2.16.5nb10.tgz
NetBSD 9.0powerpcguile-gnome-platform-2.16.5nb11.tgz
NetBSD 9.0powerpcguile-gnome-platform-2.16.5nb11.tgz
NetBSD 9.0sparc64guile-gnome-platform-2.16.5nb11.tgz
NetBSD 9.0sparc64guile-gnome-platform-2.16.5nb10.tgz
NetBSD 9.0sparc64guile-gnome-platform-2.16.5nb11.tgz
NetBSD 9.0sparcguile-gnome-platform-2.16.5nb11.tgz
NetBSD 9.0sparcguile-gnome-platform-2.16.5nb10.tgz
NetBSD 9.0sparcguile-gnome-platform-2.16.5nb11.tgz
NetBSD 9.0x86_64guile-gnome-platform-2.16.5nb11.tgz
NetBSD 9.0x86_64guile-gnome-platform-2.16.5nb11.tgz
NetBSD 9.0x86_64guile-gnome-platform-2.16.5nb10.tgz
NetBSD 9.0x86_64guile-gnome-platform-2.16.5nb11.tgz
NetBSD 9.0x86_64guile-gnome-platform-2.16.5nb11.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.