devel/gengetopt - The NetBSD Packages Collection

Command line parser generator

This program generates a C function that uses getopt_long function
to parse the command line options, to validate them and fills a
struct .

Thus your program can now handle options such as:

myprog --input foo.c -o foo.o --no-tabs -i 100 *.class

And both long options (those that start with --) and short options
(start with - and consist of only one character) can be handled.

Gengetopt can also generate a function to save the command line
options into a file, and a function to read the command line options
from a file. Of course, these two kinds of files are compliant.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/gmake

Runtime dependencies

(none)

Available binary packages

aarch64:gengetopt-2.22.6.tgz(NetBSD 9.0)
aarch64:gengetopt-2.22.6.tgz(NetBSD 9.0)
aarch64:gengetopt-2.22.6.tgz(NetBSD 9.0)
alpha:gengetopt-2.22.6.tgz(NetBSD 9.0)
alpha:gengetopt-2.22.6.tgz(NetBSD 9.0)
earm:gengetopt-2.22.6.tgz(NetBSD 9.0)
earmv6hf:gengetopt-2.22.6.tgz(NetBSD 9.0)
earmv6hf:gengetopt-2.22.6.tgz(NetBSD 9.0)
earmv6hf:gengetopt-2.22.6.tgz(NetBSD 9.0)
earmv6hf:gengetopt-2.22.6.tgz(NetBSD 9.0)
earmv7hf:gengetopt-2.22.6.tgz(NetBSD 8.0)
earmv7hf:gengetopt-2.22.6.tgz(NetBSD 8.0)
earmv7hf:gengetopt-2.22.6.tgz(NetBSD 8.0)
earmv7hf:gengetopt-2.22.6.tgz(NetBSD 8.0)
earmv7hf:gengetopt-2.22.6.tgz(NetBSD 9.0)
earmv7hf:gengetopt-2.22.6.tgz(NetBSD 9.0)
earmv7hf:gengetopt-2.22.6.tgz(NetBSD 9.0)
earmv7hf:gengetopt-2.22.6.tgz(NetBSD 9.0)
earmv7hf:gengetopt-2.22.6.tgz(NetBSD 9.0)
i386:gengetopt-2.22.6.tgz(NetBSD 8.0)
i386:gengetopt-2.22.6.tgz(NetBSD 8.0)
i386:gengetopt-2.22.6.tgz(NetBSD 8.0)
i386:gengetopt-2.22.6.tgz(NetBSD 9.0)
i386:gengetopt-2.22.6.tgz(NetBSD 9.0)
i386:gengetopt-2.22.6.tgz(NetBSD 9.0)
mips64eb:gengetopt-2.22.6.tgz(NetBSD 9.0)
powerpc:gengetopt-2.22.6.tgz(NetBSD 8.0)
powerpc:gengetopt-2.22.6.tgz(NetBSD 8.0)
powerpc:gengetopt-2.22.6.tgz(NetBSD 8.0)
powerpc:gengetopt-2.22.6.tgz(NetBSD 9.0)
powerpc:gengetopt-2.22.6.tgz(NetBSD 9.0)
powerpc:gengetopt-2.22.6.tgz(NetBSD 9.0)
sparc64:gengetopt-2.22.6.tgz(NetBSD 9.0)
sparc64:gengetopt-2.22.6.tgz(NetBSD 9.0)
sparc64:gengetopt-2.22.6.tgz(NetBSD 9.0)
sparc:gengetopt-2.22.6.tgz(NetBSD 9.0)
x86_64:gengetopt-2.22.6.tgz(NetBSD 9.0)
x86_64:gengetopt-2.22.6.tgz(NetBSD 9.0)
x86_64:gengetopt-2.22.6.tgz(NetBSD 9.0)
x86_64:gengetopt-2.22.6.tgz(NetBSD 9.0)
x86_64:gengetopt-2.22.6.tgz(NetBSD 8.0)
x86_64:gengetopt-2.22.6.tgz(NetBSD 8.0)
x86_64:gengetopt-2.22.6.tgz(NetBSD 8.0)
x86_64:gengetopt-2.22.6.tgz(NetBSD 9.0)
x86_64:gengetopt-2.22.6.tgz(NetBSD 9.0)
x86_64:gengetopt-2.22.6.tgz(NetBSD 9.0)
x86_64:gengetopt-2.22.6.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]