devel/ftnchek - The NetBSD Packages Collection

Static analyzer for Fortran programs

Ftnchek (short for Fortran checker) is designed to detect certain
errors in a Fortran program that a compiler usually does not.  ftnchek
is not primarily intended to detect syntax errors.  Its purpose is to
assist the user in finding semantic errors.  Semantic errors are legal
in the Fortran language but are wasteful or may cause incorrect
operation.  For example, variables which are never used may indicate
some omission in the program; uninitialized variables contain garbage
which may cause incorrect results to be calculated; and variables
which are not declared may not have the intended type.  ftnchek is
intended to assist users in the debugging of their Fortran program.
It is not intended to catch all syntax errors.  This is the function
of the compiler.  Prior to using ftnchek, the user should verify that
the program compiles correctly.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfftnchek-3.3.1.tgz
NetBSD 8.0earmv7hfftnchek-3.3.1.tgz
NetBSD 8.0earmv7hfftnchek-3.3.1.tgz
NetBSD 8.0i386ftnchek-3.3.1.tgz
NetBSD 8.0i386ftnchek-3.3.1.tgz
NetBSD 8.0powerpcftnchek-3.3.1.tgz
NetBSD 8.0powerpcftnchek-3.3.1.tgz
NetBSD 8.0powerpcftnchek-3.3.1.tgz
NetBSD 8.0powerpcftnchek-3.3.1.tgz
NetBSD 8.0x86_64ftnchek-3.3.1.tgz
NetBSD 8.0x86_64ftnchek-3.3.1.tgz
NetBSD 9.0aarch64ftnchek-3.3.1.tgz
NetBSD 9.0aarch64ftnchek-3.3.1.tgz
NetBSD 9.0aarch64ftnchek-3.3.1.tgz
NetBSD 9.0alphaftnchek-3.3.1.tgz
NetBSD 9.0alphaftnchek-3.3.1.tgz
NetBSD 9.0alphaftnchek-3.3.1.tgz
NetBSD 9.0earmftnchek-3.3.1.tgz
NetBSD 9.0earmftnchek-3.3.1.tgz
NetBSD 9.0earmftnchek-3.3.1.tgz
NetBSD 9.0earmv6hfftnchek-3.3.1.tgz
NetBSD 9.0earmv6hfftnchek-3.3.1.tgz
NetBSD 9.0earmv6hfftnchek-3.3.1.tgz
NetBSD 9.0earmv7hfftnchek-3.3.1.tgz
NetBSD 9.0earmv7hfftnchek-3.3.1.tgz
NetBSD 9.0earmv7hfftnchek-3.3.1.tgz
NetBSD 9.0earmv7hfftnchek-3.3.1.tgz
NetBSD 9.0i386ftnchek-3.3.1.tgz
NetBSD 9.0i386ftnchek-3.3.1.tgz
NetBSD 9.0mips64ebftnchek-3.3.1.tgz
NetBSD 9.0mips64ebftnchek-3.3.1.tgz
NetBSD 9.0mips64ebftnchek-3.3.1.tgz
NetBSD 9.0mips64ebftnchek-3.3.1.tgz
NetBSD 9.0mips64ebftnchek-3.3.1.tgz
NetBSD 9.0powerpcftnchek-3.3.1.tgz
NetBSD 9.0powerpcftnchek-3.3.1.tgz
NetBSD 9.0powerpcftnchek-3.3.1.tgz
NetBSD 9.0powerpcftnchek-3.3.1.tgz
NetBSD 9.0sparc64ftnchek-3.3.1.tgz
NetBSD 9.0sparc64ftnchek-3.3.1.tgz
NetBSD 9.0sparc64ftnchek-3.3.1.tgz
NetBSD 9.0sparcftnchek-3.3.1.tgz
NetBSD 9.0sparcftnchek-3.3.1.tgz
NetBSD 9.0sparcftnchek-3.3.1.tgz
NetBSD 9.0sparcftnchek-3.3.1.tgz
NetBSD 9.0sparcftnchek-3.3.1.tgz
NetBSD 9.0x86_64ftnchek-3.3.1.tgz
NetBSD 9.0x86_64ftnchek-3.3.1.tgz
NetBSD 9.0x86_64ftnchek-3.3.1.tgz
NetBSD 9.0x86_64ftnchek-3.3.1.tgz
NetBSD 9.0x86_64ftnchek-3.3.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.