Daemon Power

The NetBSD Packages Collection: devel/darcs

Brief description of the package:
Distributed revision control system

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://www.darcs.net/.

The package is located in the "devel/darcs" directory. The current source version of the package is "darcs-2.0.2nb29". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for devel/darcs :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: curl>=7.12.3 heimdal>=0.4e cwrappers>=20150314 heimdal>=0.6 libidn2>=2.0.0 libunistring>=0.9.3 libunistring>=0.9.4 nghttp2>=1.0.0 python37>=3.7 libffi>=1.20 libuuid>=2.18 openssl>=1.1.1 libffi>=3.3nb1 openssl>=1.1.1dnb2 readline>=2.2 readline>=6.0 python37>=3.7.0 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 heimdal>=1.5.3nb22 nghttp2>=1.40.0nb2 gmp>=4.2.1 curl>=7.69.0nb1 gmp>=5.0.1 latex2html>=2002.2.1nb3 tex-graphics-[0-9]* tex-graphics-cfg-[0-9]* kpathsea>=3.5.7 tex-graphics-def-[0-9]* tex-hyperref-[0-9]* tex-graphics>=1.0onb1 tex-ifxetex>=0.6 tex-latex-bin>=2009nb1 tex-babel>3.14 tex-carlisle>=2010 tex-cm-[0-9]* tex-tetex>=3.0.25424 dialog>=1.0 kpathsea-[0-9]* tex-kpathsea>=2012nb1 tex-texlive.infra-[0-9]* perl>=5.0 tex-latex-[0-9]* tex-latexconfig>=2011 tex-latex-fonts-[0-9]* tex-luatex-[0-9]* luatex>=0.60.1 zziplib>=0.10.82 cairo>=1.0.0nb2 Xrender>=0.2 x11-links>=1.31 osabi-NetBSD-8.1_STABLE xorgproto>=2016.1 Xrender>=0.8.2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 xcb-proto>=1.14 xcb-proto>=1.4 lzo>=2.01 fontconfig>=2.11.91 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.1nb2 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 Xrender>=0.9.0nb1 fontconfig>=2.13.0 png>=1.6.0nb1 mpfr>=2.0.3 gmp>=5.0 kpathsea>=6.2.1 kpathsea>=6.0.0 poppler>=0.5.1 openjpeg>=2.1.0 lcms2>=2.2 jpeg>=8nb1 tiff>=3.6.1 jbigkit>=2.0 jpeg>=9 tiff>=4.0.3nb5 nss>=3.43nb2 nspr>=4.25 nspr>=4.9.3.2 cairo>=1.16.0 boost-headers-1.72.* boost-jam-1.72.* zziplib>=0.13.56 mpfr>=4.0.0 poppler>=0.86.1 poppler-includes>=0.22.2 poppler-includes>=0.86.1 tex-etex-[0-9]* tex-plain-[0-9]* tex-amsfonts-[0-9]* tex-hyphen-base-[0-9]* tex-knuth-lib-[0-9]* tex-tex-ini-files-[0-9]* tex-pdftex-[0-9]* tex-dehyph-[0-9]* tex-dvips-[0-9]* tex-kpathsea-[0-9]* tex-updmap-map-[0-9]* web2c-[0-9]* ptexenc>=1.3.7 ptexenc>=1.1.1 tex-tetex>=3.0.27774 tex-plain>=3.14159265.12854 tex-unicode-data-[0-9]* tex-tools-[0-9]* tex-latex>=2009 tex-latex>=2012 tex-oberdiek>=2009nb1 tex-amsmath-[0-9]* tex-latex-bin-[0-9]* tex-etex-pkg-[0-9]* tex-ifluatex-[0-9]* tex-ifxetex-[0-9]* tex-url>=3.2 tex-tex-[0-9]* tex-url>=1.4 dvipsk-[0-9]* tex-dvips>=2013 tex-tetex-[0-9]* netpbm>=10.29nb2 ghostscript>=6.01 ghostscript-agpl-[0-9]* ghostscript-fonts>=6.0 freetype2>=2.10.0 libidn>=0.4.6 jbig2dec>=0.17 jbig2dec>=0.16 libpaper>=1.1.22 libidn>=1.20nb1 tex-fancyvrb-[0-9]* ghc>=6.8.3<7 ghc>=6.8.3nb2<7 .

This package requires the following package(s) to run: curl>=7.12.3 heimdal>=0.4e heimdal>=0.6 libidn2>=2.0.0 libunistring>=0.9.3 libunistring>=0.9.4 nghttp2>=1.0.0 python37>=3.7 libffi>=1.20 libuuid>=2.18 openssl>=1.1.1 libffi>=3.3nb1 openssl>=1.1.1dnb2 python37>=3.7.0 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 heimdal>=1.5.3nb22 nghttp2>=1.40.0nb2 gmp>=4.2.1 curl>=7.69.0nb1 gmp>=5.0.1 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
none

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]