devel/cvslock - The NetBSD Packages Collection

Safely manipulate and inspect CVS repositories

The cvslock (1) program is used to safely manipulate and inspect CVS
repositories; to this end, it properly uses CVS' lock file mechanism.

The primary application for which this program was created was
keeping several instances of the same CVS repository in synch; using
CVSup which apparently does a superior task at this was not an
option in my precise application.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfcvslock-0.2.tgz
NetBSD 8.0earmv7hfcvslock-0.2.tgz
NetBSD 8.0earmv7hfcvslock-0.2.tgz
NetBSD 8.0i386cvslock-0.2.tgz
NetBSD 8.0i386cvslock-0.2.tgz
NetBSD 8.0powerpccvslock-0.2.tgz
NetBSD 8.0powerpccvslock-0.2.tgz
NetBSD 8.0powerpccvslock-0.2.tgz
NetBSD 8.0powerpccvslock-0.2.tgz
NetBSD 8.0x86_64cvslock-0.2.tgz
NetBSD 8.0x86_64cvslock-0.2.tgz
NetBSD 9.0aarch64cvslock-0.2.tgz
NetBSD 9.0aarch64cvslock-0.2.tgz
NetBSD 9.0aarch64cvslock-0.2.tgz
NetBSD 9.0alphacvslock-0.2.tgz
NetBSD 9.0alphacvslock-0.2.tgz
NetBSD 9.0alphacvslock-0.2.tgz
NetBSD 9.0earmcvslock-0.2.tgz
NetBSD 9.0earmcvslock-0.2.tgz
NetBSD 9.0earmcvslock-0.2.tgz
NetBSD 9.0earmv6hfcvslock-0.2.tgz
NetBSD 9.0earmv6hfcvslock-0.2.tgz
NetBSD 9.0earmv6hfcvslock-0.2.tgz
NetBSD 9.0earmv7hfcvslock-0.2.tgz
NetBSD 9.0earmv7hfcvslock-0.2.tgz
NetBSD 9.0earmv7hfcvslock-0.2.tgz
NetBSD 9.0earmv7hfcvslock-0.2.tgz
NetBSD 9.0i386cvslock-0.2.tgz
NetBSD 9.0i386cvslock-0.2.tgz
NetBSD 9.0mips64ebcvslock-0.2.tgz
NetBSD 9.0mips64ebcvslock-0.2.tgz
NetBSD 9.0mips64ebcvslock-0.2.tgz
NetBSD 9.0mips64ebcvslock-0.2.tgz
NetBSD 9.0mips64ebcvslock-0.2.tgz
NetBSD 9.0powerpccvslock-0.2.tgz
NetBSD 9.0powerpccvslock-0.2.tgz
NetBSD 9.0powerpccvslock-0.2.tgz
NetBSD 9.0powerpccvslock-0.2.tgz
NetBSD 9.0sparc64cvslock-0.2.tgz
NetBSD 9.0sparc64cvslock-0.2.tgz
NetBSD 9.0sparc64cvslock-0.2.tgz
NetBSD 9.0sparccvslock-0.2.tgz
NetBSD 9.0sparccvslock-0.2.tgz
NetBSD 9.0sparccvslock-0.2.tgz
NetBSD 9.0sparccvslock-0.2.tgz
NetBSD 9.0sparccvslock-0.2.tgz
NetBSD 9.0x86_64cvslock-0.2.tgz
NetBSD 9.0x86_64cvslock-0.2.tgz
NetBSD 9.0x86_64cvslock-0.2.tgz
NetBSD 9.0x86_64cvslock-0.2.tgz
NetBSD 9.0x86_64cvslock-0.2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.