devel/blib - The NetBSD Packages Collection

Blinkenlights library

blib library contains code that you will find useful if you want to create
any kind of software related to Blinkenlights.

There is a code to read and write the old-style BLM movie format as well
as code to handle GIF files and the new Blinkenlights Markup Language.
Both sides of the Blinkenlights network protocol are implemented so that
you don't have to care about the details.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/libtool-base devel/pkgconf

Runtime dependencies

x11/gtk2 x11/gtk2

Available binary packages

aarch64:blib-1.0.2nb37.tgz(NetBSD 9.0)
aarch64:blib-1.0.2nb38.tgz(NetBSD 9.0)
aarch64:blib-1.0.2nb38.tgz(NetBSD 9.0)
alpha:blib-1.0.2nb37.tgz(NetBSD 9.0)
alpha:blib-1.0.2nb38.tgz(NetBSD 9.0)
earmv6hf:blib-1.0.2nb38.tgz(NetBSD 9.0)
earmv6hf:blib-1.0.2nb37.tgz(NetBSD 9.0)
earmv6hf:blib-1.0.2nb38.tgz(NetBSD 9.0)
earmv6hf:blib-1.0.2nb38.tgz(NetBSD 9.0)
earmv7hf:blib-1.0.2nb38.tgz(NetBSD 8.0)
earmv7hf:blib-1.0.2nb37.tgz(NetBSD 8.0)
earmv7hf:blib-1.0.2nb37.tgz(NetBSD 8.0)
earmv7hf:blib-1.0.2nb38.tgz(NetBSD 8.0)
earmv7hf:blib-1.0.2nb38.tgz(NetBSD 9.0)
earmv7hf:blib-1.0.2nb37.tgz(NetBSD 9.0)
earmv7hf:blib-1.0.2nb37.tgz(NetBSD 9.0)
earmv7hf:blib-1.0.2nb38.tgz(NetBSD 9.0)
earmv7hf:blib-1.0.2nb38.tgz(NetBSD 9.0)
i386:blib-1.0.2nb37.tgz(NetBSD 8.0)
i386:blib-1.0.2nb38.tgz(NetBSD 8.0)
i386:blib-1.0.2nb38.tgz(NetBSD 8.0)
i386:blib-1.0.2nb37.tgz(NetBSD 9.0)
i386:blib-1.0.2nb38.tgz(NetBSD 9.0)
i386:blib-1.0.2nb38.tgz(NetBSD 9.0)
mips64eb:blib-1.0.2nb38.tgz(NetBSD 9.0)
mips64eb:blib-1.0.2nb38.tgz(NetBSD 9.0)
powerpc:blib-1.0.2nb37.tgz(NetBSD 8.0)
powerpc:blib-1.0.2nb38.tgz(NetBSD 8.0)
powerpc:blib-1.0.2nb38.tgz(NetBSD 8.0)
powerpc:blib-1.0.2nb38.tgz(NetBSD 9.0)
powerpc:blib-1.0.2nb37.tgz(NetBSD 9.0)
sparc64:blib-1.0.2nb38.tgz(NetBSD 9.0)
sparc64:blib-1.0.2nb37.tgz(NetBSD 9.0)
sparc64:blib-1.0.2nb38.tgz(NetBSD 9.0)
sparc:blib-1.0.2nb38.tgz(NetBSD 9.0)
sparc:blib-1.0.2nb37.tgz(NetBSD 9.0)
sparc:blib-1.0.2nb38.tgz(NetBSD 9.0)
x86_64:blib-1.0.2nb38.tgz(NetBSD 9.0)
x86_64:blib-1.0.2nb38.tgz(NetBSD 9.0)
x86_64:blib-1.0.2nb38.tgz(NetBSD 9.0)
x86_64:blib-1.0.2nb38.tgz(NetBSD 9.0)
x86_64:blib-1.0.2nb38.tgz(NetBSD 8.0)
x86_64:blib-1.0.2nb37.tgz(NetBSD 8.0)
x86_64:blib-1.0.2nb38.tgz(NetBSD 8.0)
x86_64:blib-1.0.2nb37.tgz(NetBSD 9.0)
x86_64:blib-1.0.2nb38.tgz(NetBSD 9.0)
x86_64:blib-1.0.2nb38.tgz(NetBSD 9.0)
x86_64:blib-1.0.2nb38.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]