devel/amtk - The NetBSD Packages Collection

Actions, Menus and Toolbars Kit for GTK applications

Amtk is the acronym for "Actions, Menus and Toolbars Kit". It is a basic
GtkUIManager replacement based on GAction. It is suitable for both a
traditional UI or a modern UI with a GtkHeaderBar.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/libtool-base devel/gmake devel/pkgconf

Runtime dependencies

devel/gobject-introspection x11/gtk3 devel/gobject-introspection x11/gtk3

Available binary packages

aarch64:amtk-5.0.2.tgz(NetBSD 9.0)
aarch64:amtk-5.0.2nb1.tgz(NetBSD 9.0)
aarch64:amtk-5.0.2nb1.tgz(NetBSD 9.0)
alpha:amtk-5.0.2nb1.tgz(NetBSD 9.0)
alpha:amtk-5.0.2.tgz(NetBSD 9.0)
alpha:amtk-5.0.2nb1.tgz(NetBSD 9.0)
earmv6hf:amtk-5.0.2nb1.tgz(NetBSD 9.0)
earmv6hf:amtk-5.0.2.tgz(NetBSD 9.0)
earmv6hf:amtk-5.0.2nb1.tgz(NetBSD 9.0)
earmv6hf:amtk-5.0.2nb1.tgz(NetBSD 9.0)
earmv7hf:amtk-5.0.2nb1.tgz(NetBSD 8.0)
earmv7hf:amtk-5.0.1nb2.tgz(NetBSD 8.0)
earmv7hf:amtk-5.0.2.tgz(NetBSD 8.0)
earmv7hf:amtk-5.0.2nb1.tgz(NetBSD 8.0)
earmv7hf:amtk-5.0.2nb1.tgz(NetBSD 9.0)
earmv7hf:amtk-5.0.1nb2.tgz(NetBSD 9.0)
earmv7hf:amtk-5.0.2.tgz(NetBSD 9.0)
earmv7hf:amtk-5.0.2nb1.tgz(NetBSD 9.0)
earmv7hf:amtk-5.0.2nb1.tgz(NetBSD 9.0)
i386:amtk-5.0.2.tgz(NetBSD 8.0)
i386:amtk-5.0.2nb1.tgz(NetBSD 8.0)
i386:amtk-5.0.2nb1.tgz(NetBSD 8.0)
i386:amtk-5.0.2.tgz(NetBSD 9.0)
i386:amtk-5.0.2nb1.tgz(NetBSD 9.0)
i386:amtk-5.0.2nb1.tgz(NetBSD 9.0)
mips64eb:amtk-5.0.2nb1.tgz(NetBSD 9.0)
mips64eb:amtk-5.0.2nb1.tgz(NetBSD 9.0)
powerpc:amtk-5.0.2.tgz(NetBSD 8.0)
powerpc:amtk-5.0.2nb1.tgz(NetBSD 8.0)
powerpc:amtk-5.0.2nb1.tgz(NetBSD 8.0)
powerpc:amtk-5.0.2nb1.tgz(NetBSD 9.0)
powerpc:amtk-5.0.2.tgz(NetBSD 9.0)
sparc64:amtk-5.0.2nb1.tgz(NetBSD 9.0)
sparc64:amtk-5.0.2.tgz(NetBSD 9.0)
sparc64:amtk-5.0.2nb1.tgz(NetBSD 9.0)
sparc:amtk-5.0.2nb1.tgz(NetBSD 9.0)
sparc:amtk-5.0.2.tgz(NetBSD 9.0)
sparc:amtk-5.0.2nb1.tgz(NetBSD 9.0)
x86_64:amtk-5.0.2nb1.tgz(NetBSD 9.0)
x86_64:amtk-5.0.2nb1.tgz(NetBSD 9.0)
x86_64:amtk-5.0.2nb1.tgz(NetBSD 9.0)
x86_64:amtk-5.0.2nb1.tgz(NetBSD 9.0)
x86_64:amtk-5.0.2nb1.tgz(NetBSD 8.0)
x86_64:amtk-5.0.2.tgz(NetBSD 8.0)
x86_64:amtk-5.0.2nb1.tgz(NetBSD 8.0)
x86_64:amtk-5.0.2.tgz(NetBSD 9.0)
x86_64:amtk-5.0.2nb1.tgz(NetBSD 9.0)
x86_64:amtk-5.0.2nb1.tgz(NetBSD 9.0)
x86_64:amtk-5.0.2nb1.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]