databases/unixodbc - The NetBSD Packages Collection

ODBC 2.x/3.x driver manager

The unixODBC project provides UNIX applications with the same ODBC 3.51
API and facilities available under MS Windows. It provides a Driver Manager
that supports the full ODBC API and performs the ODBC 3 to ODBC 2
translations with UNICODE to ANSI conversion.  It also includes a collection
of ODBC drivers including a simple text-based driver, an NNTP driver, a
Postgres driver and others, and a selection of templates and libraries that
to aid in the construction of ODBC drivers. It works with MySQL, Postgres,
StarOffice, Applixware, iHTML, PHP, Perl DBD::ODBC, Paradox 9, and many
other applications and drivers.  Connection pooling is also provided to
increase performance with applications such as PHP.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/gmake

Runtime dependencies

devel/libltdl devel/readline devel/libltdl devel/readline

Available binary packages

aarch64:unixodbc-2.3.7.tgz(NetBSD 9.0)
aarch64:unixodbc-2.3.9.tgz(NetBSD 9.0)
aarch64:unixodbc-2.3.9.tgz(NetBSD 9.0)
alpha:unixodbc-2.3.9.tgz(NetBSD 9.0)
alpha:unixodbc-2.3.7.tgz(NetBSD 9.0)
alpha:unixodbc-2.3.9.tgz(NetBSD 9.0)
earm:unixodbc-2.3.9.tgz(NetBSD 9.0)
earm:unixodbc-2.3.7.tgz(NetBSD 9.0)
earm:unixodbc-2.3.9.tgz(NetBSD 9.0)
earmv6hf:unixodbc-2.3.9.tgz(NetBSD 9.0)
earmv6hf:unixodbc-2.3.7.tgz(NetBSD 9.0)
earmv6hf:unixodbc-2.3.9.tgz(NetBSD 9.0)
earmv6hf:unixodbc-2.3.9.tgz(NetBSD 9.0)
earmv7hf:unixodbc-2.3.9.tgz(NetBSD 8.0)
earmv7hf:unixodbc-2.3.7.tgz(NetBSD 8.0)
earmv7hf:unixodbc-2.3.7.tgz(NetBSD 8.0)
earmv7hf:unixodbc-2.3.9.tgz(NetBSD 8.0)
earmv7hf:unixodbc-2.3.9.tgz(NetBSD 9.0)
earmv7hf:unixodbc-2.3.7.tgz(NetBSD 9.0)
earmv7hf:unixodbc-2.3.7.tgz(NetBSD 9.0)
earmv7hf:unixodbc-2.3.9.tgz(NetBSD 9.0)
earmv7hf:unixodbc-2.3.9.tgz(NetBSD 9.0)
i386:unixodbc-2.3.7.tgz(NetBSD 8.0)
i386:unixodbc-2.3.9.tgz(NetBSD 8.0)
i386:unixodbc-2.3.9.tgz(NetBSD 8.0)
i386:unixodbc-2.3.7.tgz(NetBSD 9.0)
i386:unixodbc-2.3.9.tgz(NetBSD 9.0)
i386:unixodbc-2.3.9.tgz(NetBSD 9.0)
m68k:unixodbc-2.3.9.tgz(NetBSD 9.0)
mips64eb:unixodbc-2.3.9.tgz(NetBSD 9.0)
mips64eb:unixodbc-2.3.9.tgz(NetBSD 9.0)
mipsel:unixodbc-2.3.9.tgz(NetBSD 9.0)
powerpc:unixodbc-2.3.9.tgz(NetBSD 8.0)
powerpc:unixodbc-2.3.9.tgz(NetBSD 8.0)
powerpc:unixodbc-2.3.9.tgz(NetBSD 9.0)
powerpc:unixodbc-2.3.7.tgz(NetBSD 9.0)
sh3el:unixodbc-2.3.9.tgz(NetBSD 9.0)
sh3el:unixodbc-2.3.9.tgz(NetBSD 9.0)
sparc64:unixodbc-2.3.9.tgz(NetBSD 9.0)
sparc64:unixodbc-2.3.7.tgz(NetBSD 9.0)
sparc64:unixodbc-2.3.9.tgz(NetBSD 9.0)
sparc:unixodbc-2.3.9.tgz(NetBSD 9.0)
sparc:unixodbc-2.3.9.tgz(NetBSD 9.0)
vax:unixodbc-2.3.9.tgz(NetBSD 9.0)
x86_64:unixodbc-2.3.9.tgz(NetBSD 9.0)
x86_64:unixodbc-2.3.9.tgz(NetBSD 9.0)
x86_64:unixodbc-2.3.9.tgz(NetBSD 9.0)
x86_64:unixodbc-2.3.9.tgz(NetBSD 9.0)
x86_64:unixodbc-2.3.9.tgz(NetBSD 8.0)
x86_64:unixodbc-2.3.7.tgz(NetBSD 8.0)
x86_64:unixodbc-2.3.9.tgz(NetBSD 8.0)
x86_64:unixodbc-2.3.7.tgz(NetBSD 9.0)
x86_64:unixodbc-2.3.9.tgz(NetBSD 9.0)
x86_64:unixodbc-2.3.9.tgz(NetBSD 9.0)
x86_64:unixodbc-2.3.9.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]