databases/p5-DBD-MariaDB - The NetBSD Packages Collection

MariaDB and MySQL driver for the Perl5 Database Interface (DBI)

DBD::MariaDB is the Perl5 Database Interface driver for MariaDB
and MySQL databases. In other words: DBD::MariaDB is an interface
between the Perl programming language and the MariaDB/MySQL
programming API that comes with the MariaDB/MySQL relational database
management system. Most functions provided by this programming API
are supported. Some rarely used functions are missing, mainly
because no-one ever requested them. :-)

Build dependencies

pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

devel/p5-Devel-CheckLib databases/p5-DBI lang/perl5 lang/perl5 databases/mariadb1011-client databases/p5-DBI databases/mariadb1011-client

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64p5-DBD-MariaDB-1.23.tgz
NetBSD 10.0aarch64p5-DBD-MariaDB-1.21nb2.tgz
NetBSD 10.0aarch64p5-DBD-MariaDB-1.21nb2.tgz
NetBSD 10.0aarch64ebp5-DBD-MariaDB-1.21nb2.tgz
NetBSD 10.0earmv6hfp5-DBD-MariaDB-1.21nb2.tgz
NetBSD 10.0earmv6hfp5-DBD-MariaDB-1.21nb2.tgz
NetBSD 10.0earmv6hfp5-DBD-MariaDB-1.23.tgz
NetBSD 10.0earmv7hfp5-DBD-MariaDB-1.23.tgz
NetBSD 10.0earmv7hfp5-DBD-MariaDB-1.21nb2.tgz
NetBSD 10.0earmv7hfp5-DBD-MariaDB-1.21nb2.tgz
NetBSD 10.0i386p5-DBD-MariaDB-1.21nb2.tgz
NetBSD 10.0i386p5-DBD-MariaDB-1.21nb2.tgz
NetBSD 10.0i386p5-DBD-MariaDB-1.23.tgz
NetBSD 10.0powerpcp5-DBD-MariaDB-1.21nb2.tgz
NetBSD 10.0powerpcp5-DBD-MariaDB-1.21nb2.tgz
NetBSD 10.0sparc64p5-DBD-MariaDB-1.21nb2.tgz
NetBSD 10.0x86_64p5-DBD-MariaDB-1.23.tgz
NetBSD 10.0x86_64p5-DBD-MariaDB-1.21nb2.tgz
NetBSD 10.0x86_64p5-DBD-MariaDB-1.21nb2.tgz
NetBSD 9.0aarch64p5-DBD-MariaDB-1.23.tgz
NetBSD 9.0aarch64p5-DBD-MariaDB-1.21nb2.tgz
NetBSD 9.0aarch64p5-DBD-MariaDB-1.21nb2.tgz
NetBSD 9.0alphap5-DBD-MariaDB-1.21nb2.tgz
NetBSD 9.0earmv6hfp5-DBD-MariaDB-1.23.tgz
NetBSD 9.0earmv6hfp5-DBD-MariaDB-1.21nb2.tgz
NetBSD 9.0earmv6hfp5-DBD-MariaDB-1.21nb2.tgz
NetBSD 9.0earmv7hfp5-DBD-MariaDB-1.23.tgz
NetBSD 9.0earmv7hfp5-DBD-MariaDB-1.21nb2.tgz
NetBSD 9.0earmv7hfp5-DBD-MariaDB-1.21nb2.tgz
NetBSD 9.0i386p5-DBD-MariaDB-1.23.tgz
NetBSD 9.0i386p5-DBD-MariaDB-1.21nb2.tgz
NetBSD 9.0i386p5-DBD-MariaDB-1.21nb2.tgz
NetBSD 9.0powerpcp5-DBD-MariaDB-1.21nb2.tgz
NetBSD 9.0powerpcp5-DBD-MariaDB-1.21nb2.tgz
NetBSD 9.0powerpcp5-DBD-MariaDB-1.21nb2.tgz
NetBSD 9.0sparc64p5-DBD-MariaDB-1.21nb2.tgz
NetBSD 9.0x86_64p5-DBD-MariaDB-1.23.tgz
NetBSD 9.0x86_64p5-DBD-MariaDB-1.21nb2.tgz
NetBSD 9.0x86_64p5-DBD-MariaDB-1.21nb2.tgz
NetBSD 9.3x86_64p5-DBD-MariaDB-1.23.tgz
NetBSD 9.3x86_64p5-DBD-MariaDB-1.23.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.