cross/avrdude - The NetBSD Packages Collection

Downloader/uploader for Atmel AVR 8-bit RISC microcontrollers

AVRDUDE - AVR Downloader/UploaDEr - is a program for updating the
flash, eeprom, and fuse bit memories of Atmel AVR microcontrollers.
Avrdude supports a wide variety of chip programmers (including the
widely used STK500) that attach to the serial port, and, if supported
by the underlying OS, to the parallel port.

Build dependencies

print/dvipsk fonts/tex-latex-fonts print/tex-pdftex pkgtools/cwrappers devel/libtool-base devel/automake devel/autoconf devel/gmake devel/gtexinfo textproc/texi2html

Runtime dependencies

devel/libftdi devel/libusb1 devel/libhid devel/libftdi1 devel/libelf devel/readline devel/readline

Available binary packages

aarch64:avrdude-6.3nb2.tgz(NetBSD 9.0)
aarch64:avrdude-6.3nb2.tgz(NetBSD 9.0)
aarch64:avrdude-6.3nb2.tgz(NetBSD 9.0)
earmv6hf:avrdude-6.3nb2.tgz(NetBSD 9.0)
earmv6hf:avrdude-6.3nb2.tgz(NetBSD 9.0)
earmv6hf:avrdude-6.3nb2.tgz(NetBSD 9.0)
earmv6hf:avrdude-6.3nb2.tgz(NetBSD 9.0)
earmv7hf:avrdude-6.3nb2.tgz(NetBSD 8.0)
earmv7hf:avrdude-6.3nb2.tgz(NetBSD 8.0)
earmv7hf:avrdude-6.3nb2.tgz(NetBSD 8.0)
earmv7hf:avrdude-6.3nb2.tgz(NetBSD 9.0)
earmv7hf:avrdude-6.3nb2.tgz(NetBSD 9.0)
earmv7hf:avrdude-6.3nb2.tgz(NetBSD 9.0)
earmv7hf:avrdude-6.3nb2.tgz(NetBSD 9.0)
i386:avrdude-6.3nb2.tgz(NetBSD 8.0)
i386:avrdude-6.3nb2.tgz(NetBSD 8.0)
i386:avrdude-6.3nb2.tgz(NetBSD 8.0)
i386:avrdude-6.3nb2.tgz(NetBSD 9.0)
i386:avrdude-6.3nb2.tgz(NetBSD 9.0)
i386:avrdude-6.3nb2.tgz(NetBSD 9.0)
powerpc:avrdude-6.3nb2.tgz(NetBSD 8.0)
powerpc:avrdude-6.3nb2.tgz(NetBSD 8.0)
powerpc:avrdude-6.3nb2.tgz(NetBSD 8.0)
powerpc:avrdude-6.3nb2.tgz(NetBSD 9.0)
powerpc:avrdude-6.3nb2.tgz(NetBSD 9.0)
x86_64:avrdude-6.3nb2.tgz(NetBSD 9.0)
x86_64:avrdude-6.3nb2.tgz(NetBSD 9.0)
x86_64:avrdude-6.3nb2.tgz(NetBSD 9.0)
x86_64:avrdude-6.3nb2.tgz(NetBSD 9.0)
x86_64:avrdude-6.3nb2.tgz(NetBSD 8.0)
x86_64:avrdude-6.3nb2.tgz(NetBSD 8.0)
x86_64:avrdude-6.3nb2.tgz(NetBSD 8.0)
x86_64:avrdude-6.3nb2.tgz(NetBSD 9.0)
x86_64:avrdude-6.3nb2.tgz(NetBSD 9.0)
x86_64:avrdude-6.3nb2.tgz(NetBSD 9.0)
x86_64:avrdude-6.3nb2.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

doc
Include the documentation.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]