comms/libticalcs2 - The NetBSD Packages Collection

Multi-platform linking program for TI graphing calculators

"Tilp is a Linking Program" - The TiLP project aims to develop a multi-platform
linking program for use with all TI graphing calculators (TI73 ... V200PLT).

Supported link cables are: GrayLink, BlackLink, SilverLink, DirectLink Parallel
Link, VTi (virtual) and TiEmu (virtual).

Supported hand-helds are: TI73, TI82, TI83, TI83+, TI84+, TI85, TI86, TI89,
Titanium, TI92, TI92+, V200, NSpire, NSpire-CAS.

Capabilities: silent link, screendump, directory listing, send/recv of vars,
send/Recv of backups, send/recv of FLASH apps, send of OS, ROM dumping, ID LIST,
clock, create folder, delete var/app...

Build dependencies

pkgtools/cwrappers devel/glib2-tools devel/libtool-base devel/pkgconf

Runtime dependencies

comms/libtifiles2 comms/libticonv devel/glib2 comms/libticables2 comms/libtifiles2 comms/libticonv devel/glib2 comms/libticables2

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibticalcs2-1.1.7nb1.tgz
NetBSD 8.0earmv7hflibticalcs2-1.1.7nb1.tgz
NetBSD 8.0earmv7hflibticalcs2-1.1.7nb1.tgz
NetBSD 8.0i386libticalcs2-1.1.7nb1.tgz
NetBSD 8.0i386libticalcs2-1.1.7nb1.tgz
NetBSD 8.0i386libticalcs2-1.1.7nb1.tgz
NetBSD 8.0powerpclibticalcs2-1.1.7nb1.tgz
NetBSD 8.0powerpclibticalcs2-1.1.7nb1.tgz
NetBSD 8.0powerpclibticalcs2-1.1.7nb1.tgz
NetBSD 8.0x86_64libticalcs2-1.1.7nb1.tgz
NetBSD 8.0x86_64libticalcs2-1.1.7nb1.tgz
NetBSD 9.0aarch64libticalcs2-1.1.7nb1.tgz
NetBSD 9.0aarch64libticalcs2-1.1.7nb1.tgz
NetBSD 9.0aarch64libticalcs2-1.1.7nb1.tgz
NetBSD 9.0alphalibticalcs2-1.1.7nb1.tgz
NetBSD 9.0alphalibticalcs2-1.1.7nb1.tgz
NetBSD 9.0alphalibticalcs2-1.1.7nb1.tgz
NetBSD 9.0earmlibticalcs2-1.1.7nb1.tgz
NetBSD 9.0earmlibticalcs2-1.1.7nb1.tgz
NetBSD 9.0earmlibticalcs2-1.1.7nb1.tgz
NetBSD 9.0earmv6hflibticalcs2-1.1.7nb1.tgz
NetBSD 9.0earmv6hflibticalcs2-1.1.7nb1.tgz
NetBSD 9.0earmv6hflibticalcs2-1.1.7nb1.tgz
NetBSD 9.0earmv6hflibticalcs2-1.1.7nb1.tgz
NetBSD 9.0earmv7hflibticalcs2-1.1.7nb1.tgz
NetBSD 9.0earmv7hflibticalcs2-1.1.7nb1.tgz
NetBSD 9.0earmv7hflibticalcs2-1.1.7nb1.tgz
NetBSD 9.0earmv7hflibticalcs2-1.1.7nb1.tgz
NetBSD 9.0i386libticalcs2-1.1.7nb1.tgz
NetBSD 9.0i386libticalcs2-1.1.7nb1.tgz
NetBSD 9.0mips64eblibticalcs2-1.1.7nb1.tgz
NetBSD 9.0mips64eblibticalcs2-1.1.7nb1.tgz
NetBSD 9.0mips64eblibticalcs2-1.1.7nb1.tgz
NetBSD 9.0powerpclibticalcs2-1.1.7nb1.tgz
NetBSD 9.0powerpclibticalcs2-1.1.7nb1.tgz
NetBSD 9.0sh3ellibticalcs2-1.1.7nb1.tgz
NetBSD 9.0sh3ellibticalcs2-1.1.7nb1.tgz
NetBSD 9.0sparc64libticalcs2-1.1.7nb1.tgz
NetBSD 9.0sparc64libticalcs2-1.1.7nb1.tgz
NetBSD 9.0sparc64libticalcs2-1.1.7nb1.tgz
NetBSD 9.0sparc64libticalcs2-1.1.7nb1.tgz
NetBSD 9.0sparclibticalcs2-1.1.7nb1.tgz
NetBSD 9.0sparclibticalcs2-1.1.7nb1.tgz
NetBSD 9.0sparclibticalcs2-1.1.7nb1.tgz
NetBSD 9.0x86_64libticalcs2-1.1.7nb1.tgz
NetBSD 9.0x86_64libticalcs2-1.1.7nb1.tgz
NetBSD 9.0x86_64libticalcs2-1.1.7nb1.tgz
NetBSD 9.0x86_64libticalcs2-1.1.7nb1.tgz
NetBSD 9.0x86_64libticalcs2-1.1.7nb1.tgz
NetBSD 9.0x86_64libticalcs2-1.1.7nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

nls
Use native language support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.