chat/tootstream - The NetBSD Packages Collection

Command line interface for interacting with Mastodon instances

Tootstream is a command line interface for interacting with instances
on the distributed social network known as 'the Fediverse' using the
Mastodon.social API.

It is inspired by the Twitter client "Rainbowstream".

OAuth and two-factor authentication are supported.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/py-click textproc/py-colored converters/py-emoji textproc/py-humanize chat/py-mastodon devel/py-readline devel/py-setuptools lang/python38 lang/python38

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hftootstream-0.3.8.1nb1.tgz
NetBSD 8.0earmv7hftootstream-0.3.8.1.tgz
NetBSD 8.0earmv7hftootstream-0.3.8.1nb1.tgz
NetBSD 8.0i386tootstream-0.3.8.1.tgz
NetBSD 8.0i386tootstream-0.3.8.1nb1.tgz
NetBSD 8.0i386tootstream-0.3.8.1nb1.tgz
NetBSD 8.0powerpctootstream-0.3.8.1.tgz
NetBSD 8.0powerpctootstream-0.3.8.1nb1.tgz
NetBSD 8.0powerpctootstream-0.3.8.1nb1.tgz
NetBSD 8.0x86_64tootstream-0.3.8.1nb1.tgz
NetBSD 8.0x86_64tootstream-0.3.8.1.tgz
NetBSD 8.0x86_64tootstream-0.3.8.1nb1.tgz
NetBSD 9.0aarch64tootstream-0.3.8.1nb1.tgz
NetBSD 9.0aarch64tootstream-0.3.8.1.tgz
NetBSD 9.0aarch64tootstream-0.3.8.1nb1.tgz
NetBSD 9.0alphatootstream-0.3.8.1nb1.tgz
NetBSD 9.0alphatootstream-0.3.8.1.tgz
NetBSD 9.0alphatootstream-0.3.8.1nb1.tgz
NetBSD 9.0earmv6hftootstream-0.3.8.1nb1.tgz
NetBSD 9.0earmv6hftootstream-0.3.8.1.tgz
NetBSD 9.0earmv6hftootstream-0.3.8.1nb1.tgz
NetBSD 9.0earmv6hftootstream-0.3.8.1nb1.tgz
NetBSD 9.0earmv7hftootstream-0.3.8.1nb1.tgz
NetBSD 9.0earmv7hftootstream-0.3.8.1.tgz
NetBSD 9.0earmv7hftootstream-0.3.8.1nb1.tgz
NetBSD 9.0earmv7hftootstream-0.3.8.1nb1.tgz
NetBSD 9.0i386tootstream-0.3.8.1.tgz
NetBSD 9.0i386tootstream-0.3.8.1nb1.tgz
NetBSD 9.0i386tootstream-0.3.8.1nb1.tgz
NetBSD 9.0mips64ebtootstream-0.3.8.1nb1.tgz
NetBSD 9.0mips64ebtootstream-0.3.8.1.tgz
NetBSD 9.0mips64ebtootstream-0.3.8.1nb1.tgz
NetBSD 9.0powerpctootstream-0.3.8.1nb1.tgz
NetBSD 9.0powerpctootstream-0.3.8.1.tgz
NetBSD 9.0sparc64tootstream-0.3.8.1nb1.tgz
NetBSD 9.0sparc64tootstream-0.3.8.1.tgz
NetBSD 9.0sparc64tootstream-0.3.8.1nb1.tgz
NetBSD 9.0x86_64tootstream-0.3.8.1.tgz
NetBSD 9.0x86_64tootstream-0.3.8.1nb1.tgz
NetBSD 9.0x86_64tootstream-0.3.8.1nb1.tgz
NetBSD 9.0x86_64tootstream-0.3.8.1nb1.tgz
NetBSD 9.0x86_64tootstream-0.3.8.1.tgz
NetBSD 9.0x86_64tootstream-0.3.8.1nb1.tgz
NetBSD 9.0x86_64tootstream-0.3.8.1nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.