chat/lurch-purple - The NetBSD Packages Collection

XEP-0384: OMEMO Encryption for libpurple

In German, an Axolotl is a type of Lurch, which simply means
'amphibian'. This plugin brings Axolotl, by now renamed to double
ratchet, to libpurple applications such as Pidgin by implementing
the XEP-0384: OMEMO Encryption.

Build dependencies

pkgtools/cwrappers devel/glib2-tools devel/cmake devel/gmake devel/pkgconf

Runtime dependencies

chat/libpurple security/libgcrypt textproc/mxml chat/libpurple security/libgcrypt textproc/mxml

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflurch-purple-0.6.8nb6.tgz
NetBSD 8.0earmv7hflurch-purple-0.6.8nb5.tgz
NetBSD 8.0earmv7hflurch-purple-0.6.8nb6.tgz
NetBSD 8.0i386lurch-purple-0.6.8nb5.tgz
NetBSD 8.0i386lurch-purple-0.6.8nb6.tgz
NetBSD 8.0i386lurch-purple-0.6.8nb6.tgz
NetBSD 8.0x86_64lurch-purple-0.6.8nb6.tgz
NetBSD 8.0x86_64lurch-purple-0.6.8nb5.tgz
NetBSD 8.0x86_64lurch-purple-0.6.8nb6.tgz
NetBSD 9.0aarch64lurch-purple-0.6.8nb6.tgz
NetBSD 9.0aarch64lurch-purple-0.6.8nb5.tgz
NetBSD 9.0aarch64lurch-purple-0.6.8nb6.tgz
NetBSD 9.0alphalurch-purple-0.6.8nb6.tgz
NetBSD 9.0alphalurch-purple-0.6.8nb5.tgz
NetBSD 9.0alphalurch-purple-0.6.8nb6.tgz
NetBSD 9.0earmv6hflurch-purple-0.6.8nb6.tgz
NetBSD 9.0earmv6hflurch-purple-0.6.8nb5.tgz
NetBSD 9.0earmv6hflurch-purple-0.6.8nb6.tgz
NetBSD 9.0earmv6hflurch-purple-0.6.8nb6.tgz
NetBSD 9.0earmv7hflurch-purple-0.6.8nb6.tgz
NetBSD 9.0earmv7hflurch-purple-0.6.8nb5.tgz
NetBSD 9.0earmv7hflurch-purple-0.6.8nb6.tgz
NetBSD 9.0earmv7hflurch-purple-0.6.8nb6.tgz
NetBSD 9.0i386lurch-purple-0.6.8nb5.tgz
NetBSD 9.0i386lurch-purple-0.6.8nb6.tgz
NetBSD 9.0i386lurch-purple-0.6.8nb6.tgz
NetBSD 9.0mips64eblurch-purple-0.6.8nb6.tgz
NetBSD 9.0mips64eblurch-purple-0.6.8nb6.tgz
NetBSD 9.0sparc64lurch-purple-0.6.8nb6.tgz
NetBSD 9.0sparc64lurch-purple-0.6.8nb5.tgz
NetBSD 9.0sparc64lurch-purple-0.6.8nb6.tgz
NetBSD 9.0x86_64lurch-purple-0.6.8nb6.tgz
NetBSD 9.0x86_64lurch-purple-0.6.8nb6.tgz
NetBSD 9.0x86_64lurch-purple-0.6.8nb6.tgz
NetBSD 9.0x86_64lurch-purple-0.6.8nb6.tgz
NetBSD 9.0x86_64lurch-purple-0.6.8nb5.tgz
NetBSD 9.0x86_64lurch-purple-0.6.8nb6.tgz
NetBSD 9.0x86_64lurch-purple-0.6.8nb6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.