biology/gnome-chemistry-utils - The NetBSD Packages Collection

GChemPaint, a 2D chemical editor and other programs

GChemPaint, a 2D chemical editor and some other programs related to chemistry
suitable for the GNOME desktop.

The Gnome Chemistry Utils include three utilities:
- a 2D chemical editor (GChemPaint).
- a chemical calculator (computes raw formule, molar weight, mass composition,
  etc..) and isotopic pattern).
- a molecule 3d viewer using OpenGL to display molecular models.
- a crystal structues viewer and editor.
- a periodic table of the elements.
- a spectrum viewer.

These programs are based on an included C++ library which provides a few
widgets and various classes, some related to chemistry and some utility
classes.

Build dependencies

pkgtools/x11-links textproc/gnome-doc-utils x11/xorgproto x11/xcb-proto math/eigen2 pkgtools/cwrappers devel/glib2-tools devel/libtool-base textproc/intltool devel/gmake lang/perl5 devel/pkgconf

Runtime dependencies

graphics/hicolor-icon-theme databases/shared-mime-info databases/gnome-mime-data graphics/gtkglext misc/goffice0.10 x11/gtk3 sysutils/desktop-file-utils biology/chemical-mime-data biology/bodr biology/openbabel textproc/rarian graphics/hicolor-icon-theme databases/shared-mime-info databases/gnome-mime-data graphics/gtkglext misc/goffice0.10 x11/gtk3 sysutils/desktop-file-utils biology/openbabel

Available binary packages

aarch64:gnome-chemistry-utils-0.14.16nb4.tgz(NetBSD 9.0)
i386:gnome-chemistry-utils-0.14.16nb4.tgz(NetBSD 9.0)
x86_64:gnome-chemistry-utils-0.14.16nb4.tgz(NetBSD 9.0)
x86_64:gnome-chemistry-utils-0.14.16nb4.tgz(NetBSD 9.0)
x86_64:gnome-chemistry-utils-0.14.16nb4.tgz(NetBSD 9.0)
x86_64:gnome-chemistry-utils-0.14.16nb3.tgz(NetBSD 9.0)
x86_64:gnome-chemistry-utils-0.14.16nb4.tgz(NetBSD 9.0)
x86_64:gnome-chemistry-utils-0.14.16nb4.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]