archivers/ark - The NetBSD Packages Collection

Manages various archive formats within the KDE environment

Ark is a program for managing various archive formats within the KDE
environment.

Archives can be viewed, extracted, created and modified from within Ark.
The program can handle various formats such as tar, gzip, bzip2, zip, rar
and lha (if appropriate command-line programs are installed).

Build dependencies

devel/extra-cmake-modules devel/kdoctools pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/cmake

Runtime dependencies

security/gnupg2 archivers/libzip devel/kitemmodels x11/qt5-qtbase devel/kparts devel/kpty graphics/hicolor-icon-theme sysutils/desktop-file-utils archivers/libzip devel/kitemmodels x11/qt5-qtbase devel/kparts devel/kpty graphics/hicolor-icon-theme sysutils/desktop-file-utils

Binary packages

OSArchitectureVersion
NetBSD 8.0i386ark-20.04.1nb3.tgz
NetBSD 8.0powerpcark-20.04.1nb3.tgz
NetBSD 8.0powerpcark-20.04.1nb8.tgz
NetBSD 8.0powerpcark-20.04.1nb8.tgz
NetBSD 8.0x86_64ark-20.04.1nb8.tgz
NetBSD 8.0x86_64ark-20.04.1nb3.tgz
NetBSD 8.0x86_64ark-20.04.1nb5.tgz
NetBSD 9.0aarch64ark-20.04.1nb8.tgz
NetBSD 9.0aarch64ark-20.04.1nb3.tgz
NetBSD 9.0aarch64ark-20.04.1nb5.tgz
NetBSD 9.0earmv7hfark-20.04.1nb3.tgz
NetBSD 9.0i386ark-20.04.1nb3.tgz
NetBSD 9.0i386ark-20.04.1nb5.tgz
NetBSD 9.0i386ark-20.04.1nb8.tgz
NetBSD 9.0powerpcark-20.04.1nb5.tgz
NetBSD 9.0sparc64ark-20.04.1nb8.tgz
NetBSD 9.0sparc64ark-20.04.1.tgz
NetBSD 9.0sparc64ark-20.04.1nb3.tgz
NetBSD 9.0x86_64ark-20.04.1nb4.tgz
NetBSD 9.0x86_64ark-20.04.1nb7.tgz
NetBSD 9.0x86_64ark-20.04.1nb7.tgz
NetBSD 9.0x86_64ark-20.04.1nb8.tgz
NetBSD 9.0x86_64ark-20.04.1nb3.tgz
NetBSD 9.0x86_64ark-20.04.1nb5.tgz
NetBSD 9.0x86_64ark-20.04.1nb8.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.