Daemon Power

The NetBSD Packages Collection: www/webby

Brief description of the package:
Static web page generator

Please read the file "DESCR" for a longer description, or browse the package's history.

Please note that this package has a mit license.

The package is located in the "www/webby" directory. The current source version of the package is "ruby23-webby-0.9.4nb1". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for www/webby :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: ruby23-directory-watcher>=1.1.2 ruby23-base>=2.3.5 libyaml>=0.1.1 cwrappers>=20150314 libyaml>=0.1.4 ruby23-hpricot>=0.6.0 ruby23-launchy>=0.3.2 ruby23-addressable>=2.3<3 ruby23-public_suffix>=2.0.2 ruby23-logging>=0.9.7 ruby23-little-plugger>=1.1.3 ruby23-multi_json>=1.10 ruby23-loquacious>=1.3.0 ruby23-rspec>=1.2.2 ruby23-rspec-core>=3.6.0<3.7 ruby23-rspec-support>=3.6.0<3.7 ruby23-rspec-expectations>=3.6.0<3.7 ruby23-diff-lcs<2 ruby23-rspec-mocks>=3.6.0<3.7 .

This package requires the following package(s) to run: ruby23-directory-watcher>=1.1.2 ruby23-base>=2.3.5 libyaml>=0.1.1 libyaml>=0.1.4 ruby23-hpricot>=0.6.0 ruby23-launchy>=0.3.2 ruby23-addressable>=2.3<3 ruby23-public_suffix>=2.0.2 ruby23-logging>=0.9.7 ruby23-little-plugger>=1.1.3 ruby23-multi_json>=1.10 ruby23-loquacious>=1.3.0 ruby23-rspec>=1.2.2 ruby23-rspec-core>=3.6.0<3.7 ruby23-rspec-support>=3.6.0<3.7 ruby23-rspec-expectations>=3.6.0<3.7 ruby23-diff-lcs<2 ruby23-rspec-mocks>=3.6.0<3.7 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:ruby21-webby-0.9.4nb1.tgz(NetBSD 7.0)
alpha:ruby22-webby-0.9.4nb1.tgz(NetBSD 7.0)
alpha:ruby23-webby-0.9.4nb1.tgz(NetBSD 7.0)
alpha:ruby22-webby-0.9.4nb1.tgz(NetBSD 8.0)
alpha:ruby23-webby-0.9.4nb1.tgz(NetBSD 8.0)
alpha:ruby24-webby-0.9.4nb1.tgz(NetBSD 8.0)
arm:ruby200-webby-0.9.4nb1.tgz(NetBSD 6.1_STABLE)
earm:ruby200-webby-0.9.4nb1.tgz(NetBSD 7.0)
earm:ruby22-webby-0.9.4nb1.tgz(NetBSD 7.0)
earmv6hf:ruby193-webby-0.9.4nb1.tgz(NetBSD 7.0)
earmv6hf:ruby200-webby-0.9.4nb1.tgz(NetBSD 7.0)
earmv6hf:ruby21-webby-0.9.4nb1.tgz(NetBSD 7.0)
earmv6hf:ruby22-webby-0.9.4nb1.tgz(NetBSD 7.0)
earmv6hf:ruby200-webby-0.9.4nb1.tgz(NetBSD 7.0)
earmv6hf:ruby21-webby-0.9.4nb1.tgz(NetBSD 7.0)
earmv6hf:ruby22-webby-0.9.4nb1.tgz(NetBSD 7.0)
earmv7hf:ruby200-webby-0.9.4nb1.tgz(NetBSD 7.0)
earmv7hf:ruby21-webby-0.9.4nb1.tgz(NetBSD 7.0)
earmv7hf:ruby22-webby-0.9.4nb1.tgz(NetBSD 7.0)
earmv7hf:ruby193-webby-0.9.4nb1.tgz(NetBSD 7.0)
earmv7hf:ruby200-webby-0.9.4nb1.tgz(NetBSD 7.0)
earmv7hf:ruby21-webby-0.9.4nb1.tgz(NetBSD 7.0)
earmv7hf:ruby22-webby-0.9.4nb1.tgz(NetBSD 7.0)
earmv7hf:ruby22-webby-0.9.4nb1.tgz(NetBSD 8.0_BETA)
earmv7hf:ruby23-webby-0.9.4nb1.tgz(NetBSD 8.0_BETA)
i386:ruby18-webby-0.9.4nb1.tgz(MirBSD 10)
i386:ruby200-webby-0.9.4nb1.tgz(MirBSD 10)
i386:ruby22-webby-0.9.4nb1.tgz(NetBSD 6.0)
i386:ruby23-webby-0.9.4nb1.tgz(NetBSD 6.0)
i386:ruby24-webby-0.9.4nb1.tgz(NetBSD 6.0)
i386:ruby21-webby-0.9.4nb1.tgz(NetBSD 6.0)
i386:ruby22-webby-0.9.4nb1.tgz(NetBSD 6.0)
i386:ruby23-webby-0.9.4nb1.tgz(NetBSD 6.0)
i386:ruby21-webby-0.9.4nb1.tgz(NetBSD 6.0)
i386:ruby22-webby-0.9.4nb1.tgz(NetBSD 6.0)
i386:ruby23-webby-0.9.4nb1.tgz(NetBSD 6.0)
i386:ruby21-webby-0.9.4nb1.tgz(NetBSD 6.0)
i386:ruby22-webby-0.9.4nb1.tgz(NetBSD 6.0)
i386:ruby23-webby-0.9.4nb1.tgz(NetBSD 6.0)
i386:ruby22-webby-0.9.4nb1.tgz(NetBSD 6.0)
i386:ruby23-webby-0.9.4nb1.tgz(NetBSD 6.0)
i386:ruby24-webby-0.9.4nb1.tgz(NetBSD 6.0)
i386:ruby22-webby-0.9.4nb1.tgz(NetBSD 6.1)
i386:ruby23-webby-0.9.4nb1.tgz(NetBSD 6.1)
i386:ruby24-webby-0.9.4nb1.tgz(NetBSD 6.1)
i386:ruby21-webby-0.9.4nb1.tgz(NetBSD 6.1)
i386:ruby22-webby-0.9.4nb1.tgz(NetBSD 6.1)
i386:ruby23-webby-0.9.4nb1.tgz(NetBSD 6.1)
i386:ruby21-webby-0.9.4nb1.tgz(NetBSD 6.1)
i386:ruby22-webby-0.9.4nb1.tgz(NetBSD 6.1)
i386:ruby23-webby-0.9.4nb1.tgz(NetBSD 6.1)
i386:ruby21-webby-0.9.4nb1.tgz(NetBSD 6.1)
i386:ruby22-webby-0.9.4nb1.tgz(NetBSD 6.1)
i386:ruby23-webby-0.9.4nb1.tgz(NetBSD 6.1)
i386:ruby22-webby-0.9.4nb1.tgz(NetBSD 6.1)
i386:ruby23-webby-0.9.4nb1.tgz(NetBSD 6.1)
i386:ruby24-webby-0.9.4nb1.tgz(NetBSD 6.1)
i386:ruby22-webby-0.9.4nb1.tgz(NetBSD 7.0)
i386:ruby23-webby-0.9.4nb1.tgz(NetBSD 7.0)
i386:ruby24-webby-0.9.4nb1.tgz(NetBSD 7.0)
i386:ruby21-webby-0.9.4nb1.tgz(NetBSD 7.0)
i386:ruby22-webby-0.9.4nb1.tgz(NetBSD 7.0)
i386:ruby23-webby-0.9.4nb1.tgz(NetBSD 7.0)
i386:ruby21-webby-0.9.4nb1.tgz(NetBSD 7.0)
i386:ruby22-webby-0.9.4nb1.tgz(NetBSD 7.0)
i386:ruby23-webby-0.9.4nb1.tgz(NetBSD 7.0)
i386:ruby21-webby-0.9.4nb1.tgz(NetBSD 7.0)
i386:ruby22-webby-0.9.4nb1.tgz(NetBSD 7.0)
i386:ruby23-webby-0.9.4nb1.tgz(NetBSD 7.0)
i386:ruby22-webby-0.9.4nb1.tgz(NetBSD 7.0)
i386:ruby23-webby-0.9.4nb1.tgz(NetBSD 7.0)
i386:ruby24-webby-0.9.4nb1.tgz(NetBSD 7.0)
i386:ruby18-webby-0.9.4nb1.tgz(QNX 6.5.0)
i386:ruby19-webby-0.9.4nb1.tgz(QNX 6.5.0)
powerpc:ruby24-webby-0.9.4nb1.tgz(NetBSD 6.1)
powerpc:ruby21-webby-0.9.4nb1.tgz(NetBSD 7.1)
powerpc:ruby22-webby-0.9.4nb1.tgz(NetBSD 7.1)
powerpc:ruby23-webby-0.9.4nb1.tgz(NetBSD 7.1)
powerpc:ruby24-webby-0.9.4nb1.tgz(NetBSD 7.1)
powerpc:ruby21-webby-0.9.4nb1.tgz(NetBSD 7.1)
powerpc:ruby22-webby-0.9.4nb1.tgz(NetBSD 7.1)
powerpc:ruby23-webby-0.9.4nb1.tgz(NetBSD 7.1)
powerpc:ruby24-webby-0.9.4nb1.tgz(NetBSD 7.1)
powerpc:ruby22-webby-0.9.4nb1.tgz(NetBSD 8.0)
powerpc:ruby23-webby-0.9.4nb1.tgz(NetBSD 8.0)
powerpc:ruby24-webby-0.9.4nb1.tgz(NetBSD 8.0)
powerpc:ruby22-webby-0.9.4nb1.tgz(NetBSD 8.0)
powerpc:ruby23-webby-0.9.4nb1.tgz(NetBSD 8.0)
powerpc:ruby24-webby-0.9.4nb1.tgz(NetBSD 8.0)
sparc:ruby193-webby-0.9.4nb1.tgz(NetBSD 5.1)
sparc:ruby193-webby-0.9.4nb1.tgz(NetBSD 5.1)
sparc:ruby200-webby-0.9.4nb1.tgz(NetBSD 6.0)
x86_64:ruby22-webby-0.9.4nb1.tgz(NetBSD 6.0)
x86_64:ruby23-webby-0.9.4nb1.tgz(NetBSD 6.0)
x86_64:ruby24-webby-0.9.4nb1.tgz(NetBSD 6.0)
x86_64:ruby21-webby-0.9.4nb1.tgz(NetBSD 6.0)
x86_64:ruby22-webby-0.9.4nb1.tgz(NetBSD 6.0)
x86_64:ruby23-webby-0.9.4nb1.tgz(NetBSD 6.0)
x86_64:ruby21-webby-0.9.4nb1.tgz(NetBSD 6.0)
x86_64:ruby22-webby-0.9.4nb1.tgz(NetBSD 6.0)
x86_64:ruby23-webby-0.9.4nb1.tgz(NetBSD 6.0)
x86_64:ruby21-webby-0.9.4nb1.tgz(NetBSD 6.0)
x86_64:ruby22-webby-0.9.4nb1.tgz(NetBSD 6.0)
x86_64:ruby23-webby-0.9.4nb1.tgz(NetBSD 6.0)
x86_64:ruby22-webby-0.9.4nb1.tgz(NetBSD 6.0)
x86_64:ruby23-webby-0.9.4nb1.tgz(NetBSD 6.0)
x86_64:ruby24-webby-0.9.4nb1.tgz(NetBSD 6.0)
x86_64:ruby22-webby-0.9.4nb1.tgz(NetBSD 6.1)
x86_64:ruby23-webby-0.9.4nb1.tgz(NetBSD 6.1)
x86_64:ruby24-webby-0.9.4nb1.tgz(NetBSD 6.1)
x86_64:ruby21-webby-0.9.4nb1.tgz(NetBSD 6.1)
x86_64:ruby22-webby-0.9.4nb1.tgz(NetBSD 6.1)
x86_64:ruby23-webby-0.9.4nb1.tgz(NetBSD 6.1)
x86_64:ruby21-webby-0.9.4nb1.tgz(NetBSD 6.1)
x86_64:ruby22-webby-0.9.4nb1.tgz(NetBSD 6.1)
x86_64:ruby23-webby-0.9.4nb1.tgz(NetBSD 6.1)
x86_64:ruby21-webby-0.9.4nb1.tgz(NetBSD 6.1)
x86_64:ruby22-webby-0.9.4nb1.tgz(NetBSD 6.1)
x86_64:ruby23-webby-0.9.4nb1.tgz(NetBSD 6.1)
x86_64:ruby22-webby-0.9.4nb1.tgz(NetBSD 6.1)
x86_64:ruby23-webby-0.9.4nb1.tgz(NetBSD 6.1)
x86_64:ruby24-webby-0.9.4nb1.tgz(NetBSD 6.1)
x86_64:ruby22-webby-0.9.4nb1.tgz(NetBSD 7.0)
x86_64:ruby23-webby-0.9.4nb1.tgz(NetBSD 7.0)
x86_64:ruby24-webby-0.9.4nb1.tgz(NetBSD 7.0)
x86_64:ruby21-webby-0.9.4nb1.tgz(NetBSD 7.0)
x86_64:ruby22-webby-0.9.4nb1.tgz(NetBSD 7.0)
x86_64:ruby23-webby-0.9.4nb1.tgz(NetBSD 7.0)
x86_64:ruby21-webby-0.9.4nb1.tgz(NetBSD 7.0)
x86_64:ruby22-webby-0.9.4nb1.tgz(NetBSD 7.0)
x86_64:ruby23-webby-0.9.4nb1.tgz(NetBSD 7.0)
x86_64:ruby21-webby-0.9.4nb1.tgz(NetBSD 7.0)
x86_64:ruby22-webby-0.9.4nb1.tgz(NetBSD 7.0)
x86_64:ruby23-webby-0.9.4nb1.tgz(NetBSD 7.0)
x86_64:ruby22-webby-0.9.4nb1.tgz(NetBSD 7.0)
x86_64:ruby23-webby-0.9.4nb1.tgz(NetBSD 7.0)
x86_64:ruby24-webby-0.9.4nb1.tgz(NetBSD 7.0)
x86_64:ruby22-webby-0.9.4nb1.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby23-webby-0.9.4nb1.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby24-webby-0.9.4nb1.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby22-webby-0.9.4nb1.tgz(NetBSD 8.99.1)
x86_64:ruby23-webby-0.9.4nb1.tgz(NetBSD 8.99.1)
x86_64:ruby24-webby-0.9.4nb1.tgz(NetBSD 8.99.1)
x86_64:ruby22-webby-0.9.4nb1.tgz(NetBSD 8.99.1)
x86_64:ruby23-webby-0.9.4nb1.tgz(NetBSD 8.99.1)
x86_64:ruby24-webby-0.9.4nb1.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]