Daemon Power

The NetBSD Packages Collection: www/thoth

Brief description of the package:
Minimalistic blog engine

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://github.com/rgrove/thoth.

Please note that this package has a modified-bsd license.

The package is located in the "www/thoth" directory. The current source version of the package is "ruby26-thoth-0.2.1nb5". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for www/thoth :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: ruby26-ramaze>=2008.06 ruby26-innate>=2012.12 ruby26-rack16>=1.6.4<1.7 ruby26-base>=2.6.6 libyaml>=0.1.1 cwrappers>=20150314 libyaml>=0.1.4 ruby26-erubis>=2.7.0<3 ruby26-builder>=2.1.2 ruby26-configuration>=0.0.5 ruby26-cssmin>=1.0.2<1.1 ruby26-hpricot>=0.6<1 ruby26-jsmin>=1.0.0<1.1 ruby26-redcloth>=4.0.3 ruby26-sequel>=2.5.0 ruby26-thin>=0.8.2 ruby26-rack16>=1.6.0 ruby26-daemons>=1.0.9 ruby26-eventmachine>=1.0.4 .

This package requires the following package(s) to run: ruby26-ramaze>=2008.06 ruby26-innate>=2012.12 ruby26-rack16>=1.6.4<1.7 ruby26-base>=2.6.6 libyaml>=0.1.1 libyaml>=0.1.4 ruby26-erubis>=2.7.0<3 ruby26-builder>=2.1.2 ruby26-configuration>=0.0.5 ruby26-cssmin>=1.0.2<1.1 ruby26-hpricot>=0.6<1 ruby26-jsmin>=1.0.0<1.1 ruby26-redcloth>=4.0.3 ruby26-sequel>=2.5.0 ruby26-thin>=0.8.2 ruby26-rack16>=1.6.0 ruby26-daemons>=1.0.9 ruby26-eventmachine>=1.0.4 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
aarch64:ruby25-thoth-0.2.1nb5.tgz(NetBSD 9.0)
aarch64:ruby26-thoth-0.2.1nb5.tgz(NetBSD 9.0)
aarch64:ruby27-thoth-0.2.1nb5.tgz(NetBSD 9.0)
aarch64:ruby24-thoth-0.2.1nb5.tgz(NetBSD 9.0)
aarch64:ruby25-thoth-0.2.1nb5.tgz(NetBSD 9.0)
aarch64:ruby26-thoth-0.2.1nb5.tgz(NetBSD 9.0)
aarch64:ruby27-thoth-0.2.1nb5.tgz(NetBSD 9.0)
alpha:ruby24-thoth-0.2.1nb5.tgz(NetBSD 8.0)
alpha:ruby25-thoth-0.2.1nb5.tgz(NetBSD 8.0)
alpha:ruby26-thoth-0.2.1nb5.tgz(NetBSD 8.0)
alpha:ruby24-thoth-0.2.1nb5.tgz(NetBSD 9.0)
alpha:ruby25-thoth-0.2.1nb5.tgz(NetBSD 9.0)
alpha:ruby26-thoth-0.2.1nb5.tgz(NetBSD 9.0)
earm:ruby200-thoth-0.2.1nb4.tgz(NetBSD 7.0)
earm:ruby21-thoth-0.2.1nb4.tgz(NetBSD 7.0)
earm:ruby22-thoth-0.2.1nb4.tgz(NetBSD 7.0)
earm:ruby22-thoth-0.2.1nb5.tgz(NetBSD 8.0)
earm:ruby22-thoth-0.2.1nb5.tgz(NetBSD 8.0)
earmv6hf:ruby24-thoth-0.2.1nb5.tgz(NetBSD 8.0)
earmv6hf:ruby25-thoth-0.2.1nb5.tgz(NetBSD 8.0)
earmv6hf:ruby26-thoth-0.2.1nb5.tgz(NetBSD 8.0)
earmv6hf:ruby24-thoth-0.2.1nb5.tgz(NetBSD 9.0)
earmv6hf:ruby25-thoth-0.2.1nb5.tgz(NetBSD 9.0)
earmv6hf:ruby26-thoth-0.2.1nb5.tgz(NetBSD 9.0)
earmv7hf:ruby24-thoth-0.2.1nb5.tgz(NetBSD 8.0)
earmv7hf:ruby25-thoth-0.2.1nb5.tgz(NetBSD 8.0)
earmv7hf:ruby26-thoth-0.2.1nb5.tgz(NetBSD 8.0)
earmv7hf:ruby27-thoth-0.2.1nb5.tgz(NetBSD 8.0)
earmv7hf:ruby24-thoth-0.2.1nb5.tgz(NetBSD 8.0)
earmv7hf:ruby25-thoth-0.2.1nb5.tgz(NetBSD 8.0)
earmv7hf:ruby26-thoth-0.2.1nb5.tgz(NetBSD 8.0)
earmv7hf:ruby25-thoth-0.2.1nb5.tgz(NetBSD 8.0)
earmv7hf:ruby26-thoth-0.2.1nb5.tgz(NetBSD 8.0)
earmv7hf:ruby27-thoth-0.2.1nb5.tgz(NetBSD 8.0)
earmv7hf:ruby24-thoth-0.2.1nb5.tgz(NetBSD 9.0)
earmv7hf:ruby25-thoth-0.2.1nb5.tgz(NetBSD 9.0)
earmv7hf:ruby26-thoth-0.2.1nb5.tgz(NetBSD 9.0)
earmv7hf:ruby27-thoth-0.2.1nb5.tgz(NetBSD 9.0)
earmv7hf:ruby24-thoth-0.2.1nb5.tgz(NetBSD 9.0)
earmv7hf:ruby25-thoth-0.2.1nb5.tgz(NetBSD 9.0)
earmv7hf:ruby26-thoth-0.2.1nb5.tgz(NetBSD 9.0)
earmv7hf:ruby25-thoth-0.2.1nb5.tgz(NetBSD 9.0)
earmv7hf:ruby26-thoth-0.2.1nb5.tgz(NetBSD 9.0)
earmv7hf:ruby27-thoth-0.2.1nb5.tgz(NetBSD 9.0)
i386:ruby18-thoth-0.2.1nb3.tgz(MirBSD 10)
i386:ruby193-thoth-0.2.1nb3.tgz(MirBSD 10)
i386:ruby200-thoth-0.2.1nb3.tgz(MirBSD 10)
i386:ruby24-thoth-0.2.1nb5.tgz(NetBSD 9.0)
i386:ruby25-thoth-0.2.1nb5.tgz(NetBSD 9.0)
i386:ruby26-thoth-0.2.1nb5.tgz(NetBSD 9.0)
i386:ruby27-thoth-0.2.1nb5.tgz(NetBSD 9.0)
i386:ruby24-thoth-0.2.1nb5.tgz(NetBSD 7.0)
i386:ruby25-thoth-0.2.1nb5.tgz(NetBSD 7.0)
i386:ruby24-thoth-0.2.1nb5.tgz(NetBSD 7.0)
i386:ruby25-thoth-0.2.1nb5.tgz(NetBSD 7.0)
i386:ruby24-thoth-0.2.1nb5.tgz(NetBSD 7.1)
i386:ruby25-thoth-0.2.1nb5.tgz(NetBSD 7.1)
i386:ruby24-thoth-0.2.1nb5.tgz(NetBSD 7.1)
i386:ruby25-thoth-0.2.1nb5.tgz(NetBSD 7.1)
i386:ruby24-thoth-0.2.1nb5.tgz(NetBSD 7.1)
i386:ruby25-thoth-0.2.1nb5.tgz(NetBSD 7.1)
i386:ruby25-thoth-0.2.1nb5.tgz(NetBSD 7.1)
i386:ruby25-thoth-0.2.1nb5.tgz(NetBSD 8.0)
i386:ruby26-thoth-0.2.1nb5.tgz(NetBSD 8.0)
i386:ruby27-thoth-0.2.1nb5.tgz(NetBSD 8.0)
i386:ruby24-thoth-0.2.1nb5.tgz(NetBSD 8.0)
i386:ruby25-thoth-0.2.1nb5.tgz(NetBSD 8.0)
i386:ruby26-thoth-0.2.1nb5.tgz(NetBSD 8.0)
i386:ruby24-thoth-0.2.1nb5.tgz(NetBSD 8.0)
i386:ruby25-thoth-0.2.1nb5.tgz(NetBSD 8.0)
i386:ruby26-thoth-0.2.1nb5.tgz(NetBSD 8.0)
i386:ruby24-thoth-0.2.1nb5.tgz(NetBSD 8.0)
i386:ruby25-thoth-0.2.1nb5.tgz(NetBSD 8.0)
i386:ruby26-thoth-0.2.1nb5.tgz(NetBSD 8.0)
i386:ruby27-thoth-0.2.1nb5.tgz(NetBSD 8.0)
i386:ruby25-thoth-0.2.1nb5.tgz(NetBSD 9.0)
i386:ruby26-thoth-0.2.1nb5.tgz(NetBSD 9.0)
i386:ruby27-thoth-0.2.1nb5.tgz(NetBSD 9.0)
i386:ruby24-thoth-0.2.1nb5.tgz(NetBSD 9.0)
i386:ruby25-thoth-0.2.1nb5.tgz(NetBSD 9.0)
i386:ruby26-thoth-0.2.1nb5.tgz(NetBSD 9.0)
i386:ruby24-thoth-0.2.1nb5.tgz(NetBSD 9.0)
i386:ruby25-thoth-0.2.1nb5.tgz(NetBSD 9.0)
i386:ruby26-thoth-0.2.1nb5.tgz(NetBSD 9.0)
i386:ruby27-thoth-0.2.1nb5.tgz(NetBSD 9.0)
i386:ruby18-thoth-0.2.1nb1.tgz(QNX 6.5.0)
i386:ruby19-thoth-0.2.1nb1.tgz(QNX 6.5.0)
mips64eb:ruby24-thoth-0.2.1nb5.tgz(NetBSD 9.0)
mips64eb:ruby25-thoth-0.2.1nb5.tgz(NetBSD 9.0)
mips64eb:ruby26-thoth-0.2.1nb5.tgz(NetBSD 9.0)
powerpc:ruby22-thoth-0.2.1nb5.tgz(NetBSD 7.1)
powerpc:ruby23-thoth-0.2.1nb5.tgz(NetBSD 7.1)
powerpc:ruby24-thoth-0.2.1nb5.tgz(NetBSD 7.1)
powerpc:ruby25-thoth-0.2.1nb5.tgz(NetBSD 7.1)
powerpc:ruby24-thoth-0.2.1nb5.tgz(NetBSD 8.0)
powerpc:ruby25-thoth-0.2.1nb5.tgz(NetBSD 8.0)
powerpc:ruby26-thoth-0.2.1nb5.tgz(NetBSD 8.0)
powerpc:ruby24-thoth-0.2.1nb5.tgz(NetBSD 9.0)
powerpc:ruby25-thoth-0.2.1nb5.tgz(NetBSD 9.0)
powerpc:ruby26-thoth-0.2.1nb5.tgz(NetBSD 9.0)
sparc64:ruby22-thoth-0.2.1nb5.tgz(NetBSD 7.1)
sparc64:ruby23-thoth-0.2.1nb5.tgz(NetBSD 7.1)
sparc64:ruby24-thoth-0.2.1nb5.tgz(NetBSD 7.1)
sparc64:ruby25-thoth-0.2.1nb5.tgz(NetBSD 7.1)
sparc64:ruby24-thoth-0.2.1nb5.tgz(NetBSD 8.0)
sparc64:ruby25-thoth-0.2.1nb5.tgz(NetBSD 8.0)
sparc64:ruby26-thoth-0.2.1nb5.tgz(NetBSD 8.0)
sparc64:ruby24-thoth-0.2.1nb5.tgz(NetBSD 9.0)
sparc64:ruby25-thoth-0.2.1nb5.tgz(NetBSD 9.0)
sparc64:ruby26-thoth-0.2.1nb5.tgz(NetBSD 9.0)
sparc:ruby24-thoth-0.2.1nb5.tgz(NetBSD 8.0)
sparc:ruby25-thoth-0.2.1nb5.tgz(NetBSD 8.0)
x86_64:ruby25-thoth-0.2.1nb5.tgz(NetBSD 9.0)
x86_64:ruby26-thoth-0.2.1nb5.tgz(NetBSD 9.0)
x86_64:ruby27-thoth-0.2.1nb5.tgz(NetBSD 9.0)
x86_64:ruby25-thoth-0.2.1nb5.tgz(NetBSD 9.0)
x86_64:ruby26-thoth-0.2.1nb5.tgz(NetBSD 9.0)
x86_64:ruby27-thoth-0.2.1nb5.tgz(NetBSD 9.0)
x86_64:ruby24-thoth-0.2.1nb5.tgz(NetBSD 7.0)
x86_64:ruby25-thoth-0.2.1nb5.tgz(NetBSD 7.0)
x86_64:ruby24-thoth-0.2.1nb5.tgz(NetBSD 7.0)
x86_64:ruby25-thoth-0.2.1nb5.tgz(NetBSD 7.0)
x86_64:ruby25-thoth-0.2.1nb5.tgz(NetBSD 7.1)
x86_64:ruby24-thoth-0.2.1nb5.tgz(NetBSD 7.1)
x86_64:ruby25-thoth-0.2.1nb5.tgz(NetBSD 7.1)
x86_64:ruby24-thoth-0.2.1nb5.tgz(NetBSD 7.1)
x86_64:ruby25-thoth-0.2.1nb5.tgz(NetBSD 7.1)
x86_64:ruby24-thoth-0.2.1nb5.tgz(NetBSD 7.1)
x86_64:ruby25-thoth-0.2.1nb5.tgz(NetBSD 7.1)
x86_64:ruby24-thoth-0.2.1nb5.tgz(NetBSD 8.0)
x86_64:ruby25-thoth-0.2.1nb5.tgz(NetBSD 8.0)
x86_64:ruby26-thoth-0.2.1nb5.tgz(NetBSD 8.0)
x86_64:ruby27-thoth-0.2.1nb5.tgz(NetBSD 8.0)
x86_64:ruby24-thoth-0.2.1nb5.tgz(NetBSD 8.0)
x86_64:ruby25-thoth-0.2.1nb5.tgz(NetBSD 8.0)
x86_64:ruby26-thoth-0.2.1nb5.tgz(NetBSD 8.0)
x86_64:ruby24-thoth-0.2.1nb5.tgz(NetBSD 8.0)
x86_64:ruby25-thoth-0.2.1nb5.tgz(NetBSD 8.0)
x86_64:ruby26-thoth-0.2.1nb5.tgz(NetBSD 8.0)
x86_64:ruby25-thoth-0.2.1nb5.tgz(NetBSD 8.0)
x86_64:ruby26-thoth-0.2.1nb5.tgz(NetBSD 8.0)
x86_64:ruby27-thoth-0.2.1nb5.tgz(NetBSD 8.0)
x86_64:ruby25-thoth-0.2.1nb5.tgz(NetBSD 9.0)
x86_64:ruby26-thoth-0.2.1nb5.tgz(NetBSD 9.0)
x86_64:ruby27-thoth-0.2.1nb5.tgz(NetBSD 9.0)
x86_64:ruby24-thoth-0.2.1nb5.tgz(NetBSD 9.0)
x86_64:ruby25-thoth-0.2.1nb5.tgz(NetBSD 9.0)
x86_64:ruby26-thoth-0.2.1nb5.tgz(NetBSD 9.0)
x86_64:ruby24-thoth-0.2.1nb5.tgz(NetBSD 9.0)
x86_64:ruby25-thoth-0.2.1nb5.tgz(NetBSD 9.0)
x86_64:ruby26-thoth-0.2.1nb5.tgz(NetBSD 9.0)
x86_64:ruby27-thoth-0.2.1nb5.tgz(NetBSD 9.0)
x86_64:ruby25-thoth-0.2.1nb5.tgz(NetBSD 9.0)
x86_64:ruby26-thoth-0.2.1nb5.tgz(NetBSD 9.0)
x86_64:ruby27-thoth-0.2.1nb5.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]