www/swish-e - The NetBSD Packages Collection

Simple web indexing for humans - enhanced

SWISH-Enhanced is a fast, powerful, flexible, and easy to use system for
indexing collections of Web pages or other text files. Key features include
the ability to limit searches to certain HTML tags (META, TITLE, comments,
etc.). The SWISH-E software is free, and includes a package of Perl programs
that enable anyone who is authorized to create and maintain their own indexes
(AutoSwish). SWISH-E is an enhanced version of SWISH, which was originally
written by Kevin Hughes and modified and released with his permission.

Build dependencies

pkgtools/cwrappers devel/libtool-base

Runtime dependencies

lang/perl5 devel/pcre textproc/libxml2 devel/pcre textproc/libxml2

Available binary packages

aarch64:swish-e-2.4.5nb12.tgz(NetBSD 9.0)
aarch64:swish-e-2.4.5nb13.tgz(NetBSD 9.0)
aarch64:swish-e-2.4.5nb14.tgz(NetBSD 9.0)
alpha:swish-e-2.4.5nb14.tgz(NetBSD 9.0)
alpha:swish-e-2.4.5nb12.tgz(NetBSD 9.0)
alpha:swish-e-2.4.5nb13.tgz(NetBSD 9.0)
earm:swish-e-2.4.5nb13.tgz(NetBSD 9.0)
earm:swish-e-2.4.5nb11.tgz(NetBSD 9.0)
earmv6hf:swish-e-2.4.5nb14.tgz(NetBSD 9.0)
earmv6hf:swish-e-2.4.5nb12.tgz(NetBSD 9.0)
earmv6hf:swish-e-2.4.5nb13.tgz(NetBSD 9.0)
earmv6hf:swish-e-2.4.5nb14.tgz(NetBSD 9.0)
earmv7hf:swish-e-2.4.5nb14.tgz(NetBSD 8.0)
earmv7hf:swish-e-2.4.5nb11.tgz(NetBSD 8.0)
earmv7hf:swish-e-2.4.5nb12.tgz(NetBSD 8.0)
earmv7hf:swish-e-2.4.5nb13.tgz(NetBSD 8.0)
earmv7hf:swish-e-2.4.5nb14.tgz(NetBSD 9.0)
earmv7hf:swish-e-2.4.5nb11.tgz(NetBSD 9.0)
earmv7hf:swish-e-2.4.5nb12.tgz(NetBSD 9.0)
earmv7hf:swish-e-2.4.5nb13.tgz(NetBSD 9.0)
earmv7hf:swish-e-2.4.5nb14.tgz(NetBSD 9.0)
i386:swish-e-2.4.5nb12.tgz(NetBSD 8.0)
i386:swish-e-2.4.5nb13.tgz(NetBSD 8.0)
i386:swish-e-2.4.5nb14.tgz(NetBSD 8.0)
i386:swish-e-2.4.5nb12.tgz(NetBSD 9.0)
i386:swish-e-2.4.5nb13.tgz(NetBSD 9.0)
i386:swish-e-2.4.5nb14.tgz(NetBSD 9.0)
mips64eb:swish-e-2.4.5nb13.tgz(NetBSD 9.0)
mips64eb:swish-e-2.4.5nb14.tgz(NetBSD 9.0)
powerpc:swish-e-2.4.5nb14.tgz(NetBSD 8.0)
powerpc:swish-e-2.4.5nb13.tgz(NetBSD 8.0)
powerpc:swish-e-2.4.5nb13.tgz(NetBSD 9.0)
powerpc:swish-e-2.4.5nb12.tgz(NetBSD 9.0)
sparc64:swish-e-2.4.5nb14.tgz(NetBSD 9.0)
sparc64:swish-e-2.4.5nb12.tgz(NetBSD 9.0)
sparc64:swish-e-2.4.5nb13.tgz(NetBSD 9.0)
sparc:swish-e-2.4.5nb13.tgz(NetBSD 9.0)
sparc:swish-e-2.4.5nb12.tgz(NetBSD 9.0)
x86_64:swish-e-2.4.5nb14.tgz(NetBSD 9.0)
x86_64:swish-e-2.4.5nb14.tgz(NetBSD 9.0)
x86_64:swish-e-2.4.5nb14.tgz(NetBSD 9.0)
x86_64:swish-e-2.4.5nb13.tgz(NetBSD 9.0)
x86_64:swish-e-2.4.5nb13.tgz(NetBSD 8.0)
x86_64:swish-e-2.4.5nb12.tgz(NetBSD 8.0)
x86_64:swish-e-2.4.5nb14.tgz(NetBSD 8.0)
x86_64:swish-e-2.4.5nb12.tgz(NetBSD 9.0)
x86_64:swish-e-2.4.5nb13.tgz(NetBSD 9.0)
x86_64:swish-e-2.4.5nb14.tgz(NetBSD 9.0)
x86_64:swish-e-2.4.5nb14.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]