www/serf - The NetBSD Packages Collection

High-performance asynchronous HTTP client library

The serf library is a C-based HTTP client library built upon the Apache
Portable Runtime (APR) library. It multiplexes connections, running the
read/write communication asynchronously. Memory copies and transformations
are kept to a minimum to provide high-performance operation.

Build dependencies

lang/python38 lang/python38 devel/scons pkgtools/cwrappers

Runtime dependencies

devel/apr devel/apr-util devel/apr-util

Available binary packages

aarch64:serf-1.3.9nb1.tgz(NetBSD 9.0)
aarch64:serf-1.3.9nb1.tgz(NetBSD 9.0)
aarch64:serf-1.3.9nb1.tgz(NetBSD 9.0)
alpha:serf-1.3.9nb1.tgz(NetBSD 9.0)
alpha:serf-1.3.9nb1.tgz(NetBSD 9.0)
alpha:serf-1.3.9nb1.tgz(NetBSD 9.0)
earm:serf-1.3.9nb1.tgz(NetBSD 9.0)
earm:serf-1.3.9nb1.tgz(NetBSD 9.0)
earm:serf-1.3.9nb1.tgz(NetBSD 9.0)
earmv6hf:serf-1.3.9nb1.tgz(NetBSD 9.0)
earmv6hf:serf-1.3.9nb1.tgz(NetBSD 9.0)
earmv6hf:serf-1.3.9nb1.tgz(NetBSD 9.0)
earmv6hf:serf-1.3.9nb1.tgz(NetBSD 9.0)
earmv7hf:serf-1.3.9nb1.tgz(NetBSD 8.0)
earmv7hf:serf-1.3.9nb1.tgz(NetBSD 8.0)
earmv7hf:serf-1.3.9nb1.tgz(NetBSD 8.0)
earmv7hf:serf-1.3.9nb1.tgz(NetBSD 8.0)
earmv7hf:serf-1.3.9nb1.tgz(NetBSD 9.0)
earmv7hf:serf-1.3.9nb1.tgz(NetBSD 9.0)
earmv7hf:serf-1.3.9nb1.tgz(NetBSD 9.0)
earmv7hf:serf-1.3.9nb1.tgz(NetBSD 9.0)
earmv7hf:serf-1.3.9nb1.tgz(NetBSD 9.0)
i386:serf-1.3.9nb1.tgz(NetBSD 8.0)
i386:serf-1.3.9nb1.tgz(NetBSD 8.0)
i386:serf-1.3.9nb1.tgz(NetBSD 8.0)
i386:serf-1.3.9nb1.tgz(NetBSD 9.0)
i386:serf-1.3.9nb1.tgz(NetBSD 9.0)
i386:serf-1.3.9nb1.tgz(NetBSD 9.0)
m68k:serf-1.3.9nb1.tgz(NetBSD 9.0)
m68k:serf-1.3.9nb1.tgz(NetBSD 9.0)
mips64eb:serf-1.3.9nb1.tgz(NetBSD 9.0)
mips64eb:serf-1.3.9nb1.tgz(NetBSD 9.0)
mipsel:serf-1.3.9nb1.tgz(NetBSD 9.0)
powerpc:serf-1.3.9nb1.tgz(NetBSD 8.0)
powerpc:serf-1.3.9nb1.tgz(NetBSD 8.0)
powerpc:serf-1.3.9nb1.tgz(NetBSD 9.0)
powerpc:serf-1.3.9nb1.tgz(NetBSD 9.0)
sh3el:serf-1.3.9nb1.tgz(NetBSD 9.0)
sh3el:serf-1.3.9nb1.tgz(NetBSD 9.0)
sparc64:serf-1.3.9nb1.tgz(NetBSD 9.0)
sparc64:serf-1.3.9nb1.tgz(NetBSD 9.0)
sparc64:serf-1.3.9nb1.tgz(NetBSD 9.0)
sparc:serf-1.3.9nb1.tgz(NetBSD 9.0)
sparc:serf-1.3.9nb1.tgz(NetBSD 9.0)
x86_64:serf-1.3.9nb1.tgz(NetBSD 9.0)
x86_64:serf-1.3.9nb1.tgz(NetBSD 9.0)
x86_64:serf-1.3.9nb1.tgz(NetBSD 9.0)
x86_64:serf-1.3.9nb1.tgz(NetBSD 9.0)
x86_64:serf-1.3.9nb1.tgz(NetBSD 8.0)
x86_64:serf-1.3.9nb1.tgz(NetBSD 8.0)
x86_64:serf-1.3.9nb1.tgz(NetBSD 8.0)
x86_64:serf-1.3.9nb1.tgz(NetBSD 9.0)
x86_64:serf-1.3.9nb1.tgz(NetBSD 9.0)
x86_64:serf-1.3.9nb1.tgz(NetBSD 9.0)
x86_64:serf-1.3.9nb1.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

gssapi
Enable gssapi (Kerberos V) support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]