www/ruby-webkit-gtk2 - The NetBSD Packages Collection

Ruby binding of WebKitGTK+ for GTK2+

Ruby-GNOME is a set of Ruby language bindings for the various
application development libraries included with the GNOME/GTK+
environment.

Ruby/WebKitGTK2 is a Ruby binding of WebKitGTK+ for GTK+ 2.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

x11/ruby-gtk2 devel/ruby-gobject-introspection www/webkit24-gtk lang/ruby26-base

Available binary packages

i386:ruby25-webkit-gtk2-3.4.2.tgz(NetBSD 8.0)
i386:ruby26-webkit-gtk2-3.4.2.tgz(NetBSD 8.0)
i386:ruby27-webkit-gtk2-3.4.2.tgz(NetBSD 8.0)
i386:ruby25-webkit-gtk2-3.4.2.tgz(NetBSD 8.0)
i386:ruby26-webkit-gtk2-3.4.2.tgz(NetBSD 8.0)
i386:ruby27-webkit-gtk2-3.4.2.tgz(NetBSD 8.0)
i386:ruby25-webkit-gtk2-3.4.2.tgz(NetBSD 8.0)
i386:ruby26-webkit-gtk2-3.4.2.tgz(NetBSD 8.0)
i386:ruby27-webkit-gtk2-3.4.2.tgz(NetBSD 8.0)
i386:ruby25-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
i386:ruby26-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
i386:ruby27-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
i386:ruby25-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
i386:ruby26-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
i386:ruby27-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
i386:ruby25-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
i386:ruby26-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
i386:ruby27-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
powerpc:ruby25-webkit-gtk2-3.4.2.tgz(NetBSD 8.0)
powerpc:ruby26-webkit-gtk2-3.4.2.tgz(NetBSD 8.0)
powerpc:ruby27-webkit-gtk2-3.4.2.tgz(NetBSD 8.0)
powerpc:ruby25-webkit-gtk2-3.4.2.tgz(NetBSD 8.0)
powerpc:ruby26-webkit-gtk2-3.4.2.tgz(NetBSD 8.0)
powerpc:ruby27-webkit-gtk2-3.4.2.tgz(NetBSD 8.0)
powerpc:ruby25-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
powerpc:ruby26-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
powerpc:ruby27-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
powerpc:ruby25-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
powerpc:ruby26-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
powerpc:ruby27-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
sparc64:ruby25-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
sparc64:ruby26-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
sparc64:ruby27-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
sparc64:ruby25-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
sparc64:ruby26-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
sparc64:ruby27-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
sparc64:ruby25-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
sparc64:ruby26-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
sparc64:ruby27-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
sparc:ruby25-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby25-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby26-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby27-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby25-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby26-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby27-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby25-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby26-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby27-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby25-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby26-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby27-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby25-webkit-gtk2-3.4.2.tgz(NetBSD 8.0)
x86_64:ruby26-webkit-gtk2-3.4.2.tgz(NetBSD 8.0)
x86_64:ruby27-webkit-gtk2-3.4.2.tgz(NetBSD 8.0)
x86_64:ruby25-webkit-gtk2-3.4.2.tgz(NetBSD 8.0)
x86_64:ruby26-webkit-gtk2-3.4.2.tgz(NetBSD 8.0)
x86_64:ruby27-webkit-gtk2-3.4.2.tgz(NetBSD 8.0)
x86_64:ruby25-webkit-gtk2-3.4.2.tgz(NetBSD 8.0)
x86_64:ruby26-webkit-gtk2-3.4.2.tgz(NetBSD 8.0)
x86_64:ruby27-webkit-gtk2-3.4.2.tgz(NetBSD 8.0)
x86_64:ruby25-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby26-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby27-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby25-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby26-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby27-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby25-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby26-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby27-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby25-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby26-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby27-webkit-gtk2-3.4.2.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]